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Getting Started

The changes and enhancements in MicroSration V8 XM Edition are designed to add o the
capabilities of the V8 platform while providing & task-appropriate user experience

Installing MicroStation V8 XM Edition

You can install and run MicroStavon V8 XM Edition on the same workstation as a previous
version of MicroStation, such as MicroStation V8 2004 Editon. However, you should never
install MicroStation V8 XM Edition over an existing Microdtanon installation, whether that is
MicroStaton V8 2004 Edidon or an earlier release Install to a separate directory Also,
remember to always back up your data prior to installadon

Requirements

Hardware and sofrware reguirements have changed, so be sure to check the Reguirements
section of the product ReadMe for recommendations and prerequisites before installing Find
it in \Program Files\Bendey\MicroStaton

Oporating  Windows XP Prolecsonat
System  \Wandows KNP Frofessional rB2

Nengows KB Home Eddion
Windows 2080 Frolessiona! {SP5 o faten
Windows 2800 Server
Windows Sarver 2003 {SPY oriater)
Windows Servar 2003 164
Windowes MY Wingowe 9 608t ate ROt cupponad

thicipsolt omet Explorer v & o lates with 172000 cipher shienglh

Sofiwate  The AsroSiehion V& XA Edtiion Seftere Prereguate Fach vB3. G‘Q bs_rxnevds 10 ba installed 16 your wirkstanen prier to

Precequisites  the instalfahon of MicraSig 'an VE )iM Ed\l:un R 2T Slation VB W Bgiton Soltesre Fravequisie Paghiic
avaitable frem the el rew Chiliee The tontents of the AcroStarian V& !

Ediion Soltvisrs Preraguis

Windows tnstalier 3 17

Mitresolt MNET Framewod: 20
MEYIL & with Service Pack 2

VBB 4

Diracin 9o

BHTML Editing Contral for Apphcations

Impartant Hete: ftiersSistion VB X4 Etilon Sothwars Presoquisie Pack W(3.08.03 xx neede lo be installed prior 1o the
ingialiation of iicroStation VB W Sduion W3 BI.03 32 even i blicroStation v3 kit Edinon Sofwars Prerequisas Pack
JAG3 00 xx was previously instailed (o the same workstatien

MicroStation V8 XM Editon uses Windows Installer 2 0.

NieroSmdon VE XA Edigon Admin Copyrighe £ 3007 Bentley Sistems Incorporated D New Duplicae
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Instafling MicroStation V8 XM Edition

Desktop Analyzer

Download and run the Bentley Deskiop Analvzer to see if a system Is opdrmnized to run
MicroStation V8 XM Edition It will help vou find out if vour workstation is optimized to
rake advantage of the capabilities in MicroStadon V8 XM Edidon. Specifically, the new
Display Subsystem, which leverages Microsofts DirectN technology to oprimize view and
navigation petformance in 2D and 3D models

There is a link to the download in the ReadMe

Nofes:

Aljeradadon V8 XM Edidon Admin

120

Download it and install it oa the workstation on which vou intend to run MicroStation V8
XM Edition, following the instructions When you run it, it will examine your system for the

following information:
Operating system

System memory

Video card manufacturer

Video card RAM

DirectX installadon and version

NOTE: This urlity requires Microsoft NET Framewotk version 1 1, which can be
downloaded from the Microsoft Web site

To uninstall, go o the Windows Control Panel and then to Add/Remove programs Select

Bentley Deskiop Analyzer and select Remove.

Software prerequisite pack

This is a sedes of Miczosoft packages that must be instalied on a workstation prior to the
installadon of MicroStation V8 XM Editon or any of the MicroStation V8 XM Edition
derivartive products. For example, XML facilitates communication berween applications
DirectX provides enhanced graphics. If vou are nort sere a worksiation has ali of these
prerequisites, or if they are up o date, it is strongly recommended thar you inswuall the software
prerequisite pack prior to installing MicroStaton

Capyrighs £ 2007 Bender Svsiems Incorpouied Do Naot Daplicate
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{nstaliing MicroStation V8 XM Edition

Components

The MicroStaion V8 XM Edition Software Prerequisite Pack requires a mimimurm of 400N\ B
to install all of its components.

A complete list of the components can be found in the Instlladon Requirements section of
the ReadMe Or, to get a list of available command optons, submit the following command:

“Setup Prerequisites 08.09 03 xx_en exe” /?
Obtaining the pack

The MicroStaton V8 XM Edidon Software Prerequisite Pack is available at the Dowrldoads/
MySELECT CD area of SELEC Tservices Online.

The following command wilt extract the files to the listed locadon (C:hsome\full \path)
without continuing on to installation:

“Setup Prerequisites 08 09 03 xx_en exe”™ /C /T:C:\some\ full\path

Files necessary to install the MicroStation V8 XM Edition Software
Prerequisite Pack

If you open PrerequisitesGUT hta from the extracdon with a text editor, you can obtain a
listing of the files thar need to be installed in order to install the MicroStation V8 XM Edidion
Software Prerequisite Pack in its entirety The appropriate section begins with the comment
“The HTML dialog layour”. Each command line follows the atribute “BSI_CMD="". You
only have ro issue the command indicated in each of the HTML List Ttems (LI element tag)

Prerequisite pack instaliation

Imporiant Norte: It is highly recommended that vou close any programs and disable any
angvirus software thar is ruaning prior to the installadon of this software Be sure o turn
your antvirus sofnware back on again when you are finished To install:

1 In Windows Explorer, click Setup Prerequisites 08 09 00.20_xx exe

2 In the MicroSuation Prerequisites dialog, Click Insuall

The MicroStation Prerequisites install to vour svstem When finished, a dialog appears
teliing you that the installation Is complete

3 Click OK
You niow have the appropriate prerequisites installed o run MicroStation V8 XM
Editon.
MicrnSmgon VE XM Editun Admin Copraght © 2007 Benthey Systems. Incorporated 0 Not Duplicate
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Instaliing MicroStation VB XM Edition

MiceoSadan VE NM Edidon Admin Copyrighe € 2007 Bendey Syswms [acomponied

12706

New single-use MicroStation installation

It is recommended that vou close any programs and disable any antvirus sofrware that is
running prior to the instaflation Be sure to twrn vour antivirus software back on again when
you aze finished

Download and rusn the executable When vou run the installer for MicroStation V§ XM
Edidon, you will see two options for installing the product Select the Extract and install
installaton package option This will automarically run and complete the installation

Updating an existing installation

You can update an existing MicroStation version with a newer version that conrains changes
to existing functonality or adds new enhancements. This install acts as a minor upgrade,
which means that it will not distarb any customizations that you have complered for your
current MicroStation configuradon

Download the newer version and run the executable. When prompred with an installation
choice, select the Extrace and install installaton package option This will automatically run
the installer and update the original version loaded on the system.

MSI MicroStation installation

Use silent installation to install MicroStation without inreracting with the instzll wizard. To
perform a silent installadon, run the Windows Installer msiexec at a system command
prompt, specifying appropriate installation parameters.

Download and run the execatable When prompted with an installation choice, select the
Exuract installation package only option Note the location of the MicroStation MSI file

The following command line parameters can be set for a customized silent installadion. They
allow you to set the inswallation folder, the locadon of your workspaces and the information
necessary to obtain licenses using SELECT Server

For example, the following command invokes a silent MicroStation installation producing an
install log file named silent log in C:\, placing the program files and workspaces into the
specified directories:

msiexec /I*v Chsilent log /qn INSTALLDIR="C:\silent instal\Program\”
BSI_USTN_HOMEROOT="C\Silent instali\homeroot\” /i “MiecroStation
08 09.03 xx.ms1™

= msiexec is the Windows installer

« /1¥v Ci\silent.Jog will create a log file named silentlog in the specified location

Da Nt Duplicate
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Installing MicroStation V8 XM Edition

»  /qn indicartes the silent install; the installer’s user interface will be suppressed

+  INSTALLDIR is the folder where the MicroStation program and associated files will be
instzlled. This value must be quoted if it contains spaces or other characters that are
reserved by the command shell.

+  BSI_USTN_HOMEROOT is the folder where the MicroStation workspaces and
associated files will be instalied. This value must also be quored if it conrains spaces or
ather characters that are reserved by the command shell.

+ /i “MicroStation 08.09.03.xx.msi” specifies the MicroStadon package o install

You can also search for the online help topic “Command Line Arguments and Exception
Logs” (include quotes o search for the specific topic)

To see command options for the Windows command msiexec, select Windows Stare menu >

Run and enter msiexec.

Suppressing installation of workspace files

Use the following command to suppress the installaton of workspace files and set the install
to leverage an existing workspace location by seuing the workspace path to another location

in msdir cfg,

msiexec /v C:\silentlog /i MicroStaton msi /qn+

ADDLOCAL=ALL
REMOVE="WorkSpaces,Users,SystemBorders,System,Standards Projects, Interfaces,Font_T
raditionalChinese, Fonz_Korean,Font_Japanese, DarabaseExamples, AddidonalFontFiles”
INSTALLDIR=c\08090300 BSI_USTN_HOMEROQOT=c\08090300-W5 .

The first three properties launch the Windows installer, create a log file and specify the

MicroStation package to install.

+  /qn+ is asilent installation with a single modal dialog indicating that the installadon is
complete

+  ADDLOCAL=ALL installs everything, but

+  REMOVE="WorkSpaces,Users,SystemBorders,System,Standards,Projects, Interface
s,Font_TraditionalChinese,Font_Korean,Font_Japanese,DatabaseExamples, Addi
tionalFontFiles” indicates the components not to install

+  INSTALLDIR=c:\08090300 BSI USTN_HOMEROOT=c:\08090300-W5
indicates the path to be written as the workspace path in msdir cfg

Multiple versions on the same system

With MicroStation V8 XM Edidon 08 09 02.52 or higher, vou also have the option to install
muldple versions of the sofrware on the same system

MisrnSmtion V8 XM Edidon Admin Copyrighs € 2007 Beatley Stsiemny Incomoniied D Net Duplicare
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Installing MicraSiation VB XM Edition

é IMPORTANT: This ype of installadion is suggested for testing purposes only, as multiple
versions cannot be updated Oniy the original version can be updated

[f you are installing 2 second build, different than the original version, on the same system,
select the Extract inszallation package only installation option. This offers vou a choice to
select either the VBS file

Select the vbs file for installations of additional product versions for testing purposes These
additional installazions cannot be upgraded in the future.

Hamet A0 e e D T T L e | T
.@E_aﬁ‘{mgifﬁﬁ: sabivbs | FKB  VBScript Script Frs
'glf*ﬁﬁrﬁsta!lan 1) 164 13908 Windows Installer Package
i tutiplelnstall mst 1658 MET Fiz

Disk space

If an installadon fails with an insufficient disk space message, there may be insufficient space
on the drive assigned ro vour systemn’s TEMP and TMP environment variables, regardless of
the destination drive vou chose

During the installanon temporary space is needed to uncompress the install ser before files
get copied to their final destination. If your TEMP 2nd TMP environment variables are
pointing to 2 location on 2 drive that has less than 500MB of free disk space and you can not
free up any more disk space, you can permanently assign a new value to TEMP and TMP
through Windows’ System Properties If you do not wish to permanenty change these system
environment variables, you can do the following as an alternative

1. Open 2 Command shell (Windows Start menu > Run > cmnd).

(48]

Reassign the TEMP environment variable to another drve or folder that has more space
{for example, set TEMP=D:\temp)

%)

Set TMP=%temp¥
4. Run MicroStation .exe

Close the Command shell after the instaliation process is compleze

(5]

Note that the TEMP and TMP environment variables are temporazily reassigned only in the
IDOS session using these steps The reassignment does not permanenty impact the system
environment

MigroSiadon V8 XM Edidon Admin Copiright € 2007 Bentley Svstems Incomporaced Do Now Duplicase
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Product Activation Wizard

Product Activation Wizard

After 2 product is installed, vou must obrain a license and then activate that license Obralning
a license and acuvaring & product are two separate steps Use the wizard o help vou through
the process

To open it, select Utelzrier > License Management vo open the License Management Tool dialog
box, and then select Tools > Product Activation Wigard The wizard also opens automatically at

the end of product installation.

Product Activation Wizard

Praduct Activation Wizard F’q
The Product Activalion Wizerd asxisiz in lhe inifial sctvation ng NTLEY

[Ecensing proces:

Activating against a local SELECT Server

To activate the product against & SELECT Server that vou have deploved, select the first
option

Enter your Server Name and Site Activation kev If you ate using HTTPS, enable the HTTPS
(8SL) check box. If you are using a Proxy server o connect 1o the SELECT Server, click the
Proxy burton and enter the Proxy Server information, then click OK. Click Next

The Wizard Selections dialog box displays the information you provided Review the
information and click Finish to activate the product

Activating against a hosted SELECT Server

To activate products from a Bentley hosted SELECT Server, select the second option.

Enter your Site Acuvation key If vou are using HTTPS, enable the HTTPS (SSL) check box
If you are using a Proxy server to connect to the hosted SELECT Server, click the Proxy
butten and enter the Proxy Server information, then elick OK. Click Nexc

On the Check out a license now page, enter vour email address The appropriate product
name and version are supplied. Click Next

Microdmdon VE XM Edidon Admin Copragny T 2007 Bentlet Sy stems Inenrporamed 3o Nat Duplicate
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Using the License Management Toal

The Wizard Selections dialog box displays the information provided Review the information
and click Finish to activate the product

Activating if you are a NON-SELECT Bentley customer

Select the third opdon, click Next and select the option that applies to your site on the

License Information page.

1f vou have a license file ready for import, select the option, click Next and Browse 10 the
license file On the Wizard Selection page, review the file location and click Finish The
Producr activation complete dizlog box opens and the actvanon is complete

If you have an activation key, select the option, click Next and enter your activation key in the
Site Activation ey field The Server Name is supplied To enable HTTPS, check the HTTPS
(SSL) check box

I you are using a proxy server to connect to SELECT Server, click Proxy and enter vour
Proxy Server informadon. Click Test Connection The Product Activetion dialog box opens

and the product is actvared

1f you do not have any license information, select the opton, click Next and vou can license
the product in evaleation mode. Request a license from Bentley Sales Support by clicking the
Go To Bentey com bution

Using the License Management Tool

MicroSmtinn VA NM Edidon Admin Capyright € 200% Benrey Suscems. Incorporated

12110

Use this tool to check out application and program licenses that are under concurrent license
control of the SELECT Server License Manager 1o systems that are not always connecred
a network with access to SELECT Server This lets users whoe are dependent on the
concurrent licensing feature use managed applicavon hcenses on remote systemns for
extended periods To open i, select Usiieer > License Management

Running an application remotely

The applicaton the user is running can reside on the remote system contnually, even when its
license is not active. The only requirement is that the remote svstem 1s connected o a
necwork with access to SELECT Server during the dme thar the license is being checked out

using the License Management Tool

Onee the license is checked oue, the svsrem can be disconnected from the nerwork and the
application can be used during the valid check-cut period. This is noted in the Check Out
Expiration Dare field

Do Nz Duplicaty
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New Directory Structure

License check out and check in

The Available licenses list box at the top of the dialog box lists licenses that are available o be
checked out For each lcense, the number avaiiable is listed The term is specified in the
expiration dare field Select a license and click Check Out

The Checked our licenses list box at the botrom of the dialog box lists licenses thar are
checked out and the expiration is listed.

% NOTE: If vou do not select a license before clicking Check In, the udlity will check in the
first license in the Lt

After the check-out period has expired, the application will no longer operate until a new
license is checked out. Once the License checkout period expires, the License Management
Tool udlity automatcally checks in the license and makes it available 1o other users

If an application is no longer needed a license can be checked in, making it available to other
users within the nerwotk or remorely

Tools

Items on the Tools menu let you manage settings, actvate products and communicare with
Bentley.

*  Use the Optons dialog box to enter or edit your SELECT Server Settings, Protocol and/
or Proxy Configuration

*  Select Send Logs to directy send product usage logs to Bentley

*  Enable Use last saved email address so the email provided on license checkout is used for

interaction with Bentey

New Directory Structure

The installed MicroSration directory structure conforms to Microsoft Windows standards
The stracture makes updates easier and reduces the likelihood of overwriting datz when
reinstaliing MicroStaton Most noticeable are the separate default locations for program files

and document files
By defaulr MicroStarion installs binary files and execuiables to the following locations
C:\Program Files\Bentey\Documenration

C:\Program Files\Bendey\MicroStation

NigraSmdon VE XM Edidon Admin Copyrighe & 2007 Bendey Sysiems Incomorated Da ot Duptica
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New Dirgctory Structure

Shared data
Storing shared data in the All Users sub-folders makes them available to any user
\Documents and Settings\All Users\Application Data\Bendey\Licensing
You will find any licensing log files here Licensing is handled through the Windows registry
\Documenss and Serrings\All Users\Application Dara\Bentley\MicroStation
\Documents and Serdngs\All Users\Applicadon Dawa\Bendey\WorkSpace

The Workspace folder is where you create and maintain standards and projects in a nerworked

environment.

In this folder you will find the following sub-folders:
\Interfaces, where workspace Interfaces are stored
\Projects, where project-specific data is typically stored

\Standards, where the system adminiszrator stores and maintains corporate standards
Project data that can be used on multple projects can be moved to here.

\System, which is updated by Bendey User data piaced in this folder will be overwriten
by subsequent sofrware instaliadons or updazes

\Users, where user configuration files for using workspaces are stored

User dara files can be stored in the Workspace folder or in a shared network resource in order
to share project data, enforce the use of drawing standards and control the appearance of

MicroStation on the desktop.

Workstation specific data

You will also find the folder \Documents and Sertings\<username>\Local
Settngs\Application Data\ for each user

The  \Local Settings\Applicadon Data\Bendey\MicroStation folder is the local storage
location for some Bentley product specific data that is unique to a workstatdon The location
of this folder is defined by the variable _USTN_HOMEROOT. User preference files and
dfltuser cfg are found in a \prefs sub-folder here.

It is highly recommended that you do not to share user preference files between users.
Although muidple users could use the same workspace and user configuraton files over a
nerwork, . \Local Sertings\ Application Data\Bentley\ should reside on each local

worksration

MieroSutiun VE XM Edigon Admin Copyrighs © 2007 Benday Susrems Ineompurated Do Now Duplicne
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Multi-core/Multi-processor Support

¥ NOTE: Run the key-in ustation exe -RestoreDefaults to reser MicroStation so it s using all

the default parameters as installed

Multi-core/Multi-processor Support

M lernSiadan VE XM Editon Admin

12000

MicroStation V8 XM Edition can wake advantage of the hyper-threading capability of mulu-
core or muld-processor systems by performing graphics processing in a separate thread.
However, because MicroStation may perform better with hvperthreading disabled, users will
be notified upon swartap if hyperthreading is enabled on a system

Example files

Each delivered example data set includes relevant design and daza files They contain
DGNLIBs that have examples of shared resources and link sets for use with Project Expiorer

The General data ser illustrares features such as access control, change tracking and reference
enhancements The DGN files in the data ser have links that you can follow to relevant topics
in the online help This daw set is in the \WorkSpace\Projects\ Examples\General folder

If you have a MicroStation installation that includes the delivered examples you can follow

along with the exercise

“» Exercise: Familiarize yourself with the examples

1
2

Launch MicroStaton.

In the MicroStation Manager, ser the following:

User: examples

The Project switches to General This project contzins exampies of features users
regularly use when designing.

Open _whats new__ dgn

This file contains examples of new features If you open the References dialog box,
vou can see that the overall sheer is assembled from referenced models.

Window Area around the Templates frame

Informartion abour the feature is presented in graphic form in this referenced model
To access the geometry you must open the actual mode]

Right click over the orange frame

A dialog box appears. It prompts you to select the functonality vou want to associate
with the reset button The default is the default MicreStation behavior If vou select
this option, a right click is a reset You can reset and continue to press the mouse

burron to open the Reser pop-up menu You also have the option to switeh to default

Comright € 2007 Bentley Sustems Incomporated Du Not Duplicue
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Set Seed File Utlity

Windows behavior If vou select this opton a right click opens the Reset pop-up
menu immediately

6  Click OK

You will not see the First Reset dizlog box after the first right click, but you can
change the setting ar any dme in the Input Category of the, Workspace > Prefersnces,
Preferences dialog box As this is a user preference, the dialog box will appear again if
vou select another user in the MicroStation Manager

7 Right click over the frame and continue holding the mouse button
The right click and press action opens the Reset pop-up menu.
8 Select Exchange from the menu.

The Exchange option on the Reset pop-up menu redirects you to the referenced
model containing the geomerry

9 At the upper left of the model, right click and press inside the dashed box.
10 Select Follow Link > path to help topac

You are directed to the Element Templates topic in the online Help file
11 Close the Help window
12 Select Frle > Close
13 In the MicroStation Manager, expand the Project option menu

Note that all of the vertcal disciplines are represented. There is 2 project for each
one These projects are structured and ke significant advantage of new features
such as the Project Explorer znd task customizaton.

14 Set the following in the MicroStation Manager
User: Bentey Institute

Projecr MSVEXMAdmin

Set Seed File Utility

AeroSution V8 X0 Edidon \dmin Coprrighs © 2007 Bentley Sysimms Incorpazieed Dz Noe Duplicate

12100

Use this utility to select the seed file that will be copied when users right click and select New
> Bendey MicroSration Design File in Windows Explorer or a Windows style file open dizlog
box. Access the utility by clicking the MicroStation Manager's Tools/File History icon and
selecting Set default seed file from the pop-up menu

F NOTE: The MicroSraton Manager has many features similar ro Windows Explocer You can

right click and create a new Bendey MicroStadon Design file
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Set Seed File Utility

The Start > Programs > Bendey > MicroStation V8 XM program group also contins a

shortcur to the Ser Seed File urilite.

% Set Seed File

Options in the dialog box let vou choose whether users will be prompted to browse the file
system, to use the current seed file or to use the seed file thar is currently selected in the

dialog box

This setting has no effect on the variable MS_DESTGNSEED It is only used when creating a
new design file direcdy from Windows Explorer

MicroStation VA XM Edidon Admin Copyrgie €2 2007 Benthey Sustems, Incorporated Do Mot Duplieate
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Set Seed File Utliy
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, User Interface Enhancements

When you open a DGN file in MicroSraton V8 XM Edition, yvou will note significant
changes to the default layout of the MicroStation V8 application window. These changes
make it easy to create a truly custom working environment

Positional keyboard mapping gives each user the fiexibility to configure their eatire keyboard
so they have immediate access to any MicroStation command with the touch of a key

Many view controls can be performed using the mouse, and the default button assignments
provide more flexibility for using view commands as well as accessing information.

Tools can be customized to simplify design tasks. You can apply 2 specific set of wols,
standards and interface elements o a pardcualar task in a workflow so users can work
consistentdy This resules in standardizadon and enhanced efficiency throughout the design

pracess

Application Window

MicroStation V8 XM Edition presents changes in the layout of the application window.

*  The Main tool box replaces the Main tool frame It provides access to the Element
Selection, Fence, Manipulate, Change Atributes, Groups and Modify wols, plus the
Delete tool Creadon tools are located elsewhere

A

Many rools that were formerly accessible from the Main ool frame are accessible from
the Task Navigaton tool box, which is docked on the right side of the application
window, or the Task Navigavon dialog box if you are using thar option

MizreStadon VB XA Edidon Admin Copyrighe T 2007 Beatdey Systems. Incorpormied Do Nes: Duplicare
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Positional Keyboard Mapping

The numbers and letters superimposed on the lower left corner of ool 1cons are
associated with posivonal kevboard navigadon
The Main Classic tool frame can be accessed from the Tools > Too/ Bexer dialog box or by

using the key-in DIALOG TOOLBOX MAINCLASSIC It is 2 single column of tools
rather than two columns Tools and tool boxes can still be accessed from the Tools menu.

+  The ~view control wol box appears at the top of each view window Move its locaton 1o
the side or botiom, or remove it, using the user preference Show View ToolBox in the
View Optons category of the, Workspace > Preferences, Preferences dialog box

e e T e e D
s 8 LAt

The first tool in the wol box opens the View Aruibutes dizlog box

= Additonal fields on the right side of the status bar indicate the open DGN file’s design
history status and the fearure that has input focus.

Positional Keyboard Mapping

Positonal keyboard navigation lets you use the keyboard 1o select tools and change settings.
The keyboard is divided into zones and each zone is mapped 1o a tool box or the Yool

Serungs window.

=2 Exercise: View the keyboard map
1  Open Interface.dgn
2 Right click over the Posidon Mapping frame
3 Click OK in the First Reser dialog box to set the preference for this user to the
default.

4 Righ: click and press over the frame and select Exchange from the pop-up menu to
open the Positon Mapping model

MicroStation uses managed focus to follow your actions, moving input focus for common
operations In this system, the top level is called home Look for the home icon on the right

side of the status bar

& MISCNOTE

MigroStation VB XM Edidon Admin Copirighs € 2007 Bentley S1stems. Incorpaorared Do Nese Duplicne
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Positional Keyboard Mapping

This field indicates focus location whether it is hame, the ool sertings window, the Kes-in
browser or AcculDraw: If there is no icon, some other window or dialog box has the focus

1 I

Y=

i

Foens at howse. the tool ssttngs windaw; the Key-mn browser or AeenDraw

When vou place a line, the focus moves from home to the Acculdraw window during
placement, then back to home. The icon in the statas bar changes accordingly To specifically
move the focus home, press Esc on the keyboard From home, press the keyboard key thar

corresponds to the tool you want to use

Positional keyboard navigation is enabled by default To disable it, turn off the user
preference Use Position Mapping in the Position Mapping caregory of the Preferences dialog

box.

& NOTE: If you are left handed, open the Preferences dialog box and select the Positien
Mapping Category Click the Left Handed button to change the mapping set up

Tools in the Main tool box

When accessing tools in the Main tool box you use 2 combination of kevs When focus is at
home, pressing 3 will open 2 pop-up menu listing the Manipulate tasks. Press 3 again to
activarte the tool that is in the third position, Scale, or press 9 to Move Paralle]l When focus is
at homne, press 7 for the Modify tools, then 3 to Extend or 6 ro Trim

Tools in the Task Navigation tool box
In the Task Navigation ool and dialog boxes, tools are mapped w letiers Pressing W will
open a pop-up menu listing the Polygons tasks Then press 2 for the Place Shape wol. When

specific tocls that belong 1o a task occupy the Task Navigadon tool or dialog box, only a
single key press is needed Just press the lerter that corresponds ro the tool you want to use

& NOTE: To disable the display of kevboard kev labels on interface items that are subject 1o
positional kevboard navigadon, disable the Position Mapping user preference Show Positional
Keyboard Navigaton Aids.

Additional key functions
The foliowing kevs also perform funcrions

<Enter> opens the [<ey-in browser at the pointer location If it is already open, focus is
shifted to it

<Space bar> moves focus o the AcculDraw window

<Tab> Change the next element under the pointer

MicrnSeation V8 WM Edigon Admin Copyright € 2007 Bentiey Sivtems Incomporued Do Not Duplicne
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Mouse View Controls

<Pglip> When the rask list is open, go to the next wask

<PgDn> \When the task list is open, go wo the previous sk

Mouse View Controls

Several view operations can be performed using the keyboard and mouse

+  Shift and drag while pressing the left mouse button to activate dynamic panning

»  Press the Shift key then press the wheel of a wheeled mouse and drag for dyramic

romuon
*  Roll the wheel of 2 wheeled mouse w0 zoom in and out dynamically.

»  Press the Shift key and roll the wheel of a wheeled mouse to zoom in and recenter

«  Double click the wheel to fit view
& NOTE: Double click to fir view is abways assigned to the same butron as pan drag

There are user preferences in the Mouse Wheel category that ler you customize use of the

mouse wheel

Button assignments

The default button assignments give you more flexibility for using view commands as well as
accessing information The following able shows many combinations You can see in the
second row that a double click with the mouse wheel, which is using it 2s a burton, will fit
view In the third row, if you drag while pressing the mouse wheel you will pan the view

MigmSmton VB NM Bdidon Admin Coparight © 2007 Bendey Syscems Incorporared Do No: Duplicate
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Mouse View Controls

Action:

Lefi mouse

Right mouse

Mouse wheel as

Mouse wheel

button burien button
Click Dat point or ¢lick Reset or press and
hold™
Double click Fir View
Drag Define start and #nd Pan
points
Roll Zoorm 1o and out

<Shift> + click

User-definable view

pop-up

<Shifi> + drag

Dynamic panning

Rouare view
dynamically (3D
only}

<Shifi> + roll

Pan with zoom

<Cul> + click

Selection logic and
following hypeslinks

Main ool box at the
pointer

<Cirl> + drag

Swivel view
camera {30 only)

<Cui» + roll

Walk (3D only}

<Al + click

March aztributes
fromeursor

Element quick info
at the poinrer

Rotate view
extended

<Ak> + yoll

Pan lefi/right

<Shift> + Toggle Accubnap Current tasks e the
<Cul> pointer

<Shift> + Element Selection’s

<Curl> overlap trectangle

and drag

Cirl + Tentazive sets the AccuDraw origin to the resulting rentative point

* NOTE: The default behavior is thart a right click works as a tradidonal reset command.
Right press and hold gives you access to the Reset pop-up menu

Customizing button assignments

Use the Workspace > Button Assignments dialog box to assign any MicroStation kev-in to a
mouse burton, 2 butron chord, or combination of kevboard modifiers with mouse buttons.
Even the default assignments are customizable.

You can assign Cirl + Left Mouse Button + Right Mouse Bunon to send the key-in PLACE

FENCE.

To customize a button assignment:

1 In the Button Assignments dizlog box, enable the check box for the aceeleraror kev vou
want 1o associate with the command.

NliproSation VE XM Edidon Admin
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The Task-based Interface

g

[2]

Select the burton you want to assign the command o from the option list

3 In the Action rext field, enter the kev-in you want 1o associate with the assignment and

press Tab
4 Click OK when vou are done

NOTE: If you temap the middle mouse button or wheel o tenative it will no longer be
mapped to XBurton 1 which, by default, controls many view control operations If vou have
only three mouse burtons and they are mapped to dara, reser and rentative you can map a
butron chord to XButton 1 so that you can stll perform the view conerols

Notes:

The Task-based Interface

A task is something that you accomplish using a logical grouping of tools For example,
hanging a picture is a task for which you mav need a measuring tape and a2 hammer

Tasks let you organize wols and tool boxes into an interface that is easy 10 navigate. Creating
a sequence of rasks creates a streamlined workflow Tasks actually contain references o rools
and tool boxes, so they can contain overlapping sets tools A drawing task and a drawing
composition task can both conrtain text tools In the example, the measuring tape you used to
hang the picture will also be used w accomplish other tasks

The fizsticon in the Task Navigarion tool box or dialog box is the Task List icon Click it to
open the task list Defaule task lists are provided for drawing tasks (lines, polygons, patterns,
erc ) and drawing composition (references, dimensions, annoration).

MicroStazion V8 NM Editon Admin Copyright © 2007 Bendey Systems Incorporaied D Mot Duplican
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The Task-based Interace

Use the PgUp and PgDn keys to select tasks Click the + sign o expand the rask 0 see sub-
tasks, which correlate to o] boxes Use the arzow kevs to step through the sub-tasks

Dhavang Compositien “H.inear
—Folpgon:
-Ccles
Patems
T ags
-Taxt
-Calls
rideasure
—{im=nzicnrig
EFDiavang Compasiion

The defaule taske fist and the Drapng tasks expanded

Rather than having a number of tocl boxes open, by default, tasks occupy the Task
Navigation ool box The tools presented change when you select a different task from the
task list

tdeatue
L‘Drm‘:n: foning
FCawing Compasition

i hers you setect the Pofygans task the defautds Drawing task tools suiteh to the Polypons tooly

Options for task navigation
Task navigation in views

By defaulr, the View control tool box is docked ar the top of each view window Even though
this makes them easy to access, the view controls are available from the Main rool box and
many are accessible using the mouse

[KCnowing this, you can choose to have a task bar docked on each view window. Do this by
selecung Window > Task Navigation in Views or sewing the Presentadon option in the Task
Navigation category of the Preferences dizlog box to In Views.

Drawing task navipation i Ve 1
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The Task-basaed Interface

If vou have multple view windows open, different tasks can be active for each view window
Dialog box option for task navigation

Select the Presentation option w Dialog in the Task Navigadon category of the Preferences
dialog box to display tasks in the Tasks dialog box Displaving tasks this way provides a lot of
flexibility It lets vou work with a greater number of tasks, tool boxes, and tools, some of

which may have long names

Clicking All Tasks displays all tasks in the hierarchy wree Click the + to expand a task When
vou select a task it becomes the root task and the other wasks hide, just like the Task

Navigation tool box

ST AlTa
& A Tachs

Fallens
- Tap:
Tout
- Cale
- ieanue
- {lnenziaring
% Dirawing Compornian

Right clicking on a wask presents a list of settings for the task

Select Set Task Root and the selected task becomes the root task, moving it to the 1op of the
Tasks dizlog box and hiding the other tasks. Select Clear Task Root to reset the task so thac s

no fonger the root sk

Items on the view sub-menu conurol what you see.

»  Select Icon o see the tools as icans only

+  Select List to see the tools’ icons, position mappings, and names

+  Select Panel to see the rools' positdon mappings and icons
Apply View to All applies the current rask's view to all tasks

Select Open as Toolbox to open the selected task as a tool box

Copirighr & 2007 Beatles Svstems. Incorporatad Po Nag Duplieace
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Customizing the User Interface

Customizing the User Interface

Llement Templates, custom tools, tasks and menus are created and managed in the
Customize dialog box

Enforcing standards with element templates

Element templates are named sets of element parameters that can be used o set acrive
element placement paramerers. A user selects an element template, which activates the
settings stored in the template and can also activare a key-in stored for that template.

You can create remplates and apply them to tools to ensuze that elements placed using the
tool conform to specific standards Use templates o further enforce standards by storing
them in DGINLIBs

Element Selection can show all the element templates within the active design file. You can
use the listing to select and deselect elements based upon the temnplare that was used for their

placement

Conceptual 2D
3 Door L abel
- Dowe
L[ Floor Slabs
71 Foungatipnz
+| Funizhings
1] Ground
'] Pavement
| Ros!

Creating element templates

= Exercise: Create an element ternplate
1 Open \dgnlib\Bidg dgnlib

This DGNLIB contains the tools, tasks and templates available for a project

2 Select Workspace > Cunstonse
3 On the Templartes tab of the Customize dialog box, expand Bldg denlib.
4 Expand the Design template group
5 Expand the Svmbols template group
MicrnSeadon VE XM Editinn Admin Copyright £ 2007 Beatley Svsiemy Incorpanated Da No: Duplicate
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Customizing the User interface

6 Select Handicapped Access
7 Check the General Settings properties

Any me that this template is applied users will place blue elements on the Special
notations level, using weight 0

Select the Symbols template group

x| 9 Click New Template or right click on the template group name and select New
Template from the pop-up menu

10 Name the new remplate Trees

11 Select the new template and set the {ollowing properties:
Color: 12
Liine Styfe: 1

Waight 1

Additional template properties

Right click in the gray area below the existing propertes to open the Add pop-up menu Use
it 1o add more properties to the selected template. These can be General Setings such as
Level, Color, Line Style Attributes, Class ete. They can also be Closed Linear Settings such as
fill rype or color, text settings, cell settings, Multi-line styles or Dimension styles

Gensral Ssttings ¥
Ciogad Linsar 4
Text ¥
el *
Point *

Patternfriateh »

#ine Styis
Gansnsion Styla

Hzteriz)

You can also right click on a template and select Add to add additional atiribute fields

for the template

Setting and locking templates

Element templates are activated using the Actve Template wool in the Accributes ool bar It
provides a list of available remplates and also serves as a toggle to lock new elements to the
actve template during placement While element templates are similar to Settings Manager
components, elements that are placed with a template locked are automatically updated when
paramerers in the element template are modified

MicroSudon VE XM Edinon Admin Copyright € 2007 Benshe Syserms. Incorporated Do Noo Dupitcare
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Customizing the User Interface

There 15 an imporiant difference between serting and locking the acuve element template In
both cases elements will have properdes thar are defnined in the template Buc they will
uldmarely behave differently

When you ser the template by selecring one from the hierarchy iree, the actve atribute
setungs change o the properdes defined in the wemplate. When you place an element, the
elernent will have the template’s properdes but it is not locked to the template. If the template
properties are changed and a library updare is issued, these elements will not change.

When a template 15 locked, the active artribure settings change to the properties defined in the
template and elements will have the lemplate’s properties Elements are also associated with,
or locked to, the template If the template is stored in the active DGN file, these associated
elemensts will update automatically when propertes in their template are modified If the
ternplate 1s from a DGNLIB you can use the DGNLIB UPDATE TEMPLATES kev-in to

synchronize properties This is similar to text and dimension styles.

To lock a template, set the template by selectng one from the hierarchy tree then click the
Actve Element Template icon so that it is depressed

2 ILxercise: Change remplate attributes
1 Open \dgn\packing lot] dgn

The elements in the file were placed locked o the Design > Lianear Curb, Parking
Pavement Sturiping and Warning Suiping emplates. As templates from a library file
are used, they are copied into the active file

2 Take note of the green curb atuributes.
©7 NOTE: You can use the icons in the View Groups diaiog box at the botrom of the

MicroStation application window to move between all the models vou have visited in
a MicroStation session, regardless of the file in which the model resides

Select Previous Model w rewurn to \dgnlib\Bidg dgnlib

In the Customize dialog box, expand Bldg dgnlib
Expand the Design template group
Expand the Linear remplate group

Select the Curb template

o ~ Ot B

Change the following General Sertings:
Color: 6

1 eight 2
9 Right click in the Properties area and select .Add > General Setings > Lane Shik from
the pop-vp menu

10 Ser the Line Swle to 2

0 6T Benley Susems. fncoqonied 3o No Duplizate
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Customizing the User Interface

11 Select File > Save Setsings

= Exercise: Updare elements locked to a template

1 Open \dgn\parking lotl dgn

;T Select Next Mode! to open it directy.
2 With the peinter in the view, press Enter to open the Key-in browser
3  Key-in the following:

DGNLIB UPDATE TEMPLATES

Press Enter or click Run key-in in the Key-in browser.

The properties of the curb, which is locked to the template, update If you select the
Curb template in the Atiributes rool bar, you will see that the properties assigned o it

have changed

Updating elements using templates

If a template was used while placing elements and a user manually changes element
symbology so that it doesn’t match the remplate, you can issue a command to updare the
symbology Select Usilittes > Update §elected Elements in the Customize dialog box to update the
symbology of all elements in a selecdon set that are associated with local templares 1f an
element that is not associated with a templaze is selected, its symbology will not change

>  Exercise: Update changed elements

1 Contnuing in parking_lotl dgn, expand the Element Selection tool settings.

Atribute tabs in the ool settings let you select elements by one or more arzriburtes
like level, color, stvle, weight, tpe, or class

e 2 Selecr the Line Style tab

3 Click on line style ----- 2 to select it
The curb elements, which are line style 2, are selecred

4 In the Aaributes tool bar, change the active line stvle o 0
Now the line style artribute does not march the template

=k~ .\ . 5 )
R 5 In the wol serrings, click Clear to release the selection set

Clear switches to Select All

3 6 Click Select All.

All elements are selected.

7 In the Customize dialog box, select Utifinies > Undaie Seiected Elomenis
£ #

The changed curb elemenss are updared

Coprrght € 2017 Bendey $isems Incomporied Da Net Duplicate

2-26

MicroSution VE XM Edicon Admin

127171



Customizing the User Interface

8 Click Clear 1o clear the selecrion set

® NOTE: Select Utiliries > Refresh Local Elensonz Templates in the Customize dialog box to update
the template list with element remplazes from DGNLIBs

Key-ins

Use the kev-in CUSTOMIZE DELETEALLDATA to delete all template data and ali custom
tool box, tool, task, and menu dara from 2 DGN file All elements that are associated with che

remplates being deleted will no longer be associated with the wemplares
Use the key-in CUSTOMIZE RELOAD 1o reload all template data and all custom ool box,
rool, task, and menu dara into 2 DGN file Use this key-in if DGN libraries are updared and

vou want ro reload data to make it available while working in MicroStadon Closing a DGN
file and reopening it will produce the same result

Creating tasks

> FExercise: Create a task

t«ﬁ' 1 Open \dgnlib\Bldg dgnlib

Micradiaton VE XA Edigon Admin
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2 Click the Task Listicon.

All the wasks defined by MS_DGNLIBLIST are listed along with the default 2ID tasks,
Drawing and Drawing Composition

3 In the Customize dialog box, select the Tools tab.

Tools, taol boxes, tasks and menus are defined on the Tools rab of the customize

dialog box

If you are not wotling in a file that is identfied in MS_DGNLIBLIST (IForkspare >
Configuration, Primary Search Paths category, DGN Library List) you will see a
warning message. Tool, task and menu customization can be performed only in files
that are configured DGN libraries.

4 Open the File menu.

Avajlable DGNLIBs are listed on the File menu If vou anemprt to access the Tools
rab and see the warning message, you can go 1o the File menu and select a listed
DGNLIB so vou can use the 1ab.

F NOTE: Add the capabiticy
_USTN_CAPABILITY <+CAPABILITY_UI_LOADFROMACTIVEFILE
1o a user configuraton file {ucf) or project configuration file { pef) o allow access w the
Tools b while working in a DGN file thatis not specified by a configuration variable. If this
capability is set, vou will see the custom tools, tasks, and menus from the open DGN file in

additon to those in the configured DGN libraries.
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Customizing the User Interface

Personal DGNLIBs

When a user creates a new Interface in the MicroStation Manager, not only is 2 new ustn 101
file creared, a user specific DGNLIB is also created The name of chis DGNLIB is the same
25 the name of the user interface. Users can open this new DGNLIB and add custom wols,

tasks and menus that are unique w them

The Primary Search Path category, User Interface DGN Library List variable,
MS_GUIDGNLIBLIST, includes the path :o DGNLIBs in the current user interface folder
SCUSTN_USERINTNAME)\* dgnlib

IMPORTANT: Users can copy other DGNLIBs to their user interface folder so that wols,
tasks and menus from those files are also loaded Tools, tasks and menus in the user interface

folder will be the first ones loaded and will have precedence if duplicates exist in the
DGNNLIBs referenced by MS_GUIDGNLIBLIST

Adding existing tools to tasks

Once 2 task s created you can add existing tools or rools that you define in the Customize
dialog box You can use any MicroSwmtion tool or any existing custom tools you have
previously defined in an m0? file

“» Exercise: Compose a task containing tools from different tool boxes

1 Condnuing in Bldg dgnlib, on the Tools tab of the Customize dialog box, expand
User Tasks in the cight frame.

2 Select the file name, next to the V8 icon

= 3 Click New Task

The task list expands and a new task is added

4 Name the new task Landscaping

F NOTE: A rghr click menu for each task offers a Rename option as well as options
for reordering, creating and deleting rasks.

S In the left frame, expand Application Tools, then MicroStation
All MicroStaton’s rools are listed here

6 Scroll to the Measure tools

7 Drag the Measure wols 1o the Landscaping rask in the right frame and drop them
You can add entire ool boxes or individual wols

8 Scroll to the Polvgons toals

?  Drag these wools to the Landscaping task

MieroSuaion V8 XM Edidon Admin Coperighe © 200 Bentley Svstems Incomnred 30 Nos Dueplicaie
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Customizing the User interface

If vou make 2z mistzke, Undo works on these drag and drop operations
10 Scroll to the Modifv wols.

11 Drag these wools o the Landscaping task

Tool key-in syntax

When an Application tool is copied into a tool box the icon is copied into the current
DGNLIB When this happens, the connectdon to the original application that provided the
command and icon is removed This way you can use icons from MicroStation and change

the command thart is seart

When you copied MicroStation’s Measure tools to the Landscaping task, the owner of the
otiginal command for each tool was included in the Properties section of the Customize

dialog box

FPipeiia T

12 Rezouce icon

| o 3 - TRanng

MERSIUNE

For example, in the Kev-in browser the key-in DIMCREATE ELEMENT invokes the
Element Dimensioning command When using Customize, it would appear as
[DIMCREATE] DIMCREATE ELEMENT

[DIMCREATE] is the taskID, which is the MDL. Task 1D as in the Uiktier > MDL
Applications dialog box. If vou want to make sure the original command is always used, include
the [taskID] prefix. When vou copy tools, it is ahways included

The supported syatax for cusiomize is:
[taskID_1;taskID_2} kev-in_1:kev-in_2 and so on

The number of taskIDs and key-ins do not have to march up Each taskID in square brackers
is loaded, if it is not alreadv Joaded, and then the semi-colon separated kev-ins are sent 1o

MicroStation for processing,

7 NOTE: This kev-in syntax is onlv for DGNLIB-based teols It also affects menu irems that

specify a tool path

If vou want to actvare a different command for a copied tool, vou replace the entire

command string

Once vou add a tool box 10 a task, vou can edit the wols it conrains

0 N Daplicaie
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Customizing the User interiace

Editing tasks

=» Exercise: Refine the task

T Contnuing in Bldg dgnlib, on the Tools wb of the Customize dialog box, expand the
Measure tools in the Landscaping task

You will keep only the tools that are relevant to the landscaping task
2 Select Measure Volume, right click and select Delete

You can select multiple tools or tasks and use the Customize dizlog box Delete icon
_ 10 delete them
x 3 Select Measure Radius and Measure Length and click Delete
4  Expand the Polygons tools and delete Place Regular Polygon and Place Orchogonal
Shape '
5  Edir the Modify tools to only include the first five rools.

1}

Idaddy
Mocly Shamzry
[ Paizr Dbt

o Exandline

Fafems Slemants fa Intarsscton

i L Esrand Slamen to Infarzzcton
—_-'-'_'_:J Folpgons

TV Plaze Aok

L% Plaza Shaoa

_v__] WMoasure

Y Sfmanwa Dicance
Uk

_éé.l Koazws Angh

5;;:“ Meazura Arza
NOTE: Since rools are referenced into Tasks, changing a wol’s the functon can affect many

tasks

= Exercise: Reorder the tasks

1 Contunuing in Bldg dgnlib, click the Task List icon

The Landscaping task is added to the task bist
2 Expand it and see thart the tool boxes vou added are available

3 In the Customize dialog box, select the Landscaping task.

4 Use the Move Up arrow, or drag and drop, to move it under the Planning task

You can also reorder the ools wichin the task
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Customizing the User Iniarface

5 Arrange the tool boxes in the Landscaping task in the following order:
Pelvgens
Mesasure
Modify
Click the Task List icon.
7 Click the Landscaping rask.

The reordered Landscaping tasks are added o the interface

Use tasks to define a workflow
You can compose a series of tasks that help define a complete workflow

2 Exercise: Compose a workflow
1 Contnuing in Bldgdgnlib, in the Customize dialog box, select the Dimensioning
tools from the MicroStation application tools in the left frame
2 Drag them to the Bldg dgnlib tasks and drop them

% User Tashs

¥

The Dimensioning tools are now an overall task

Use the up arrow icon, or drag and drop, to move them wnder the Planning task
Reorder the msks below Dimensioning as follows:

Floors

Walls

Roof

Elecrric

Plambing

Lighting

Landscaping
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Customizing the User Interface

o ~ o~ n

Annotaton

Select Bldg.dgnlib and click New Task

Name the task Prindng

In the lefr frame, expand the MicroStation Standard tools

Drag the Print teol to the Priang task

Adding custom tools

=+ Exercise: Create a custom tool

1

S
QN O W N

11
12
13

14
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Conunuing in Bldg dgnlib, in the Customize dialog box, expand User Tools in the left

frame

Select Bldg denlib

(lick New Tool Box

Name the new tocl box Plants

Select the new tool box and click New Tool.
Name the new wol Place Trees

Select the new ool

In the Properties secton of the Customize dislog box, in the Command Dara
section, remove null and eater the following in the Key-in input field:

PLACE REVCLOUD POINTS
Change the Balloon Text w Place Trees

In the General Sertings section, click in the Icon inpur field, and then click the
browse burton on the right

In the Define Icon for Tool dialog box, you'll be choosing tools from the
MicroStation application

Expand MicroStation

Seroll to the Cells tools and expand them.
Select Place Active Cell Martrix and click QK
The icon displays in the icon field

You can choose to display a t00l’s icon or label, or both by serting the Tool

Presenration

Set Tool Presentation o lcon Gnl
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Tool icons

In the Define Icon for Tool dialog box, the Look for icons in options let vou select the source
from which you want to select, imporr, or delete icons for custom tools

+  Applicatons contins the icons listed under Application Tools in the Customize dialog
box. It includes ail MicroStadon wols and MDL application tools

«  Current Design File is the only source from which you can delete icons.

*  Import Selected Icons is the source 1o use t import icon (ICO) files.

*  Import Selected Bitmaps is the source 1o use to import bitmap (BMP) files

The settings for MS_ICONLIBRARYLIST, MS_TCONRSCLIST,
LUSTN_SYSTEM_GUIDGNLIBLIST and MS_GUIDGNLIBLIST determine which icons
appear when Applications is selected You can select icons from all applications, including

MicroStation tools and MDL application tools. You can also select icons from the current
design file, selected icons ACO files) and selected bitmaps (BMP files)

Import/export

Use the key-in CUSTOMIZE EXPORT ICONS <path\directory\> to export icons from
the open DGNLIB to a directory. You may want to export icons in order to edit them

INOTE: Only the icons shown in the Define Icon for Too} dialog box when Loak for icons
in is set to Current Design File will be exported.

Use the key-in CUSTOMIZE IMPORT ICONS <path\directory\> to import icons from a
directory to the open DGNLIB

NOTE: When importing icons, imported icon will replace existing icons of the same name.

Notes:

MicroSmdon V8 NM Edinon Admin
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General settings for user tools

The Tool Type options specify the behavior of the ool
+  Standard makes the too! active until vou select anodher wol.

+ A Push Burton will not start a new command and does notinterrupr a current placement
command Use this 1o send immediate command key-ins For example. the key-in
CO=1LV=Landscaping would set the active color and level
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Customizing the User Interface

Dimension options determine whether a tool will be available when working in 2D DGN
files, 310 DGN files, or both

Adding advanced tools

Since you can use any MicroStation key-in 2s the command suring, you can pre-determine ool
settings or open documertts You can also link to a website

~» Exercise: Create advanced tools

N B W

This exercise depends on the location of the file Lot_Design mt. It is delivered in the
darta set \data folder Place it in the C:\temp folder to follow the exercise.

Continuing in Bldgdgnlib, in the left frame of the Customize dialog box, expand the
Planning User Tools

Select the Guidelines tool 2nd look at the Key-in in the Command Data section of

the dialog box

This toot links to a web page You can use % to link t any document For example,
%% C A\ temp\CADsmndards doc

Select the Plants tocl box.
Click New Tool
Name the tool Parameters.

Select the tool

In the Key-in field in the Command Data section, enter the key-in:
I C:A\temp\Lotr_Design xt

This opens the text document in the application associated with the . txt extension
Set the following:

Balloon tescr: Parameters

Leon: MicroStation > Redline > Redline Display

Too! Presentation: Icon only

Now you can add the custom ool box to a task

=2 FExercise: Add tools to a task

1

Microdiadon V8 XM Edidon Admin
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Continuing in Bldg dgalib, in the Custornize dialog bos, drag the Plants tool box to
the Landscaping task in the right frame

Click the Task List icon and expand the Landscaping rask.

The Plants tool box has been added to the task
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3 Click on Plants in the task list so that the Plants wols occupy the Task Navigaton

ool box
4 Click the Place Trees wol

Tool sertings change 1o reflect the command string vou entered
THZ 5  Click the Parameters tool

The document identified by the key-in opens in the application associated with the
Xt extension

6  Exit the application.

You can also create tools that open dialog boxes or perform repeated user actions
You can add tools that open dialog boxes to specific tasks

<> Exercise: Tools that open dialog boxes

1 Continuing in Bldg dgnlib, in the left frame of the Customize dialog box, expand the
Primary Tools in the MicroStation Application tools.

2 Drag the References tool to the Walls sk

3  Click the Task List icon and select the Walls task.

The References tool is added to the rask

Apply an element template to a tool

You can apply element templates to tools so that the attributes in the remplate are always
invoked with the wol is used You can import setrings from existng Setting Manager resource
files and to import and export element emplate definitions using XML files

2 Exercise: Define antributes for a placement ool

1 Continuing in Bldg dgnlib, in the left frame of the Customize dialog box, select the
Place Trees User Tool in the Plants ool box

In the Comrnand Data section, vou can set the template parh

2 Click in the Templare Path input field and navigare to the (Design > Svmbols) Trees
remplare Double chck the Trees emplate to apply it

Open the task list and click the Landscaping tasks
4 Select the Place Trees tool.

Note the change in the ool and active atributes semtings.
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Additional command data settings for tools

The Associate Template secting sets the staras of the Active Element Template ool in the
Auribuces ool bar when 2 ol is used

*  When Always is selected, the icon is available
*  Never makes it unavailable

»  Use Current Sexting does not change the status of the icon If the icon is available and a
template is defined, elements thart users place with the tool will be placed with the

template setrings

f you right click in the Associate Templae field there is an Add Default Template option. If
you set one, when the ool is used, the default template’s properties are applied to the
element If 2 template property is specified in both templates, the associated template takes

precedence

Managing tool settings

Another feature is the ability to control ool settings Other options for customizing tools are

also avatlable

3 Exercise: Add customization options to the Customize dialog box
1 Contnuing in Bidgdgnlib, on the Tools tab of the Customize dialog box, expand the
Fixtures User Tools.
2 Select the Place Pipe tool
3 Right click in an empry area of the Properties section at the bottom of the Customize
dialog box
4 Select Add and select Dialog Irem Setrings from the pop-up menu

A Dialog Item Serdngs field is added to the dialog box Use this area to set tool

setrings parameters

To find out the available tocl settngs for 2 command you can use the key-in SET ITEM
TOOLSETTINGS To do so, invoke the tool in MicroStation and then issue the key-in. The
optons aze listed in the right-most frame of the Key-in browser.

= Exercise: Pre-set tool settings

1 Continuing in Bidg.dgnlib, in the Item Sertings secton of the Customize dialog box,

expand Dialog Item Settings
2 Set the following:
Dialag Ttenr Name: ToolSetings Join

Type: Literal
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Il 1

This enables the join Elements check box in the Place SmartLine tool sertings
3 Right click on the Iiem Settngs heading and select Dizlog Item Seuings

Addivonal dizlog items can be specified this way
4 Set the following for Dialog Irem Seutings(1):

Dialpg ey Name: ToolSettings verextype

Iype: Lireral

Value: sharp

Add the Fixwures User Tools to the Plumbing tasks

Make the Fixtures tasks the active tools in the Task Navigation tool box.

Select the Place Pipe tool {from Home, press W) and note the ool settings.

8 Selecr the default Drawing tasks from the task list so those tools occupy the Task
Navigation ool box.

The Type oprion determines the type for the dialog item It can be literal, as in the exercise, 2
distance stored in meters, an area stored in square meters, or a volume stored in cubic meters
The Value is the value for the Type If the tool places a line thar is constrained, one of the
dialog items would be the line’s length, which is Type distance. The Value would preser the

lengtn of the line

Additional tool properties

You can also access available ool properties if vou right click on 2 new ool and select Add
from the pop-up menu

" Gesign Fle Settings ¥

Lotk *
General 4
Command Gata ¢

Uiglog ltem Settings

Expand the options on this menu ro add design file settings such as the active snap mode or
an active angle Fence modes can be ser. Use the Locks options so thar the tool uses the
graphic group lock or the annowton scale lock You can also apply fence settings such as clip
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or overlap. The command data sub-menu lets vou add a field so vou can define a defauls

remplate.

Migrating stg resources

Legacy

stg resources can be imported and be used as tools and templates The sertings file

groups become individual rool boxes Their components are rools that maintain all their
specific serings Each group also becomes a template, containing all actribute setzings

= Exercise: Migrate existing customizations

1

Continuing in Bldg dgnlib, in the Customize dislog box, select Fike > Import > From
Settings Manager.

In the Select Sertings File to Import dialog box, select \data\bldg stg from the class
dara ser.

Click Open

An Informarion dizlog box informs vou that the file was successfully imported
Click OK

A new tool box named after the DGN file is added to the User Tools

Right click on the Bldg dgnlib wool box and select Rename

Rename the ool box Building

Expand the Building tool box and note the tool boxes listed

There is one for each Serrings Manager Group

Expznd cne of dhe ool boxes and selecr a ool

You can see any key-in associated with the tool, along with any other properties that
were set for the component The Template Path specifies the element template from
which the atributes such as color and weight will come.

Drag the Building User Tools to the root level Bldg dgnlib User Task and drop them
Move the Building task under the Landscaping task

The new wools are ready for use

~» HExercise: Additional settings imported from the Settings Manager

1 Condnuing in Bidgdgnlib, in the Customize dialog box, select the Templates wab
2 Expand Bldg dgnlib
3 Expand the Annotwrtion emplate group.
4 Expand the Text template group and select one of the templates
MicroSation V8 XM Ediden Admin Capyrighs £ 2007 Bentkey Syswmis Incorporawed Da Net Duplicare
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Note the general amributes as well a5 the text overrides that were ser for the

compoenent when created using the Settings Manager

5  Select Elewent > Drmension Styles and Elewrent > Mudti-ling Styles from MicroStation'’s

maln menu bar

Dimension and Mulu-line swles were also imported

Importing an m01 file

To import a legacy mO1 file, first creaze an Interface folder for the m01 file (for example,
\Workspace\Interfaces \OldInterface) in Windows Explorer Place the m01 file there. Then
open MicroStation using that interface

When you open the Customize dialog box, the customizadons from the .m01 file will appear
under the MicroStation Applicadon tools Work with them now just as vou would defaulr

MicroStazion Application tools

Reporting on customizations

You can generate an HTML report on ali the template, custom tool box, custom tool, task,
and custom menu datz in the open DGN file

=>» Exercise: Report on the customizations

1 Conunuing in Bldgdgnlib, in the Customize dizlog box, select Unlinies > Generate
HTML Report

2 Specify 2 name and location for the HTML file in the Define HTML Reporr File
dialog box

The default is to creare a file named after the DGN file in the current folder

3 Click Save

An HTML file opens. It contains information abour all the template, custom ool
box, custom rool, task and custom menu dara in Bldg dgnlib

4  Close the HTML file

Exporting and importing custornizations to XML

You can import and export to NML files in order to edit tool boxes, tools and templares with
an XML ediung wol

Once user tools and tasks have been created, select Fie > Exporf > XML in the Customize

dialog box

Do N Dueplicae
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Select 2 Jocaznion and name for the file

- <liodaDaiz namas Centerline® showChildren="false’>
- CBECRATTDELES
- cUstn_ElamentParamz wring="Ustn_ElementParams 03 00%
- <levelss
- zlavel»
eMaluaz 3o alugs
< flzvel
w/Levelss
- <Colpts>
- zColars
avalue»0,1,2:0,255,0)\\\ </ Values
</Colars
<footores
<LineSiyies>
- <LinsStyles
<Valuesde/Values
</LineStyies
</linaSiyiess
- cweightss
- 2Weight>

P T L VAT T

A portian of the XML file experted from Bidg dgniib

Managing custornizations

The MS_GUITASKTREEROOT configuration variable specifies root rasks Set this variable and
then refresh the task list Users will only see tasks that are under the root task in the task list
= Exercise: Define the root tasks a user can access

1 Continuing in Bldg dgnlib, on the Tools tab of the Customize dialog box, create a
User Task for Bldg dgnlib named Finalize

Move it above the Printing task
In the left frame, expand the Building User Tools

Drag the Borders twols to the Finzlize rask

v B oW N

In the left frame, select the MicroStation Applicaton wols References rool box and
drag it to the Finalize task

Open the rask list and note that the Finalize tasks are included.

Select Workspace > Confignration

Create a new configuration variable named MS_GUITASKTREERGOT with the value

Finalize.
9  Exit the dialog boxes, saving the changes
10 File > Close

11 Open Bldgdgnlib and click the Task List icon

Oniy the Finalize tasks are available
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< Exercise: Resert the configuration variables

1

2
3
4

Continuing in Bldg dgnlib, open the Configuration dizlog box.
Delete the MS_GUITASKTREEROOT wvariable
Exit the dialog box, accepting the changes

Select Fife > Clore

Working with Menus

AMicraSmton VE NN Edidon Admin
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You can edit and create menus on the Tools tab of the Customize dialog box.

Creating menus

@:

Select Menu from the Tasks/Menu opdon list above the right frame Then use the tools
provided to create new menus and menu items

2 Exercise: Creare a menu

1

10
11
12

Open Bldg.dgnlib.
Open the Customize dizlog box

On the Tools tab, select Menu from the Tasks/Menu opdon list

Select Main Menu
Click New Menu
Reaame the new menu Building

To insert a mnemonic, insert the tlde character before the characier vou want o he
the accelerator

Place the cursor at the beginning of the word Building
Press Shift + ~ before the B in Building
~Building

Select the menu and click the Move Up arrow, or drag and drop, to move it above the

Help menu
Right click on the Building menu.
Select New Menu from the pop-up mena

Name the new menu Tools
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Adding tools to a menu

= Exercise: Add tools to the menu

T Continuing in Bldg dgnlib, in the left frame of the Tools b in the Customize dialog
box, expand User Tools.

2 Expand Bldg.dgnlib
3 Seclect the Planning tool box and drag it to the Tools sub-menu
The tools are now accessible from the main menu bar
You can also create 2 menu entry that opens a tool box
Right click on the Tools sub-menu entry and select New Menu Item
Rename the new menu item Modificatuon
6 In the Properdes section of the dizlog box, Command Dara section, enter the key-in:
CUSTOMIZE OPEN TOOLBOX MODIFY

7 Select Bulding > Tools > Modification o open the ool box

Menu items

% Exercise: Add additional menu items

1  Condnuing in Bldgdgnlib, in the right frame of the Customize dialog box, right click

on the Building menu.
Select Add New Menu Separator

Righr click on the Building menu and select New Menu ltem from the pop-up menu

Name the new item Dimension Styles

oW N

In the Properties section of the dizlog box, Command Data section, enter the key-in:
MDL KEYIN DIMSTYLE DIALOG DIMSTYLE QPEN

The Dimension Styles dialog box can be opened from the custom menu

6 Right click on the Building menu and select New Menu Item.

7 Rename the menu item Finalizadon

8 Enter the key-in

CUSTOMIZE OPEN TASK Finalize

This entry opens the Finalize rasks that vou created as a tool box

Copyright € 2007 Beatder Systems incomporind D Nen Puplicare
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Screen Menus

Additional menu properties

As with wols, the Dimension options determine whether a menu will be available when
working in 2D DGN iiles, 3D DGN files, or both

The Shorteut field for new menu items lets you sefect shortcut keys to be used when selecting
a menu item If a shortcut is already used, it is dimmed in the list of options and is not
available

Screen Menus

You can also customize the MicroStation user interface by using screen menus. A screen
menu is created as 2 design file and can contain menu blocks of varied shapes and sizes, just
like a digitizing rabler menu The difference is that a screen menu is displayed on screen in its
own resizable window Users click tools to select them. You can display and use up to five
screen menus simultaneousiv

The procedure for drawing screen menus is like drawing digitizing tablet rnenus See the Help
topic Setting Up Projects > Workspaces > Cusiomuzing the User Interface > Screen Menns for
customizing instructons
2 Exercise: Attach a screen menu
1 Condnuing in Bldg dgnlib, open the Key-in browser.
2 Enter the following and then press Enter or click Run Key-in:
AM=v8menu dgn.Command,s]

The screen menu consained in the Command model from V8menu dgn appears in a
window entitled Screen Menu 1. Users click on the desired command o invoke it
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3 Close the screen mena.
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Dialog boxes

Dialog boxes

MicraSmzon VE XA Edidan Admin

120006

File Selection Dialog Boxes

Windows style dialog boxes are used for file selection dialog boxes such as New, Open and
Save As, and also the MicroStation Manager. The funcdonality vou 2ssociate with nadve
Windows file selection dialog boxes is available when using them For example, you can right
click on listed files to rename or delete them, create sub-folders, display file sizes, ypes and
modification dates and change the file list sortng order Double click oa a file name to open

the file

In the Windows style file Open dialog box, the View Menu setting, which determines the way
file names are displayed, persists across MicroStation sessions when using Windows XP. The
options are Thumbnails, Tiles, Icons, List (the default), and Derails.

A Windows style dizlog box can be ternporarily disabled by pressing Shift + Esc while it is
open The Windows version of the dialog box closes and the MicroStation standard one

appears.

Whether native Windows or MicroStation standard file selecdon dialog boxes are used is
controlled by the user preference Use Windows File Open Dialogs, in the Look and Feel
category of the [Workspace > Preferencec dialog box

Copiright € 2007 Beadey Svsiems Incorporared £ Noy Duplicace
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Dialog boxes

Dockable dialog boxes

Many dialog boxes can be docked. They can be docked as tabs or as a horizonsal or vertcal
panel next to another docked dialog box Tabs can be torn off to beceme floating dialog

boxes again

A Centeiline

g Delat

“f Diainege

4| Lines

= Lotives

-2 Lot rmbers

1 Mahers

L | Patcel numbers
| Right of Wey
1| Foad names

'.Lr-ml Lisplay 4 Femw

Elensent Sefection tool settingr and the Level Display dialog boxes doiked ar tans
As vou drag the dialog box, an opaque box indicates how it will be docked Select the title bar,

drag o the side and waich the box as it changes size To create tabs, drop one tide bar on

another title bar

You can move manv dialog boses and the tool settings window ourside of the MicroStation

applicaton window:

Transparent dialog boxes

The Tool Settings window and non-modal dialog boxes can be made wansparent so vou can

see more of a design

User preferences relazed to transparent dialog boxes are set in the Look and Feel category of
the Preferences dialog box When All modeless dialogs use same transparency is disabled,

-~
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Diatog boxes

right click on the dizlog box and select Transparency {rom the pop-up menu to set
transparency for each Individual dialog box.

The Transparent dialogs become opaque when receiving focus preference removes the
transparency from transparent dialog boxes when you are entering data
Key-in Browser

When the focus is home, pressing Enter opens the Key-in browser at the pointer location. To
dismiss it, move the pointer away.

NEWSESSION key-in
You can open a specified file and model in a new MicroStaton session using the key in
NEWSESSION ([filename],[model_name].

Working Units settings

In the DGN File Settings dialog box, the Working Units category has been reorgznized. The
controls from the Coordinate Readour category are included in the Working Units category.

‘[Active Angiz

Active Scale

Jhxiz

FColor
Eloment Allibites

JFenze

HGad

‘isometic

JLock:

Rendaiing

Snops

Sheam

Hiews

=1

Drawing Scale window

You can use the dockable Drawing Scale window to change DGN file sertings and on the £y
Open it by selecting Settzngs > Drawing Scale

Use it to see, or modify, the current working units, the current annotation scale, the current
ACS and its scale and w0 toggle the annotdon scale and ACS locks.
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Dialog boxes

The annotation scale optons are partcularly useful when creaung sheets that have derails ar
muliple scales

Right click in the Drawing Scale dialog box o toggle display of available options
NOTE: The units that display in the Master Units and Sub Unirs option menus can be

customized by editng the file units def The scale factors that display in the annotation scale
option menu can be customized by edidng the file scales def

Element Information dialog box

Selected elements are Listed in the top frame Information displayed in each section pertains
1o the element that is selected in the top frame If you selecr the <Selection™ entry vou can
view or modify properties for all selecred elemenss

Depending on the element types selected General, Geometry, Material, Text Formarung,
Annotadon Links, Image, Color and Attachment tabs, among others, may be availabie

@ N oSeleciions

i~ Chcle(1)

. BTy

Default
o 2
“iline Gile Elo
Wegm - B30
nBem Primaty
<1 Template Hone
o Trancpasency [
S Privdty G

| Geometry
[ St
1 End
rhength

3224328610
3992327097 |

THEBONG 12 34 P
Snappable

i difie;d

- ;'h:wr ‘

" Locked Unlocked

[ Rever Data i - ot

’ !;fEI Mn'rl;.'
GLURE

Right click on each section’s tide bar to add or remove fields. Right click on an individual field
to hide the field '

You can view and modifv element properties such 2s color, weight and swle or extended
+ poel -
properties such as snappable and locked in the General section. You can modify kevpoint
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Cialog boxes

coordinates and orientadon using the options in the Geometry secdon. If zn element s
linked, a Links section gives you access to information about the link. View or modify
additonal properties in the other available sectons

Browse modes

Selection, Model or File browse modes are available Selection maode is acrive by defauit You
can choose a single mode or you can display all three modes simultaneously on abs

Right click <Selection> in the selection tree and select Dialog Properties. This adds a Dialog
Propertes section. You can set the Browse mode o File, Selecdon, Model or All.

O Crclaf1}
-/ Linef)
-2t Shapatl)

E-A Text ABCOUY

<Saved Viewsy
sHamed Groupsy

‘Hame

Browsing 4 {Seleerton, Model, and File} nith eleaents organiged by Nanse
nformation about sefected elements, Selection tab, on the left
Information about elerments in the acitve model, Model tab, ou the right

Then, click on an element entry to see the element informadon about it

Orzganize selected elements by Name, Level, Color, Style, Weight.

A Tew ABCD
e Weight 1(3)
23 Shape

]

Weighl: {1]
2

(7] <Saved Views>
we «Mamed Graups>

i

Browseng Al elements organized by Weight
Information about selected elenents, on lefe
Information abont elenrents i the active wodel, on right - selected clnents are bughlighted

Right click on the top most entry in the tree at any tme to switch modes or the method of
organizaton. When vou right click on the top most entry in the tree vou can also select Atach
to open the Reference Arrachmenr dialog box
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The Active View

When browsing by File, click on each model entry o obzain information abous it. Righr click
on & model and select Mzke Active to switch to thet model Then, select elements in thar

model o obrain Informaton

Selection | Model

+ o rTag Selsy

[
R -
£ 7-

Browsing A4

Shorteuts

A shorteut for opening the Element Information dialog box is 1o reset and press on an
element and select Properties from the Reser pop-up menu

To open an abbreviated version of the Element Information dialog box, the Quick Info
dialog box, do the following With any rool active, point at 2n element and press and hold the

Alvkey Then, reset

F NOTE: To open the Element Informaton dialog box from the previous editon, use the key-
in ANALYZE ELEMENT

The Active View

MicroSuzon VB NN Edidon Admin

1278706

MicroSzation has an acuve view that is indicated by a highlighted dde bar A view is made
active by entering a data point within it, clicking its dede bar, startng a wol from the view’s
view control tools, or right clicking within it The active view is used by view controls like Fit

View:

Previously, when a tool like that was selected from the View Contro! tool box rather than a
view window’s view controls, users were prompted to select the view on which they wanted to
act Now the active view is auromaucally acted upon when the view control is selected. There

is no prompr 10 select a view

Caprright € 2007 Benroy Svstems Incorporand Do Nor Duplicate
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PopSet

PopSet

PopSer lets the wol settings window hide auromatically when a tool’s funcdon is execured
Toggle PopSet by clicking on the icon in the Primary Tools toot bar

Properties

Right click on the PopSet icon znd select Properties to open the propertes dialog box. If
Auto-Positon Tool Setdngs is enabled, tool settings will always redisplay centered on the
pointer, or as close to the pointer as possible, near the tool you are selecting,

You can make the tool settings open close to the pointer on a orne time basis by pressing Cul

+ Space If vou diszble PopSet you can stll invoke this behavior by enabling Allow Cel +

Space When Disabled in the properties dialog box

*  You can change the number of seconds that elapse before PopSet hides the ool sertings
after a new tool is selected using the New Tool Delay field

»  The Hide Delay field specifies the number of seconds until PopSet hides the tool settings
after the pointer is over a view

«  Hide border sets the size of the border, in pixels, azound the tool settings window in
which the presence of the pointer causes the tool settings to hide. If ser to zero, the tool
sectings window will always be hidden when the pointer is removed

+  To restore PopSet’s behavior from the previous edition, enable Auro-Position Tool
Settings and set Hide Border to 0

Reset Pop-Up Menu

AMigroStazian V8 NN Ediion Admin

12:1 6p

If vou selected the default MicroStation behavior in the First Reser dialog box, place the
pointer over an element and press and hold the reset buon to open a shorteur menu that
provides convenient access to tools for manipulating that elemenc. Opdons change
depending upon the element. There are also Cut/Copy/Paste options and Element Selection
options. Select Properties to open the Element Information dialog box.
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Project Explorer

Managing and organizing project content is made simpler by providiog users with an index of
their project-specific information This logical, structured view of project content lets users
easily navigate the project. Store project links in DGNLIBs.

If vou have a MicroStaden installadon that includes the delivered examples you can follow

along with the following exercise

2 Exercise: Using link sets defined by MS_DGNLIBLIST

1
2

[55 B N Y]

6

9

Select Fule > Close vo return o the MicroStation Manager.
Set the following:

User: examples

Pragect: Building

Open BSI300AE101-Plan dgn

Select File > Project Esplorer.

In the Project Explorer, click Manage Link Sets

In the Link Sets dialog box, the Link Set List Mode option menu indicazes that vou
are seeing link sets in files that are defined by the MS_DGNLIBLIST configuration

variable

You can also choose 1o view those found in the active {ile or those in a file you select
Select Workspare > Configuration

In the Configuration dialog box, select the Primary Search Paths category

Note the expansion of the DGN Library List variable (MS_DGNLIBLIST}.

This is where the DGNLIB thar contains the link sets resides

Click Cancel to exit the dialog box

10 In the Link Sets dialog box, select Active File from the Link Ser List Mode opton

MicroSurion VE NAM Edidng Admin
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menu

Coniiguied Litvaties |!-¢5-_DGI-!LIBLISTI LI_‘:'\_I
Conhigured Libranes (M5_DEHLIBLIST) IR
Actve Fie [ASIIMAEIN Fandgnt - <~ -~
Selecled File
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There are no link sers defined inside this file They are all being read from
DGNLIBs Each example project conrains 2 DGNLIB with example link sets

11 Select File > Close vo return to the MicroStation Manager
12 Set the following:
Uiser: Bentley Insdtute

Project: MSVBXMAdmin

Storing project data

Project dara includes design and sheet models contained within DGN and DWG {iles, as well
as other file formats It also includes supporting documents such as spreadsheets and links to

PDFs and URLs

When you are working in 2 IXGN file you can open Project Explorer (Fue > Project Escplorer)
to see linked data. If link sets exist in the open DGN file or in the configured DGN libraries,
they appear in the Project Explorer dizlog box when you open it

A link set is a group of links w files, models, references, saved views, and supporting
documentation Each link set is an independent object stored as non-graphical dara in a DGN
file or in 2 DGN library. The Link Ser dizlog box is where you add, copy, rename, delete, and
import link sets

You can create a lick set for 2 projecs in the project’s index model Create folders for all
resources, specifications, details, design work and sheers Next, create links o the actual
project darz. Then use Project Explozer £ associate the data links to text itemns in the index
file The index file can then be used to directly open project data or the link set can be opened
m any file and users can use Project Explorer to navigate the project

Linked models, saved views and references

= Exercise: Exploring a project
1 Open \dgnlib\structural dgnlib
2 Select File > Project Excplorer.
3 In the Project Explorer, click Manage Link Sets
Note thar the wols in both dialog boxes are graved out

4 In the Link Sets dialog box, select Active File from the Link Set List Mode option

mena.
ép‘kclivé Fila |shuctural. danlib] :J X
Confiaed Lisrarips (48_OEHLIBLIST}
Selecled Fila
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Now vou can edit the project. When projects are read from DGNLIBs they cannot
be modified.

In Project Explorer, select the Structural project from the available project list

Expand the Design work folder

Expand the Structeral dgn, Structural model link

Model ink names include the file name followed by the model name.
Expand the Saved Views folder.

Each design link includes a Saved Views folder where any saved views that are
present are listed and a References folder for references Right click on a saved view
or reference and select Open to redirect to the saved view or model. As saved views
or references are added to 2 model, Project Explorer updates to reflect them.

Expand the Strucrural dgn, Strucrural Composite model link

Expand the References folder 1o see the linked references.

Right ciick on the link to the reference Ref-1, Structural dgn, Foundadon
Select Open

You are redirected to the referenced Structural Composite model in the file

Structural dgn

TTP: Since level masks are not saved for references vou may want to create 2 saved view and

link to it to preserve level status.

Linked elements

When placing Detailing Symbols, users have the opton to specify a link target that links the
annotation 1o a file in a project

> Exercise: Linked elements

Continuing in Structural dgn, select Previous Model wo requrn to structural dgnlib
In Project Explorer, select the Suwuctural project from the Link sets from list
Expand the Derails folder

This folder contains links to detail models.

Right click on Structural_Proi dgn, Meral deck section

Select Open

Coparighs © 2007 Bentley Svstems, Incompurated (30 Nosz Duplicase
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Creating Projects

The Metal deck sectdon model in the file Strucrural_Proj dgn opens
6 In the file, right click and press over the Detziling Symbol BEAM SIZES

When the pointer passes over the annotatdon conmining the link, you see a link icon.
Pop-up informarion notes the link path.

7 Select Follow Link > Beam sizes
The linked beam sizes schedule opens in Excel
8 Exit Excel
= Exercise: Links to documents

1 Select Previous Model o return to structural.dgnlib.

2 In Project Explorer, select the Structural project from the option list and expand the
Specifications folder

These are the linked support documents.

&l 3 Expand the Base Plate schedule Excel link
- 4 Right click on the worksheet 24 & zbove and select Open
The Excel file opens 1o the specific worlisheet
Project Explorer supports links to office documents and even specific ropics in
therm. When vou add a link you can expand the item you are linking to and selecta
specific aspect to which vou link
5 Exit Excel
i 6 Expand the Height.doc Word link
Expand the Headings folder
These are all the Heading styles in the document
e 8 Right click on Height 72 2nd select Open

You are directed to the specific section in the Word document You can creare the
link direcdy to this heading rather than linking to the entire document

9  Exir Word.
10 In Project Explorer, Specifications folder, note the link to Height doc, Height 72.

This is  direct link to that heading

Creating Projects

o

A project consists of link sets You can access link sets that are stored in three location
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Creating Projecis

* In Configured Libraries mode, link sets from all DGNLIBS identified by
MS_DGNLIBLIST are shown. All users can use the data, but they cannot modify it

+  In Actve File mode, vou can build 2 link set only in the current file No one else has
access to the link set when vou are in this mode

»  In Selected File mode, vou can select a particular file from which to view link sets In this
mode anyone can modify 2 link set without being in the file

Once link sets are created or selected, the Project Maintenance tools in the Project Explorer
dialog box are used to create and delete entire projects.

Folders are used to organize projects Create 2 hierarchy of folders within a project then
create the links and set the order in which the links appear, dragging and dropping as with
Windows Explorer. Use the New URL tool 1o create a link to a URL, MicroStation key-in, or

e-mail address in the open link set

The link stores links to fles and models, but reference attachments and saved view definitons
are extracted from the linked file. Links are static, so file locaton is important
= Exercise: Create a link set

1  Open \dgalib\Building_Proj dgalib

2 In the Link Sers dialog box, Active File is selected in the Link Set List Mode option

menn
None are listed because none exist in this file
3 3 Click New Link Set
In the Create New Link Set dialog box, enter the name Building project
5 Click OK

The project is added to the file and vou can add folders and links in Project Explorer

3 Exercise: Build a project

A1

J 1 Contiruing in Building_Proj.dgnlib, in Project Explorer, click New Folder
2 Rename the new folder Design.
3 Click New Folder again 1o create another top level folder
7 NOTE: Make sure no orher folders are selected when creating a new top level folder
to avoid creating sub-folders
4 Rename this folder Sheers

L 5 With the Sheers folder selected, click New Link
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Creating Projects
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When ¢reating links vou can select one or more files To make a link portable across
direcrories, projects, and nerworks vou can enable the Save Relative Path check box
You can also click the Directory History icon 1o setect a configuradon variable whose
definition points to a folder

Enable the Save Reladive Path check box

Select \dgn\A300AE9-Overall.dgn and click Open

In the Crearte Links dialog box, expand A300AE9-Overall dgn

Select the Print sheet model

Click OK

A link to the sheet model is added to the project.

Select the Design folder

Click New Link.

Select the files conc dgn, elec.dgn, equip dgn, hivac dgn and pipe dgn and click Open

You can use the List tab to change the view in the Create Links dialog box from a
hierarchy tree to a list of all the linkabie components contained in it, such as models,
saved views and references or worksheets ot headings

=]

Icons precede each available component to help you idensdfy them more easily
In the Create Links dialog box, click the List tab.

Select all the design models and click OK.

Links to the models populate the Design folder

Drag and drop to reorder the links so all the Default models appear first in the list

Renumbering sheets

You can number a single sheet model, but if a folder contains muldple sheet models you can
number all of them at once.

To renumber muldple sheets, right click and select Renumber 1o open the Set Sheet Number
dialog box Enter a number for the first sheet model in the Starr Index field. Enrer the
number by which you want to increase each subsequent sheer number in the Increment field
Right-click the folder containing the sheet models and choose Validate from the pop-up

renu

Once you assign a number 1o a sheer model, the number appears after the sheet model’s name
i the Projecr Fxplorer dizlog box
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Creating Models with Links

9  Right click on the worksheer link 1o Sheet 1
) 10 Select Add Link 10 Element
11 Enter a data point on a horizontal section of pipe in the Front view.
The pop-up information now shows the path to the linked spreadsheet

12 Reset

«» Exercise: Follow the link

1 Continuing in pipedgn, right click and press over the section of pipe that you just
linked

2 Select Follow Link > pipe sizeixls Sheet 1
The spreadsheet opens
Exit BEaxcel

4 Close the Link Sets dialog box

Deleting links from elements

To remove 2 link from an element, right click and press on it and select Properties from the
pop-up menu. In the Links portion of the Element Info dialog box, right click and select
Delete Link Click the button to the right of a link’s name 10 open the Properties dialog box,
which lists the properties of the selected link.

Link Properties
In the properties dialog box, the File Name property is the stored portable file name that can
include a relative path or a configuration variable if one was set. The Full Path property shows

the location where the file is located . If the file is not there, the link is broken and the full path
field will be blank.

Creating Models with Links

You can select existing models to link using Project Explorez, but you can also define links for
models when vou create them

> FExercise: Create a linked sheet model

1 Continuing in pipe dgn, open the Models dialog box
2 Create & new Model with the following parameters:

Iype: Sheer : 2D
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Creating Models with Links

Name: sheet layour
Sheet Nuntber: 8

Sige IS0 A2
Create Link: Enabled and navigate to and select the \Sheets folder

% NOTE: A project must be active in Project Explozer to create a link
Click OK

In Project Explorer, look at the Sheets folder

w

The pipe: sheet layout model is included in the project
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Project Explorer Lab

When vou are working in 2 DGN file you can open Project Explorer to see all the data that is
linked to a project The Project Explorer and Link Sets dialog boxes can be docked as tabs, or
as horizontal or vertical panels, to create more space To follow a link, right click the link and
select Open from the pop-up menu

Remember that vou can link to:

-

Microsoft Word documents, including sectons and bookmarks within the documents
Microsoft Fxcel workbooks, including specific worksheets within the workbooks
Adobe PDFs, including bookmarks within the file

Web sites, MicroStazion key-ins, and e-mail addresses

Any other file type

Create a Project Containing Data Set Files

When vou complete the exercises in this lab, vou will be able to use Project Explorer to
navigate through the data set for the remainder of this course

Cieate the folder structure

> Exercise: Create the folder structure

1 Open \dgnlib\MSVEXMAdmin2 dgnlib

2 Open the Project Explorer
K 3 Open the Link Sets dialog box

4  Select Acdve File from the Link Ser List Mode option menu
ij 5  Creare a new link ser entided MSVEXMAdmin2.
o= & In Project Explorer, create top level folders, named as follows, in the following order:
o Expanded Funcronality

Models
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Create a Project Containing Datz Set Files

References

Raster

Design History
Google Earth Tools

@ NOTE: You can drag and drop to reorder the folders

These folders represent the remaining chapters in the course guide

Notes:

Link the files

-+ Exercise: Create links for the Expanded Functionality chapter

T  Continuing in MSVEXMAdmin2 dgnlib, select the Expanded Functionality folder.
Click New Link
In the Create Links dialog box, enable the Save Relative Path check box

Navigate to the data set \dgn folder.

oW

Select the following files:
Dimensions dgn
field_reportdgn
intersecton dgn
lavout dgn
manthoies39 dgn
namedfence dgn
parkside dgn
stairwell.den
survey.dgn
update_site dgn
zonesdgn

& Click Open
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Create a Project Containing Date Set Files
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10
11
12
13
14
15
16
17

In the Create Links dislog box, on the Tree b, expand updaze_site dgn
Select the Default model.

Expand surveydgn

Press Curd and select the Default model.

Espand swairwell dgn.

Press Cirl and select the Core model

Expand parkside dgn

Press Cerl and select the Defanit model.

Expand namedfence dgn

Press Curl and select the Default and print layout models.

Expand each of the remaining files and select models as follows:

manboles39 dgn: Manholes [3] model

- Alayont dgm: Walls model

18

intersectzon dgm: Default model

Jietd_report dgm: Default model

Limensions dg: entire design file
zones.dgn: Defzult model

Click OK.

These are the models you need 1o complete the exercises in the Expanded Funcionality

chapter

You can create 2 Project Explorer ink when vou create 2 model and you can also impose a
model-specific line style scale Additional enhancements are a sheet number property for
sheet models and the ability to navigate a history of the models you have visited.

“» Exercise: Create links for the Models chapter

1
2
3

Conenuing in MSVEXMAdmin2 dgnlib, select the Models folder
Click New Link.

Select the following file:

parcels.dgn

Click Open

In the Create Links dialog box, on the Tree tab, expand the file and select the Global

Scale and Use Annotation Scale models

Click OK
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Create 2 Project Containing Data Set Files
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Reference features include the zbilicy to menipulate references as vou would elemerts, using
the standard manipulaton rools. Amachment sertings include options for selecting Saved

Views and Named Fences, Named Groups, Revision (if Design History is used), and Global
Line Stvle Scale New reference display serings include Transparency, Priozity and Plot as 3D

(PDF)

2> Exercise: Create links for the References chapter

1
2
3

Contnuing in MSVBXMAdminZ dgnlib, select the References folder
Click New Link

Select the foliowing files:

division_plan dgn

REFPlan dgn

training,_grid dgn

Click Open

In the Create Links dialog box, on the Tree tab, expand each file and select the
following:

REFPlan.dgm entire design file

division_plan dgi: Defaclt model

tramng. grid don: Ground Floor Sheet [1] model
Click OK

The Raster Manager dizlog box has a hierarchy tree in which the open DGN and its antached
references are listed A properties frame provides information abour the selected arrachment.

~» Exercise: Create links for the Raster chapter

1

R wWN

Continuing in MSV8XMAdmin2 dgnlib, select the Raster folder

Click New Link

Select areaplan dgn and conrours dgn

Click Open

In the Create Links dialog box, on the Tree b, expand each file and select the

following:

areaplan dgn: Default model
conttonrs dgi: Model-1

Click OK.
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Create a Project Containing Data Set Files

Design history stams is indicated by an icon in the status bar You can set the design history
revision number format for individual DGN fles You can also combine revisions, retire

revisions and tag revisions

> Exercise: Create links for the Design History chapter

1
= 2

3

4
@

6

Contnuing in MSVEXMAdminZ dgnlib, select the Design History folder.
Click New Link -

Select the following files:

city_layout dgn:

MidstateV_work dgn

Click Open

In the Create Links dialog box, on the Tree b, select both design files

Click O

MicroStation’s Google Earch tools ket vou export geometric data 1o the Google Earth
applicaton so that it can be viewed in the context of satellite data, zenial photography, maps
and other geographical data

*» Exercise: Create links for the Google Earth Tools chapter

1
= 2
3
4
& 5
6

Condnuing in MSVEXMAdmin2 dgalib, select the Google Earth Tools folder.
Click New Link

Select the following file:

placemark dgn

Click Open.

In che Create Links dialog box, on the Tree wb, select the entire design file

Click OK.

Set the Link Set List Mode to configured libraries

2 Exercise: Set the mode back 1o Configured Libraries (MS_DGNLIBLIST)

= 1 Continuing in MSVEXMAdmin2 dgnlib, open the Link Sets dialog box
2 Select Configured Libraries (MS_DGNLIBLIST) from the Link Set List Mode
option menu
This gives vou access to the data set project DGNLIB regardless of the file vou open
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Create & Project Containing Data Set Files

3 Close the Link Sets dialog box
4 In Project Explorer,rselect; the MSVEXMAdrmin project

Now vou can dock Project Explorer and navigate the data set project
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Expanded Functionality

Color
MicroStadon V8 XM Editon offers PANTONE and RAL colers and gradient fills. In the
Active Color dialog box you open from the Attributes tool bar, and other locadons where you
specify element color, tabs let you choose the type and specific color 1o use.
Notes:
*  The first tab ts the defaulr color tab, which lets you select a color from the awached color
table
*  The second b is the True Color wab. Select a color by specifving true colozs. Use the
Color Model option menu to select between RGB (Red, Green Blue, 0-255 or 0-1), HSV
(Hue, Satration, Value) and CMY (Cyan, Magenta, Yellow).
Click and drag the eye dropper icon 1o select and match any color visible on the screen,
even from areas ouside the MicroStaton applicaton window.
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Caolor

+  The third tab is the Color Book wb. When 2 color from 2 color book is assigned 10 an
element the book name and color name are stored in the element

*  The Gradient Fill tab is available when you set £ill color and the fill rype is opaque or
outlined A gradient fill takes multiple colors and interpolates them across the element
surface. You can select colors by clicking the tiles below the bar

Sertings provide options to control the gradient Set the type of gradient o Linear,
Curved, Cylindrical, Spherical, or Hemispherical

Linear, cylindrical and spherical gradients
Color Mode sets the number of points where vou can change the color. These are calied
Keys You can add keys by setting this to Multipie and clicking anywhere in the bar. To
delete an additional key, select the box on the upper part of the key. It will rarn blue Then
press the Delere key

Madtinle Keys
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Viewing Enhancements

Invert reverses the siart and end points of the gradient

Enable Center to center the gradient in the center of the element

You can apply gradient fills t¢ closed elements directly or by applying an element

template

Color boaoks

Color boolss can be stored in DGNLIBs. A set of DGN libraries containing color books is
delivered with MicroStation. Along with the Standard color book, the standard PANTONE
and RAL color books are provided for communicating industry standard colors

A NOTE: The PANTONE and RAL color books are copyrighted materials Neither the boolks
nor the colors specified within the books can be renamed or modified.

o You can create additional boolks using the Sermgs > Color Books Color Beok Ediror dialog box
,_:] Selecr File > New to name the custom color book, and then click Creare Color to open the
Modify Color dizlog box where the color is defined.

Viewing Enhancements

The View Attribures dialog box includes sertings related o element, level, and reference
transparency and display priority Bution assignments are expanded to allow a greater degree
of customizadon Mouse view controls provide easy view navigaton.

View attributes

Find the View Arributes ool in each view window’s View Control tool box The View
Arurributes dialog box includes serings related to element, level, and reference transparency
and display priority Rendering view atiributes, such as Partern and Bump Maps, are integrated
into the View Auribures dialeg box

Ly v
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Function Keys

When vou change a view attribute setting in the View Arributes dizlog box the new serting is
immediately applied to the selected View Number To change settings for all views, enable the
Apply To All check box first

Rotating to the AccuDraw drawing plane
In situations where users need precision in rotating views, they can use the Acculraw

shorteut key-in <R> <V>, Rotate View, which lets vou rotate the view to the current
Acculraw drawing plane crenration

Function Keys

The default function key menu lets vou easily navigate the task-based user interface and
access frequently used tool boxes and dialog boxes

Fi halp

F2 lazh manu

F3 inpuimanager menu main

4 inpulmanage cunenttesk
F5 dialog viewselling: posup
33 disiog namedvizwiz

] diziog cmdiowze popup

Fi1g diglog tookettings

11 accudiaw disfog

Fi2 inputmanagsat home

Task Navigavon toc box task List <F2>

Main rool box: <F3>

Task Navigaton tool box tools of the acuve task: <F4>
View Arwibutes dialog box: <F5>

Tool Serings window: <F10>

AccubDraw window: <Fil>

As with previous editions, vou can customize function keys using the [Forkspace > Function
Keyr Function Keys dialog box
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Acculraw Enhancemenis

AccuDraw Enhancements

AccuDraw has increased configurability and there are additional shorteut key-ins In Polar
mode the AccuDraw window’s fields for distance and angle are labeled with icons rather than
text

i
e

When using polar coordinates, the Auto Focus Fields option on the Operation tab of the
AccuDraw Sertings dialog box lets you use the <A> and <D> AccuDraw shortcuts to set
focus to the selected field and lock the current value.

If the serting is off, the <A> and <D> AccuDraw shorteuts lock the carrent value without
affecting the focus

Display options

Additions to the display tab of the AccuDraw Settings dialog box let users customize the
compass and the AccuDraw window

Configurable compass fill color

Set the Acculraw compass fill color using the Fill opton menu
Configurable window size

Adjust the width of the AccuDraw window using the Dialog Size opton menu
Displaying coordinates

If Display Coordinates is enabled, drawing plane coordinates are displaved in pop-up
informaton with the pointer.

Shortcut key-ins

Shaded shorrcurs are new to MicroStadon V8 XM Edition. There are several that relate
specifically to the ACS.

7 Show Shortcuts Opens the AccuDraw Shorrcuts window

- Bump Tool Setting Move rool sertings to the nexr value o set

A Lock Angle Toggles the lack swmtus for the Angle value

B Base Rotaton Rouates the drawing plane 1o the last non-content retaton, that is: Top.
Frong, Side. View, or Auxiliary Selecr the shorteut again o return the
drawing plane to its previous rotan
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AccuDraw Enhancemants

C Center Snap Activates Center snap mode
D Lock Disance Toggles the lock status for the Distance value
E Crcle Rotation Rotates berween three main planes: Top, Froat, and Side (3D only) This
2350 warks when your original piane is an ACS ar context rotation, 50 vou
do not have o use B, RY o rotzte to 2 90 degree plane
Enter Smart Lock Smart Lock
« In Recungular coordinates, locks X to 0 if the pointer is on the
drzwing plane y-axis or sets Y to 0 if the polnter is on the x-axis

- 1In Polar coordinates, Jocks Angle to 07, 90°, -90°, or 180 if the pointer
is on a drawing plane 2xis or otherwise locks Distance to its last entered
value

F Front Rotatien Rotates the drawing plane to align with the 2xes in a standard Front view

GA Get ACS Retrieve a saved ACS

G Go 1o Keyin Opens or moves focus 1o the Key-in browser

G5 Go 1o Settings Opens or moves focus to the AccuDraw Sectings distog box

GT Go o Tool Sewings | Moves focus 1o the ool settngs window

HA AccuDraw on Hald | || AccuDraw oa Hold cempoiszily disables AccuDraw

HS AccuSnap Toggie AccuSnap Toggle toggles the seate of Accudnap off or on

HU Accubnap Suspend AccuSnap Suspend stops AcenSnap unt! the next rool is selected

I Intersect Snap Activare the Intersect snap

K Snap Divisor Ogpesns the Keypoint Snap Divisor serings box to set the Snap Divisor for
Keypoiat snapping

[[ LA - [[Lock ACS I[ ‘Fopgles ACS plane lock.

LI Lock Index Lorks the current index sete IF an axis or distance is not indexed, <L>
disebies indexing. On the other hand, if an axis or distance is indexed,
21> locks indexing, The effect is temporary, lasdng only untl you enter
another data point or run the shortcut again

Lr Lock Grid Plane Toggles ACS grid plane lock, which roggles the ACS plane and ACS plane
snap locks, and the grid view attribize for.all views

15 Lock Plane Snap Togeles ACS plane snap lock

LZ Lock Stcky Z Toggles Sticky Z Lock When used in conjuncdon with ACS Plane Snep
Lock, it force a series of snap points 16 lic on the active ACS XY plane
“Z=0)

M Paiar Keyin {multi) Opens the data point Key-in sertings dislog box for entering muluple data
points

N Nearest Snap Activate the Nearest snap

O Set Crigin Moaves the drawing plane origin to the current pointer position

P Point Kevin (single) | Opens the daca Point Key-in sectings box for entering 2 single data point

Q Quit Acculraw Deactivate AccuDraw

RA Rotate ACS Lised 1o permanently rotate the drawing plane Because it rotates the
current ACS, this rotation remains active after the current command
terminates

RC Rotate Current Rozates che drawing plane to the current ACS.

RE Rotate Efement You can define AcculDraw rotation by selecting an element Tool sewings
Jec you choase to move the origin or update the current ACS as well

f RQ | Retare Quick [ Used o quickly and temporarily rotate the drawing plane
[ RV {| Rouate View [} Rotate View puts the view into 2 dvnamic romtion mode
RX Rotate abour X Rotates the drawlag plane 90° about its x-axis
RY Rotate abour Y Rotates the drawing plane 907 abou is y-axis
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The Fence

RZ Rotate about Z Rotates the drawing plane 90° abour its z-axis

5 Side Rotadon Rotates the drawing plane to align with the axes in 2 standard Righe (side;
view

Spzce Change Mode Togples berween Recrangular 2nd Polar coordinates

T Top Rottion Rotates the drawing plane to align wich the axes in a standard Top view

vV View Rotation Rotates the drawing plane to align with the view axes

WA Write to ACS Saves the drawing plane slignment as an ACS

X LockX Toggles the lock status for the X value

Y LockY Topgles the lock stares for the Y value

z LockZ Togyles the Jock status for the Z value

The Fence

Copy/Move Fence Contents to New Design File

This tool lets you copy or move the contents of a fence to 2 new DGN or DWG file. The file
is given a name in the formar <filename_model>. Select 2 different file name by clicking the

magnifying glass.

Two modes define how contents are processed. Select Copy to copy the fence contents o the
new file The original elements remain in the active model. Select Move to move the fence
contents to the new file. Fence contents will be deleted from the actve model.

If you enable Switch to generated file the current file is closed and the new file is opened after

processing the fence.

% NOTE: You can still use the key-ins FENCE FILE (FF=) and FENCE SEPARATE (SF=)

Named Fences

Narned fences let you store and recall fences with names vou define. A separate list of named
fences is stored for each model Expand the Place Fence tool settings to see the list of saved

fences for the acuve model

The fences are stored as regular elements that can be manipulared with any of the
modification wols When a named fence is selected, the fence element highlights

Named fences can be used with the tools that use elements to define clip areas or volumes
such as clip volumes, masks and reference file boundaries
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The Fence

Creating Named Fences

Use Create Named Fence from Current Fence tool in the Place Fence ool settings to creare 2

new named fence

=2 Exercise: Create a named fence

1 Open parkside dgn, Defauit model

2 Select Place Fence (2 + 1) and expand the o0l settings
Named fences already exist in this file
Click on named fence Section II

4 Click Activare Named Fence

The area defined by the named fence is fenced
5 Select Fike > Print vo open the Print dizlog box

When a named fence is active the area to print is automatically set to Fence in the
print dialog box and the acdve named fence will be printed.

6 Double click on named fence Section IIT in the tool sertings
The print preview changes

7 Close the Print dialog box

Select Place Fence to dismiss the feace

9 Set the following Place Fence tool settings:
Fence Type: Block
Fenee Mode: Inside
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The Fence

10 Use diagonal corners of the grid surrounding Section IV to create 2 fence

% NOTE: Enable the Seitings > Snaps > AccuS nap serting Enable for Fence Create so
you can use AccuSnap during fence placement

Note that the grid and the grid designadons are in a reference. Elements from
attached references will be included in named fences if references are attached with

Live Nestng enabled

11 Click Create Named Fence from Active Fence

12 Name the fence Section ['V.

13 Select Place Fence to dismiss the fence

?’* 14 Open the Level Display dialog box and rurn off display of the level Grid in the

S reference {parkside dgn, Grid)
You can control display of named fence outlines using the display option in the ool
sertings

Le] 15 Click the Display check box for each named fence in the ool sertings.
pial 3
The boundaries of all named fences display Use this to locate named fences when
many exist in the same file
References

Elements from artached references are included in named fences if references are artached

with Live Nesting enabled
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The Fence
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You can select a named fence to attach a3 2 reference just as vou can select a specific model or
saved view Araching a reference from z narned fence creates an attachmene with all levels on
If you need to control display, apply the named fence as a clip volume and then save and
attach as a saved view.
= Exercise: Artach named fences as references
1  Open namedfence dgn, print layout model.
2 Open the References dialog box
3 (Click Atrach Reference
4 Azach parkside dgn, interactively, with the following attachment setungs:
Modet: Defaulr
L_sgreal Nawe: Secton 111
Onentation > Named Fences: Secdon 111
Seale: 1:1200
Live Nesting: Enabled
5 Enter a data point on the left side of the sheet to place the reference
Click Attach Reference
7 Armach parkside dgn with the following artachment settings:
Model Defauit
Lagica! Name Secdon IV
Orientation > Named Fences: Secdon IV
Seale: 1:1200
Iive Nesting. Enabled
8 Enter a data point on the right side of the sheet to place the referénce.

All feniced elements are visible in the sheet

Fence boundaries

When you select 2 named fence for accachment the Clip Boundary Element opton becomes
available in the Atachment Settings dialog box It also becomes available if you select a saved
view that includes a clip boundary. This option lets you choose whether a clip boundary
element is copied into the master file or associated directly to the clip boundary element in

the reference
= Copy to Master copies the reference boundary to the master file The boundary is not
associative and it can only be modified directy in the master file This is the default

setting.
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Levels Enhancements

You can select the copied boundary of a referenced named fence with Element Selecdon
and resize or move it. The original boundary does not change if the boundary element in
the reference is resized

+  Associate 10 Saved View associates the clip boundary directly to the boundary element in
the reference’s view. The clip boundary will automacically reflect any changes to the
boundary element in the reference

Clip volumes and masks

Use named fences with Clip Volumes and Clip Masks much the same way as you do standard
ferices Clip boundaries can be applied to a reference file from a named fence by selecting the
Nzamed Fence method
2 Exercise: Use a named fence as a clipping element
1 Continuing in namedfence dgn, open the Defaul: model.
2 In the References dialog box, click Attach Reference
3 Artach parkside dgn with the following attachment settings:
Maodet Default
Orientation: Coincident
Scale 1.1
]1;_] 4  Fit View by clicking the view control or double clicking the mouse wheel
In the References dialog box, click Clip Reference with the following tool settngs:

Merbod: Named Fence

Ulse References Dialog List: Enabled

Narsed Fenee: Section TT
Enter a data point 1o accepr the clip boundary

Fit View,

Levels Enhancernents

Enhancements to levels let vou select specific levels or filters to import into the active design
Levels also support transparency and priority.
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Levels Enhancemeants

Moving elements between levels

Right click on 2 level name in the Level Manager dialog box and select Remap Elements 1o
move elements from one level, or several levels, to a different level

When you select the menu item, the Remap Elements o Level dialog box appears so you can
make the change The selected level, or levels, are listed as the source Select the destinaton
level for elements that are on the source levels from the Desdnation option list.

Level and filter import

You can selectively control the levels or filters that are imported. If you only want to add
certain levels to 2 DGN or DGNLIB, select Leve/ > Import. You can select the specific levels
or filters you want to add to the file from the Level/Filter Import dialog box. The level
definition is imported directly into the file

Working with level libraries

The Modified column in the Level Manager shows whether 2 level has been modified A
bullet appears if one or more of the active file’s level atributes or properties differ from the
library source level Pop-up informadon listing the attribute or property that is out-of-synch
appears when the pointer is over the modified icon.

= NOTE: Properties are not synchronized unless they are specified by
MS_LEVEL_SYNC_ATTRIBUTE_LIST

‘T'h:-z colurnn indicates if an actachment level is also out-of-syne with the artachment source.
Set MS_LEVEL_DO_NOT_SYNCHRONIZE_ATTACHMENT _LEVELS_TO_DGNLIB if you do

not want 0 synchromnize the artachment level with the attachmesnt source

The nzme of the level library a level is derived from is listed in the Library column

Transparency and priority
Ser transparency and priority so elements obscured by other elements can be seen

«» FExercise: Assign priority and transparency

1 Open zonesdgn Default model

' 2 Click the View Awriburtes tool w open the dialog box
. 3 Enable the Transparency check box
=
e 4 Open the Level Manager
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Levels Enhancements
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Right click on 2 column heading and enable display of the Priority column.
Right click on a column heading and enable display of the Transparency column
Select the zones level.

Click in the Priodsy column for the level

R e B N - ST

Ser the priority for the zones level to 200

The zone 11D become visible because the level they are on has the highest priority in
the file

10 Select the zone boundaries level
11 Click in the Transparency column for the level
12 Set the transparency for the level to 30
The elements behind the filled boundaties become visible.
To boost display of other elements, set their priority somewhere in between.
13 Select the roads level
14 Set the priority for the roads level 1o 100

The roads become more visible.

Reference levels

Identify reference levels easily using the File column. This makes it easier to conirol
settings for reference levels. Right click to add the column.

The Modified column also indicates if a reference attachment level is out-of-sync with the
attachment source

The display state of attachment levels remains consistent regardiess of how they are

changed in the source file You no longer need to use the REFERENCE
FILECHANGED key-in to make display states consistent

MS_LEVEL_EDIT_NESTED_ATTACHMENT_LEVELS lets vou edit the auributes of levels
in nested reference artachments if it is defined
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Element Selection

Level option menu

The configuration variable MS_LEVEL_DISPLAY_FORMAT can be used to define the values a
user sees in the level display option menu in the Attributes tool box. The default setdng is N,
showing the name Set to D to use the description. Moze than one value can be used

_Filtar: (none}

Annalatisn[design notes] 4 &
s >0
v o [

Irlet{dzain inlets} « 3

Link numbaiflink 1D} “ w1

Narves and deseriptions shown int the option mens

The configuration variable MS_LEVE L_PICKER_WIDTH specifies the width, in pixels, of the

Level oprion menu

Element Selection

AcroSaton V8 N Edidon Admin
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The Element Selection tool’s selection merhods let you select by individual element or using a
block, shape circle or line The modes let you 2dd, suberact or invert selecdon of elements or

1o select and clear all.

Use the Individual merthod and the New mode so the tool works like traditional Element

Selection

Drag and drop operations

In previous editions you could move clements that had been selected with the Element
Selection tool by dragging and dropping them. You can now perform additional drag and
drop operations with selected elements

Copy

To copy selected elements rather than moving them, drag the selected element while pressing
and hoiding the Cuzl key When you move selected elements, 2 box follows the poinzer When
vou copy selected elements, a plus sign is added to the box You can use this technique to
copy elements 1o another DGN file if the file is open in another instnce of MicroStaton
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Element Selection

Named Groups

To add the selected elements to a named group, drag the elements 1o the specific named
group in the Named Groups dialog box and drop them on that group

Attributes

To change an active attribute setting to match the corresponding property of a selected
element, drag the selected element into the Attributes tool bar and drop it on the icon for that
seting To set the active line weight, users select 2n element, drag it to the Autributes tool bar

and drop it on the active line weight icon

To change all of the active atiribue settings, drop the element on the Symbology Preview
window in the Attributes tool bar.

Right click and select Symbology Preview to add it to the Auribures tool bar

You can do this with muldiple selected elements, but only if all the elements have the same
value for the property or properties.

Use this technique with elements in the active model or referenced elements. You can only
drag to set the active level or set the active line style to 2 custom line style if the selected

element is in the actve model.

Element rotation

Use options in the Geometry section of the Element Information dialog box to check and
change the rotation of an element. Use Element Selection to select an element and click
Element Info There are editable fields in the Geometry section.
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Element Selection

Wrapping text

You can use the Alt key to switch berween the usual scale handles and wrap handies thart are
available for text elements Using the round handles, you can wrap text

® o
U AN
»\\\"“’ D o
06\ e7 4
5%' \XB“ ﬁf‘*‘
O 2 T

@%“Y\ﬂ‘ %fc

Once text is wrapped, the text is confined If text is edited so thar it exceeds the size limit, the
next word drops to the next line Once wrapped, text will remain wrapped

Selecting edit handles

With the Individual method and New mode, element handles are shown if you select 2 single

element or multiple elements using Cul + click When Disable Edic Handles is enabled, edit
handles are not shown for selected elements.

& INOTE: Element handles are not shown when you select by dragging a rectangle or use the
Block, Shape, Cizcle, or Line selecton methods

If you enable Select Edit Handles after elements are selected, edit handles will appear on
elements in the selection set and the Block, Shape, Circle, or Line selection methods will
select the handles rather than the elements Disable Edit Handles must be disabled to use this

= Exercise: Selecting handles

1  Open surveydgn, Default model

2 Select Element Selection

3 Expand the tool settings.

ﬁ _ 4  On the Level tab, click on the following levels to select the elements on those levels:

Prop Alignment
Roadway Shoulder

S In the wool settngs, enable Select Edir Handles
In the status bar you can see that nine elements are selected.

6 Press and hold the Cud key
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Element Selection

7 Click on each of the three handles_ at the upper cons;rucuion limit line.
'r- //‘ - //

S

4

s e

RS

/ _/
!

Ed

.-'w:.',‘. - LV
S

The handles s change color

8 Drag o modify the handles to the lower construcdon limit line.

e
.

-

Only the elements that are part of the secondary selection ser are extended

Q@ Disable Select Edit Handles

The secondary selecdon set is disabled, bus the original is sull actve

& TIP: You can also hold the Shift + Ctrl kevs on the kevboard and then drag an overlap
reciangle to select elemenss
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Text

Reviewing and editing

Aruribute 1abs in the rool settings let you select elements by one or more attributes like level,
color, style, weight, type, or class. When you select elements graphically using Element
Selection, the atwributes of elements included in the set are 2 highlighted group at the top of
each b

Tap row ket to right. Elenrent Type, Element Class and Elersent Teriplate tabs
Bottom rowy Level, Color, Style and Weight tabs

You can add to the set in each tab by clicking actributes that are not highlighted If an element
with that attzibute exists, the element will be included in the set. You can remove elements
that have specific attributes from a set the same way. Switch tabs to add or eliminate elements

with other acributes.

2 Exercise: Add and remove set members by atiribute

1 Continuing in survey.dgn, on the Level tab in the Element Selection ol settings,
click on the Boundary RW level to selectic

The right of way lines are added 1o the selecoon set.
2 Select the Color tab
3 Click on the color 71ByLevel

The blue roadway shoulder elements are removed from the set.

Select the Line Style tab
5 Scroll down 1o style 3 and click it

The blue roadway shoulder elements are added back into the set

6 In the wol settings, click Clear to release the selection set

Text

RSC to TrueType font conversion

In previous releages RSC fonts were replaced with a TrueType font Now when text uses an

RSC font, the fonr informaton is extracted and convereed to a TrueType font format where
the information is temporarily saved and loaded into the fonrt table for MicroStation to use o
propezly displav the characters It is unloaded when vou exit MiczoStation
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Text

Macro support in the Word Processor

Acdons caprured in the Word Processor can be recorded as a MicroStation BASIC macro

Text style remapping

Right click on a text style name in the Text Styles dialog box and select Remap Elements to
change the text style of all text elements having one text style to another text style

When you select the menu item, the Remap Elements to Texst Style dialog box appears so you
can make the change. The selected text style is listed as the source. Select the desdnation style

from the Destination opuon list

Text Fields

As you place or edit text vou can insert flelds that derive content from the attribuzes of an
element, the properties of 2 model or the propertdes of a file Insert text fields using the Word

Processor text editor
Field properties

Fields based on element attributes are updated to reflect changes whenever a change to the
element causes the attribute to change If a text field includes the area of a closed elemeny, the
text will be updated automarically to reflect any modifications to the element Fields based on
file or model properties are updared when the file is opened.

= Exercise: Add a file property field
1 In manholes39 dgn, open the Manholes model
2 Select Edit Text (A + 3).
3 Click on the suing FILE NAME: on the left side of the title block
4

In the Word Processor text editor, click at the end of the string so the cursor appears

there.

This is where the feld will be inserted.

5 Righrclick
& Select lnsert Field > File Properties from the pop-up menu
7 In the Fields Editor dialog box, select File Name
8 In the File Name Formar area, set Path to False
Setting the path to false excludes this informadon from the text field. You can also
roggle display of the root file name, showing only the extension, or exclude the file’s
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extension You can choose the case in which you want the field to display A preview
of the field contents is shown ar the borom lefr of the dialog box

Click OK

10 Enrer a data point in the file to complete the edit

The sting now reflects the file name

11 Select File > Save Sertings

=2 Exercise: Change file properties

1

2
3
4
5

Condnuing in manholes39 dgn, select File > Close.

In the MicroStadion Manager, right click on manholes39.dgn and select Rename
Change the file name to manholes_RC-39.dgn.

Reopen the file

in the Key-in browser, enter the following:

FIELD UPDATE ALL

Press BEnter or click Run Key-in

All fields are updated

A field can appear anywhere within a texc suwing and can span multple words or lines within

muld-line text

Background

In order to distinguish fields from text that is entered directly, fields are shown with a light
gray background. There is a user preference to display fields without it

=> Exercise: Element properties

1

Open update_site dgn, Defaulr model

The area of the building is indicated in the text field

Select Seale (3 + 3) with the following ool setting:

Xand Y Seale: 5

Enter 2 data point on the building and then one to accept

The field updares o reflect the new element properties

Select Sertangr > Drawing Scale.

Change the Master Units o Meters.

In the Key-in browser, enter FIELD UPDATE ALL and press Enrer

The field updates to reflect the unit formar.
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Text

7 Select Workspace > Preferences
8 Select the Text category and enable the Hide Field Background check box
9  Click OK.
10 Select Fike > Save Semnngs

The next dme you open the model the field will apdate 1o the new settng,
11 Select Previous Model
12 Select Next Model

You return to the site plan and the background has been removed.

= Exercise: Copy field data
1 Launch Excel.
2 Open field_report.dgn, Default model.

3 On the Level tab of the Element Selection tool settings, select the building area level

Elements on that level are selected.

Select Edit > Copy

In Excel, select Edit > Pasre.

The building area data is copied into the spreadsheer
6 Exit Excel

@ NOTE: Fields in MicroStation and AutoCAD are similar A MicroStaton fleld will be saved
to DWG format as long as the underlying field property exists within AutoCAD.

Editing fields

The Word Processor test editor is the only style of text editor in which you can insert and ediv
fields

Associate a field to new element

Use the Reassign Field option on the Word Processor text editor’s right click menu to reassign
a field from one element to another element

Edit a field to get it into the rext editor, then right click and select Reassign Field Idenufy the

new element and then accept
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Text

Inserting and updating null fields

You can insert a field associated with a property whose value is NULL (or, blank} Insert the
field with “H###” as 2 placeholder When the value of the property is ser and the field is
updated, the field text reflects the new value.

Enable Update Fields Avtomatically in the Model Propertes dialog box o update fields
auromatically when the DGN file that contains the model is opened

Annotation scale displays the logical name

When you insert 4 field derived from a model’s annotation scale the logical name of the scale

will displays instead of the raw scale value

MODEL SCALE:EL

“Faudl Sige 1=77 filly the freld rather than *1 0~

Copyright € 2007 Beaddey Systems Incomporated Do Nt Dueplicate

5-88

MicraSratgon v § NM Edirion Admin

1271700



Dimensioning

Tags support annotation scale

Tags support annotation scale As 2 result, when there is 2 change in 2 model’s annotaton
scale, the tags in the updare to the new annotation scale.

.
- bkl
=
*
X ¥
'
\
db i : i
tiach Shafy
o aals Cabiema Splice Lreried Lolumn
. no scala me scole

S Cornt ke
- pravon
Mach Shalft
m0 acaie

P T

Tag at left was placed path the Annotation Scale lock on
The model’s aumotation scale was changed from Full Scale 1710 1.2 5

The Annotadon Scale lock in the Place Text tool sertings conrtrols this

Dimensioning

The Dimension stvles dialog box has been reorganized ro offer easier access to dimension
SEEUﬂgS
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Dimensioning

Dimension Styles dialog box

The dialog box conmins a hierarchy wee of all dimension styles Icons in the hierazchy ree
indicate whether a style is derived from a library or is part of the active file
¥
T
The top icon indrcates the style Is derved from o fibrary

The botton: fcon fndicates that a style is part of the active design

Library styles that are present in the acdve design and are consisteat with those in the library
A+ are marked with a check mark. Styles that are not consistent are indicated with 2 modified
icon

& NOTE: The Text Styles dialog box also uses these icon indicators

The Style menu offers options that are also available as icons, plus a rename option Use
options oa the View menu to toggle the preview window and the style list

Dimension style remapping

The Remap Elements funcdon allows you to change the dimension style of all elements
having one dimensiosn style to another dimension style Access this function by right clicking
on a style name in the Dimension Styles dialog box and selecting Remap Elements from the
menu

Dimension settings

The dialog box has zbs for setting geomerry, units, text and symbology sertings Tool tips for
individual setrings explain the serting’s function.

There is also an Advanced tab that includes all controls for dimension styles On this tab vou
can compare two dimension styles and review their differences.

I =(iientation Afigred
! peation Ahove
- Justificstion Center » Left
- P ~Framsa Hons
Soblons W i LeftMagn 0.000870
Magsr TG O0GID i C L Lowsr Margin 4500000
Margie | 8560600 ) i ~LabelLing Fomal Langth 7 angls

Sestings i the Fornal section o the Text fal and settings an the Advanced tabh
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Dimensioning

2 Exercise: Compare two dimension styles
1 Open Dimensions dgn.
Select Element > Dimension Styles to open the Dimension Styles dialog box.
Select the Advanced tab

2
3
4  On the Advanced wb, set the Mode o Comparison
5

e

Press the Ctr] key and select the local dimension styles M Dimension and mm
Dimension

The attribute categories in which the two styles differ are listed at the op

&  Expand each category to view the sryle comparisons
As you expand the categories you see a column for each selected dimension style and
the comparison is noted.

If vou select Differences mode, only the differences between the styles are listed

You can also compare or check differences for a dimension style in the open DGN file with
the DGNLIB version by enabling Compare with library.

New options for geometry

On the Geometry tab there are new fit options for text and terminarors. The fit options onlv
apply to linear dimensions

The Text/Terminator setting determines how the dimension will fit based upon the size of
the text, the size and type of terminator or 2 combination of both You can force text 1o
remain inside or force terminators to be placed inside or ourside

L

[Zooeme -

The move settings determine whether text or terminators take precedence.

The Min. Leader settng sets the space, in units of text width, between extension lines and

dlmension text

There is also an opton in the Dimension with Leader section to generate leaders
automasgcally Ser the Mode to Automatic to automatically place a leader when one is
required. You do not have to move the dimension text to creaze the leader
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Dimensioning

=¥ Exercise: Automatic leader lines
- 1 Open layour dgn, Walls model,
. r_)l 2 Select Dimension Linear (F + 2) with the following ool setting:
Ste Allow Leader
3 Dimension from the right side of the building to the doorway.

The second wall width dimension requires a leader.

4 Select Modify (7 + 1)

5  Select the dimension text (12) and move it below the dimension chain

The text styvie allows leaders, so one is created when the text is moved

6  Select Dimension Linear (F + 2) with the following tool setting:

Sople; Anro leader
This text style creaces leaders autamarically.
7 Dimension the rest of the building
Leaders are now added automatically where they are required

8 With the Auro leader style selected in the Dimensioa Styles dialog box, in the Fit
Options section of the Geomertry tab, change Text/Terminator to Text inside.

9  (lick Save Sryle
10 Click Yes ro All in the Alert dialog box

The dimension text that was placed using the Automenc Dimension With Leader

opuon updates, moving inside the dimension

11 In the Dimension Sevles dialog box, change Text/Terminator to Term Reversed

12 Click Save Svle
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Dimensicning

13 Click Yes to All in the Alert dialog box.

Terminators are added inside the dimension and the text moves to accommodate

them.

Advanced options

Tool specific dimension settings

The Tool Specific section on the Advanced tab has settings that affect individual
dimensioning tools. Expand the listed tools to see the options. Set left and right rerminators,
extension and leader lines and stacking Add arc accent symbols, prefix or suffix, a center
mark and set text orientation. Use the Chord option to place arc dimension extension lines

non-radiaily

=» Exercise: Change advanced settings

1

o0 N e R WM

Open stairweli dgn, Core model

In the Dimension Sryles dialog box, copy the ordinates dimension style.
Right click and rename the new style ordinates n

Press Tab

Select the Advanced wb

Set the Mode to Edit

Expand the Tool Specific options.

Expand the Ordinate options

Enable Decrement in Reverse Direction.

Enable Decrement in Reverse Direction so ordinate values 1o the left of the origin
point will be less than the origin.

10 Click Save Style

» Exercise: Use the styles

1 Continuing in stairwell.dgn, select Dimension Ordinates (F + 4 with the following
tool serring:
Style: ordinates
This sets the too! settings to Alignment View, Location Automatic and Mode
Ordinate Unstacked
MieruStigon VE XM Editon Admin Copyrighe £ 2007 Beniley Susems Incorporated Do Not Duplicare
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2

w

4

oo

AccuSnap 1o the floor at locaton 1 and enter a dara point

7

Move the pointer upward and enter a data point 1o indicate the direction in which

you will be dimensioning.

Enter a data point to the left of location 1 to establish the end of the dimension.

: &
X

‘This ts the origin
Snap to the floor above and enter a data point.

Enter a data point on each floor above to dimension the stairwell

7 500 _ l <
3 750 g_ r,-r/“"_'
: P
.
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Dimensioning

7 Then, enter a data point on each of the floors below the origin, ending at the bottom.

: 7
3750 ,,ff
7 500 ‘ ,.—"/—H

8 Reset.
? In the tool sertings, change the Style to ordinates n.

The ool settings change accordingly The Decrement in Reverse Direction option is
already set Expand the tool settings 1o see this

10 On the other side of the stairwell, snap to the floor at location 2

11 Enter a dara point.

12 Move the pointer upward and enter a data point to indicate the direction in which
vou will be dimensiorning

13 Enter a data point to position the dimension.
14 Enter a data point on each floor above the origin 10 dimension this side

15 Enter a darz point on each of the floors below the origin on this side, ending at the

bottom

-3 750

Y

-7 500

These dimensions are now negative numbers
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Dimensioning

16 Reser

DIN dimensioning

DIN Dimensioning properties, such as superscript and rounding, are included in the Units
category on the Advanced ub

If you enable Superscripy, the least significant digit is displayed as superseript If Superscript
Character 15 enabled the superscript number uses a resource character If not, the superscript

number is supplied by the active font

Enable Rouncing 1o round o the closest half unit 0 is not displaved.

2428
242.58

I | Y |

508,25
506.25

Dimensions with DIN properties are nsed on the lejt
Here, superserpt is supplied by the active font

Angular dimension fit options

Previously the Fit Oprtions in the Graphics category of the Advanced tab applied only to
linear dirmensions They now apply to angular dimenstons as weil.

Enable the Extended Dim Line Under Text fit opdon so the dimension line under angular
dimension texrt is extended when the text is pushed to the ourside.
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Cells

Non-8tacked Fraction Space

In the Units section of the Advanced tab, this properry controls whether dimension text is
placed with a space between a fraction and a unit symbol By default the space is included To
prevent the space from being included, wrn this option off

Show Sign for Zero

In the General section of the Advanced tab, this property lers vou to turn on the sign symbol
{(+ /=) when dimension rolerance is zero

Styles for note placement

If you are creatng dimension styles to be used with note placement, when the Dimensions
view atribute is off the entire note will not display The attribute no longer affects only the
dimension leader.

You can enable the Frame Scale option on the Text tab of the Dimension Styles dialog box to
set the size of a text frame If you do set this serting, the frame will not resize dynamically if

the text changes

Dimension tools

Users can open the miscellaneous dimension tool box by selecting Tools > Too/ Boxes and then
enabling the Misc Dimensions check box in the Tool Boxes dialog box. Open the tool box
containing other dimensioning tools such as Dimension Angle from X-Axis, Perpendicular ro
Points and radial dimensioning by enabling the Dimension Tools check bos.

Dimensioning tools from previous versions that do not appear in tool boxes can sull be
accessed by key-in

Cells
Enhancements ler users directly atzach entire folders that contain libraries and ler vou apply
annotation scale o cells.
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Cells

Cell Libraries

You can attach all the cell libraries that are in a folder by selecdng Fike > Attach Folderin the
Cell Library dialog box. You can attach V7 DGN files, 3D Swudio (.3DS), or DXF files.

You can also artach and place the model stored in an OBJ file as 2 cell OB] is an open
geometry definition file formar that is available in various sofrware applications

Nofes:

When 2 cell library is attached, right click on a cell in the Cell Library dialog box and select
Open for Editing from the pop-up menu to directly open the model that contains the
Zeomerry.

Annotation scale for cells

Annotaton scale applies to cells When you change the active model’s annotation scale,
annotation cells in the model are auromatcally scaled by the new factor

The Place Active Cell tool is used to place annotation cells The rool settings have an
Annotadon Scale lock similar to the one for the text and dimensioning tools. When users
make 2 cell active for placement a cell that can be placed as an annotation cell, this lock is
enabled

To make an existing cell an annotation cell:
1. Open the library that contains the cell as a DGN fle

2 In the Models dialog box, select the cell model and click the Edir Model Properdes
icon.

3. In the Model Properties dialog box, turn on Can be placed as a cell and Can be placed
as an annotation cell.

4 Model Properties dialog box with added Cell Properties.
5 Click OK

This topic is covered in detail in conjunction with model properties.
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Multi-Lines

Cell index

A cell index contains all of the models in the active DGN fie that have the Can be placed as

cell option enabled

Find the Place Cell Index tool in the Cells ool box Tool sertings let you set the size of the
box in which each cell appears The size is based on the active text style.

You can also set the number of cells per row and you can choose whether or not to display
grid lines, similar to showing grid lines in spreadsheet applications You can include celi names
and descriptions. The Insertion Points option displays the cell origin

A cell index can be used as a screen menu if the Grid Lines opton is enabled

Multi-Lines

Remapping Multi-line styles

You can remap style of all muld-lines having one style by dght clicking on a style name in the
Muldi-Line Styles dizlog box and selecting Remap Elements. In the Remap Multi-line
Elements dialog box, the selected multi-line s designated as the source and you select the

destination style from the Destnaton options

Line Styles

There are enhancements related to modifving custom line style atuibures and scaling line

styles

Line style modification

The Modify Line Style Artzibutes tool, from the Change Auribuses tasks, lets users modify
custom line style atributes by entering a precise value or by modifying the attribute
interactively in the view Use the icons in the ool settings to select the attribute to modity

Medufy Uidth, §tart or Eud nidth. § cale. Dash or Gap scale or Shift
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Line Styles

= Exercise: Make line styles legible dynamically
1 Open intersection dgn, Default model

Some of the electric line style’s characters overlap another line style

T 2 Select Modify Line Seyle Attribuces (5 + 4) with the following tool settings:
T Shift icon: Enabled
el
Ry Shift check boxe Enabled and set to 30.0
The Shift check box is available when the Shift icon is selected Enable it and enter
the shift distance, relative to the beginning of the element Results depend on the
Absolute serting
If the Absolute check box is enabled, the value represents the actual shift distance. If
Absolute is disabled, the value represents the amount to modify the existng shift
distance.
3 Idendfy one of the red electric lines with 2 data point
4 Enter 2 daza point to accept
E,
The sevle shifes
5 Disable the Shift check box
6 Enter a data point on the other red electric line.
7 Move the pointer to dynamically reposition the character
8 Enrer a data point
True width

If this opuon is enabled, the line style width is not affected by a change in line style scale The
line style scale can be modified wsing the Modify Line Style Artributes rool, as well as by the
global line style scale, using the ACTIVE LINESTYLE SCALE key-in.

For example, if you set width to 2.0 and the scale is 3 0, 2 line with True Width enabled will be
2 0 working units wide, while a line with True Width disabled will be 6 0 working units wide
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Standards Checker

Model-based line style scale

Every model can have a global line style scale that is applied to all line styles within the model

If you change the global line style scale for the model, ali line styles will be scaled by that
amount. If you choose to apply the annotation scale, that scale will be applied to all line styles.
This is useful for styles that must rerain a relationship to sheet size This topic is discussed in

conjunction with models

Standards Checker

When using the Standards Checker to check element templates, you can check all element
template properties You also can add elements that fail the standards check 1o a named

g EOUP

Element template properties

When defining standards checks for element templates, vou can selecr any or ali of the
g p 2§ )
properties stored in an element template in the Element Template Checker Settings dialog

box.

In the Checks to Perform section, enable Check Local Templates to check the open DGN
file’s local elemnent templates against the emplates defined in DGN Libraries.

Enable Check Elements to check all elements in the open DGN file against the local
templates with which they are associated

Then, in the Properties to Check section, enable the check box for any or all of the properties

stored in an element wemplate.

Isolate non-standard elements in named groups

When running the Standards Checker to check element templates, vou can add all elements
thar fail the standards check to a named group. After the Standards Checker runs, open the
Named Groups dialog box w0 see the of the check
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Muliiple Redline Support

The default name for the named group is Nonstandard Eiements The Nonszandard
Elements group is a list of templates and the number of elements thar failed the standard
checks against each templare. If you want w keep track of the results of your standards
checks, enter a different name each time you perform a standards check. If vou do notenter 2
different name the Nonstandard Elements group is overwritten when vou rerun the

Srandards Checker.

@ NOTE: If you enable the Named Group check box and Interactive and fix all errors when
they occur in interactive mode are also enabled, a named group will not be created

Multiple Redline Support

czx When you select the Attach Redline File tool, the Display Redline Files dialog box appears
: L:é’ This dialog box lists the files identified by the configuration variable RD L_OTR Users can
select any or all of the listed redline files 1o be displayed.
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INI files

Printing

The Print dialog box is enhanced and printer driver development keeps pace with evolving

technology

The format of saved configuration, INI, files has changed Configuration files written by
previous editions of MicroStzation remain valid, but once a configuration file is written by
MicroStation V8 XM Edition it will not be usable with previous editions

Enhancements to the print engine let vou create prints that are a mix of raster and vector dara

and you can also apply wransparency

Rasterized Printing

Microdmdon Vi XM Editon Admin

12 1/0G0

Rasteriged printing recogmiges transparency
The Pt previens show an element withont transparency bebind an element iwith transparency
The image on the left 15 & preveew with the Rasterized setting aff, on the right the Rasteriged setiing s on

The funcrionality from the ripwin32 drivers is included in Rasterized printng

You can output 2 print as a single raster image or as a mix of vector and raster data Rastenzed
printing works by generating a display st from a model, then rendering that display list into
raster tles or bands before writing them to the plot file The printer driver file determines

whether tles or bands are used.

The size of the tiles or bands is important to performance The larger the e, the faster the
plot, but more memory is used Tile sizes are also limited by the capabilides and available
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Enhancements to the Print Dialog Box

memory of the video card A system’s display sertings must also be set to use 24-bit color, true

color

Rasterized option

Use the Rasterized serting in the General Settings sectdon of the Print dialog box to toggle the

opron.

+  If zll view mocdles that will be printed are not rendered, you can toggle the Rasterized
aption

+  If the active view’s mode is one of the rendered modes, ot if any reference presentadons
are anything other than wireframe or wiremesh, the mode is set to Rendered and the

Rasterized serting is not available

This setting can also be set with the key-in PRINT RASTERIZED <OFF | ON>.

Transparency

There is a Transparency prine attribute in the Print Awributes dialog box that is similar to the
Transparency view attribute. You can print partial transparency with any printer driver
capable of printing in rasterized mode To do so, turn on the Rasterized check box in the Print

dialog box.

Enhancements to the Print Dialog Box

The MicroStation Print in Progress dialog box displays print starus when you send printed
cutpur directly to a printer. This dialog box allows you to cancel the print job For rasterized
and rendered prints, a progress bar shows the rasterization process

Non-orthogonal rotation

Use the Rotation field in the Print dialog box o specify any rotation from 0 w0 360 degrees
for prints that are not rendered and do not contin a camera definiton. To enable non-
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Ernhancements to the Print Dialog Box

orthogonal rotation, disable Hide advanced layout controls in the Print dialog box’s Serings >
Preferences Print Preferences dislog box

Euahm ]FE_MW d.egl.

If Hide advanced layou: controls is enabled, the Rotation conirol is an optien menu rather

than a field

This can also be set with the key-in PRINT ROTATION <rotaton_in_degrees>
@ NOTE: You can remove the Preferences irem from the Sewings menu by setang the
MS_PLTDLG_DISABLE_PREFERENCES_DIALOG configuration variable
Mirroring

Another advanced option js the Mirror option menu You can mirror printed ourput about

the x- and y-axis

Or, use the key-ins PRINT XMIRROR <OFF | ON> and PRINT YMIRROR <OFF |
ON>

Print destination

A print’s destination can be set in the MicroStation Print dialog box instead of the Windows
Print dialog box. Select from Send 10 printer, Create plot file, or Create merafile.

*  When printing with a Bendey printer driver, Create plot file is the only available choice If
the plt file is configured 1o write direcdy to an LPT port, this is the same as Create plot
file. If you want Create plot file to be the default, change the default_outFile record in the
plt file

«  Send ro printer is available only when using 2 Windows printer driver. The print is sent to
the selected printer, using the selecred printer driver

»  Create mezafile is available only when using a Windows printer driver This option creates
2 Windows enhanced merafile { emf). If you want Create mewfile to be the defauls,
change the Model record in the plt file 1o model = sysprnmetafile
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Printing Preferences

This can be ser with the key-in PRINT DESTINATION <DEVICE | METAFILE |
PLOTFILE>

The Full option

When you are using the Windows printer you can enable the Full check box to maximize the
porton of the sheer thart is used When you are printing to an 8.5 x 11 sheer, the maximum
print size may be only 8 x 10.5 If full sheet is enabled, the maximum prine size will be 85 x
11 Some geometry may be clipped by the printer if it falls into the area around the edge of
the paper that can’t be printed by the printer

To enable the Full option all the time, add the following to the plt file:

sysprinter /fullsheet

Raster options

The Settings > Rasrer Optrons dialog box shows the printer resoludon in dots per inch and che
raster resolution that results from the specified raster quality factor

Printing Preferences

MicroSnion Vi SA Edition Admin Copyright £ 2007 Benden Svsterns. Incorponaied
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Many print settings that were previously oaly available using configuration variables are now
stored in the user preference file and can be changed in the Print Preferences dialog box

- One preference, Thumbnail preview time-out, controls the period of time that the thumbnail

preview paints When the Print dialog box first opens, the thumbnail preview paints for 10
seconds before stopping to allow the rest of the dialog box 1o refresh. If the print preview is
not complete within that time period, a message appears in the staras bar. Change the amount
of time using this setting The preference Show print status dialog determines whether users
see the Print status dialog box at print time
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Preference configuration variables

The configuraton variables are sull honored and, if defined, thev override the wser
preference When a configuraton variable setting is in effect, the corresponding controlin the
Preferences dialog box is disabled

Allow paper size
edidng

MS_ PLTIDLG_ALLOW_FORM_
SIZE EDIT

If enabiled, the size of the seleciad
form can be modified in the pring
dizlog box Not valid for svsiem
printers

Hide advanced
fayout controls

MS PLIDLG_SHOW_BASIC 1 AYOUT_
CONTROLS

If enabled, the arbitrary angle
rotztion edit field znd mirror options
are notin the print dislog box

Show print status
dialog

MS_PLT_SHOW_PRINT_STATUS

Toggles display of the Print Staws
diaiog when printing

Enable auto rotadon

MS_PLT_ENABLE_AUTOQ_ROTATE

If disabled, rotation is not
autematcally changed o achieve 2
best fiv Only applies 1o Bendey
drivers

Enable auto
orientation

MS_PLT_ENABLE_AUTO_ORIENT

if disabled, paper arfentation is not
automatically changed 1o achieve o
best fir Only applies 1w system
printers

Enable scale
preservation

MS_PLT ENABLE_PRESERVE_SCALERE

1f disabled. the current print scale is
not preserved when & new view,
fence, or paper size is selected

Enable scale clipping

MS_PLIT_ENABLE_SCALE_CLIPPING

If disabled. the print fence or sheer
size 15 not reduced in order o
accommodate the user or sheet
specified scale factor

Honor sheet
definiton

MS_PLT HONGR_SHEET_INFO

Prevents sheet anribures stored in the
model fro being applied when
creating a print descripdon 1f a sheet
definition is present, the plot area
defaults 1o Sheet and the boundary is
set from the sheer IF this is disabled.
it is a5 if there is no sheer definidon
present

Haonor sheet layout

MS_PLT_SET_LAYOUT_FROM_SHEET

1f disabled. Jayout s not automatically
ser when a sheer definition is loaded
{and the current print mode is sheer)
By defauls, the sheer favout
information is honored

Honor sheet plot
styie table

MS, PLT_SET_PLOT_STYLE_TABLE
FROM_SHEET

By default, any plot stvle table (CTB
or $TB) specified in the shees
definition is auromatcally anached o
the plot If disabled, sheet plot swle
rables are ignored

Set units from sheet

MS_PLT_SEY_UNITS_FROM_SHEET

If disabied. units are nor
automatically ser from rthe sheet
definition whesn the current print area
mode is sheet Other sheet atzibules
are honored

MicroSmoon VE WA Baigon Adrmin
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Use sheer instead of
fence

MS_PLT_AREA_PRIORITY

If enabled, sheer definidions in the
medel take priority over the sctve
fence New fences are ignored when
the prnt area mode is sheet This is
the default seedng If this variable is
not set, the active fence takes priority
over sheet definitions

Default form scale
priofin

MS_PLT_FORM _SCALE, _PRIORITY

if enabled, the default form scale
specified in the plt file is re-applicd
whenever the paper size changes By
default, the cusrent peing scale is
preserved

hlaximize on new
plot arca

MS_PLT_MAN_ON_NEW_AREA

If enabled, the print size is
sutomatically maximized when the
print arez is changed, inchuding when
a view number is selected or a fence
is placed By defaul, the carrent print
scale s preserved

Fit with raster
references

MS_PLT_FIT_RASTER_REFS

If enabled, raster references are
included when compuuing the design
range for the Fit printarea modes By
defaulr, it they are not

Auto fit vigw

MS_PLI_AUTO FIT VIEW

1F set to a value other than None, the
print area mode is automansally set
to 'Fit Master' or 'Fit Al when first
invoked (and z fence or sheer is not
defined) Otherwise, the printares
mode is set w0 View

Preview accurate
rotation

MS_PLTDLG_SHOW_ACCURATE_
PREVIEW_ROTATION

If disabled, preview always shows the
print as if it had no totation The
paper orentation display can be
swapped to accomplish this. Qnly
meaningful for Bentley printer
drivers when the print rotagon is 90
or 270 degrees

Thumbnait preview
timeout

MS_PLT_THUMBNAIL_PREVIEW TIME
QuT

Specifies the maximum number of
seconds to spend updating the pant
dialog thumbnait preview

Apply color mode o
raster

M5 PLT APPLY_COLOR_MODE_
TOURASTER

If disabled, the print engine does net
apply the color mode specitied on the
print dialog to raser da

Use view
background color
when rendering

MS_PLT_USE_VIEW_BACKGROUND_
COLOR_FOR_RENDER

1f enabled, che print engine does not
change the background color for the
print when rendering

Pen Table Enhancements

output.
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When creating printed ourpur, a pen table tests for the presence of specific nipes of elements
and related element characteristics If these elements are detecred, the pen table will modify,
enhance, or eliminate these elements or their characterisucs depending on the intended
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There are several enhancements to pen table-relaied funcdonality

AutoCAD interoperability

DWG plot style tables

MicroStation checks to see whether an AutoCAD plot style table (CTB or STB) is specified in
a DWG file. If a plot style table is present and enabled, by defanlt MicroStation converts it
into a memory-resident MicroStaton pen table and ataches it to the print

CTB color mapping

When converting a CTB file into a MicroStation pen table, AutoCAD color numbers !
through 254 are mapped to MicroStation colors | through 254 However, the CTB file has an
addidonal assignment for AutoCAD color number 255 Since MicroStation users expect
colors 0 and 7 to be pute white when working with DWG files, MicroStation V8 XM Edidon
pen table processing ignores the CTB color 255 mapping and makes pen map colors 0 and 7
the same, with output assignments taken from color 7.

NOTE: If you map pen colors or weights, the Export CTB File option on the Modify Pen
Table dialog box’s File menu becomes active and vou can save as CTB.

Modify Pen Table: Element Selection Criteria

Level regular expression

You can use regular expressions to select levels For example, if you rvpe a * in the Level
regular expression text box, the pen table secton will match every level beginning with a.

Levelieguar grpiession © 7 7
ie

The comparisons are not case sensitive. If a pen table contains a list of levels and a regular
expression, all must match the element leve) name for the pen table section's outpur actions

to be applied
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Tag element type

Tags have been added to the list of element rypes available Previously vou could not select

tags as part of your element selection criteria

Fype

Mulifine
Hazisr
Shape
3 Shated Call

: Text Mode el

In the Pen Table Opdons dialog box, you can specify whether tag elements should be weated

individually or as a group

& NOTE: When reading a pen table created in earlier editions of MicroStation, the Explode
tags check box is selected by default This ensures compatibility berween the two editions

Modify Pen Table: Element Output Actions

Transparency

Pen table transparency is supported for any printer driver capable of printing in rasterized
mode If it is used when printng in non-rasterized mode, the wansparency values have no

effect. Find the check box on the Element Qurpur Actions b

Priority

This lets vou assign different priorities to individual components of a shared cell

Pen table priority is 2D oaly, just as for elements. It does nor have any effect for printing 3D
files Priority is implemented for printing 3D files through £ depth, so the pen wble is no

longer required to make multiple passes through the element list

Modify Pen Table: Pen Table Options

This dialog box is used to control pen table options Click the Pen Table Oprions butzon on

the Element Selecton Criteria t2b to open it

Level symbology

The Element symbology comparison mode setting affecs only the way in which the input

criteria treats level symbology There are rwo modes

= Asstored in element header means tha: the element hieader symbology is matched against

the input criteria

Copreirin € 2007 Bentler S15tems Incomorated
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*  Asdisplaved in view means the view symbology is matched against the input criteria

= Gengal e
. ‘Elsment symbology compatizon mods -
s stored i element
CiAs dhoplayed in view 55

The pen able ourput actions are always applied, regardless of whether level symbology is
enabled

Applying muitiple sections to elements
You can set a pen table to apply more than one section to an element

If Match multiple element secdons is enabled the sections will be selected and applied in
descending order, starting at the top of the list and working down

+ If the pen table turns blue elements cyan, then  later section makes cyan
elernents dashed, the elements will be dashed.

If this setting is disabled, once a section has been selected by its input criteria and its outpur
actons are applied, pen table processing on that element stops

* If the pen table mins blue elements cyan, then a later section makes cyan
elements dashed, the originally biue elements will not be dashed

Complex and compound elements

Use options to control whether pen table processing will trear cells, shared cells, dimensions,
multi-lines or tags as single units or as individual elements

When treadng as a single unit:

*  Only the complex/compound header is processed by the pen able All of its children
inherit any output actions applied 1o the header.

When treatng as individual elements:
*  The complex/compound header is ignored by the pen table
*  Complex chains and complex shapes are always treated as single units

*  Individual elements cannot be processed by the pen table more than once

# NOTE: When reading a pen table created in earlier editions of MicroStaton, the Explode
tags check box is selected by default This ensures compaubility berween the two editions as,

previcusly, tag elements were always exploded
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Due to the new display subsvstem, fewer printer drivers are supported In addition, some
delivered PLT files have been consolidated. See the online help topic What's New > What’s
New in MicroStation V8 XM Edition > Printing Enhancements for a complete list

New printer driver configuration file format

The .plt printer driver configuration file format has been superseded by the XML -based
plecfg format Legacy plt files are still supported, so two sets of defaule printer driver
configuration files zre delivered

Both sets of printer driver configuration files are stored in the \Workspace\System\Plotdrv
folder All dizlog boxes in which you choose a printer driver show files with both extensions
You can open and view both types of files in the Print dialog box, the Batch Print dialog box,
and the Printer Driver Configuration dialog box

When vou open a .plt file for editing, MicroStation opens it in Notepad Whesn you open a
plicfg file for editing, MicroStation opens it in the Printer Driver Configuradon editor

NOTE: Migration to .pitcfg files is strongly encouraged The currendy delivered ple files will
be removed in 2 future reiease

Printer Driver Configuration editor

The Printer Driver Configuration edizor allows you to add and edit plecfg printer driver
configuration files, which are stored in XML format Select File > Edit Printer Draver
Confignration in the Print dialog box to open it

Copyright & 2007 Bentley Systems . Incorponued Do Not Duplicste
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When defining symbology, vou can edit more than one opdon at a time by selecting while
using the Curl key After names are selected, click Edit to open a dialog box where vou set

desired values

The Edit Paper Sige(t} diatog booc opens wihen you select paper sizes on the Paper Sizes tab and click Edit

On some tabs vou can click Add to add an individual paper sizes, fonts or programs to the file
or you can click Remove to remove individual eatries.

General tab

This tab shows the selected printer driver configuration file’s name and locarion and the type
of printer driver for which the file is intended There is also a text field in which you can enter

notes
Base Properties tab

This tab has settings that are used to edit properdes defined for the selected printer dnver
The categories that are included, as well as the properties within the categories, depend on
which printer driver is selected Click the downward arrows to expand categories

+  General properties, such as automatc centering, line cap and join, number of copies and
the default output mode are set in the General category ‘

+  Depending upon the tvpe of driver that is selected, you will see a Windows Printer or
Driver Properties category. Set propertes related to the type of driver, such as the default
printer and orientation for Windows drivers or properties related to specific non-
Windows drivers

+  There are also categories for border print properties {on or off, content of border text,
height, fence outine) and raster printing (on or off, quality, brightness, contrast,

grayscale)

»  The Printer Communication category includes the printer communicaton propertes.

Cupyright ¢ 2007 Benidey Sysiems Ineorporated Do Not Dupliense
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These propertes are available only for the PostScript printer driver They are the
communication: properdes used to generate the print file and send it wo the printer.
Generally the default properties are sufficient However, if the printer is used with other
software that requires different communication properties, you can use the Prnter
Communication properties to meet those requirements

% NOTE: If you find zingers, incompleze, or no printed outpur ar all, make sure the
communication properties of the printer driver configuration file march the prinrer

setup.

*  Advanced secdon contents let you set the advanced properties that are in printer driver
configuration files Contents depend on which printer driver was selected -

Paper Sizes tab

This tab has settings that are used to edit, add, remove and reorder the paper sizes defined for

the selecred printer driver
Color Maps tab

This tab has settings that are used to edit the color maps defined for the selected printer
deiver You also can remove all exisung color maps

Enable the Define maps from design color to print symbology option to define design-color-
to-print-symbology If this option is disabled, all existing color maps will be removed

& TIP: This functonality, as well as symbology mapping for weights, is also available using pen
tables. One advantage to defining print symbology in a pen table is that one pen tzble can be
shared by muitiple printer driver configuration files

w‘ g '.’(é H

Color mapping, left from the Printer Daver Confignration editar, and in a peu table
Weight Maps tab

This tab has sertings thar are used to edit the weight maps defined for the selecied printer
driver configuration file You also can remove all existing weight maps.
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Enable the Define maps from design weight to print width option to define design-weight-to-
print-width assignments. If this option is disabled, all existing weight maps will be removed.

Line Styles tab

This tab has setrings that are used to edit the print line style on/off patterns defined for the
selected printer driver

Enable the Define print line style patterns option to assign on/off patterns in paper units for
each MicroStation line style index. If this option is disabled, all existing line style patterns will

be removed

You can indicate how each partern should be applied, either by the printer or by software
inside MicroStation, using the Process style in sofrware option.

Process séyle by software instde MicroStation enabled
Font Maps tab

This tab has settings that are used to edit, add, remove, and reorder the design-font-to-print-
font maps defined for the selected printer driver

Enable the Define maps from design fonts to hardware (or Windows or TrueType) fonts
option to map MicroStaton resource fonts, AutoCAD SHX font, and Windows TrueTvpe
fonts to printer fonts If this option is disabled, all existng font maps will be removed

This functonality is available only for the Windows and PostScripr printer drivers

@ NOTE: Note that defining font maps may result in text having a different appearance on the
print than jt does in MicroStaton.

Programs tab

This tab has settings that are used to edit, add, remove and reorder operaring system
commands defined for the selected printer driver

Copyrighs © 2007 Bendev Sy stems. Incorporied Da Naor Duplicue
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Enable the Define pre-print and post-print program commands option to define operating
system commands to be run either before or after a print

Ficoon coninan:
; [SheiEveente

Adding a program conrmand

If the option is disabled, all existing program commands will be removed

Printer driver file enhancements
The CHANGE_PEN record is no longer supported, and is ignored if present in the PLT file.

ANSI and ISO paper sizes

Both ISO and ANSI paper sizes can be defined simultaneously in a PLT file. Each delivered
PLT file contains a single resolution line, defined in inverred DPI, which is not ded to the
SIZE records. Each SIZE record contains a units qualifier chat indicares how the form size
and offset should be interpreted. For example:

size=:{1189,841} /units=mm /name="150 AQ”

For legacy PLT files where the SIZE records do not contain a units qualifier, the resolution
units 2re used instead As before, PLT files should not contain multiple resolution records

Paper size-specific line weight and line style scales

You can control line weight and line style scaling on an individual paper size basis by
specifying one of the following qualifiers for the SIZE record:

/weightScale=<seale>: scales the widths defined in the WEIGHT _STROKES record
/styleScale=<scale™: scales the pattern lengths defined in the STYLES record

/penScale= <scale>: sets both line weightScale and line seyleScale.

Each qualifier takes z value greater than zere, with 1.0 indicating no scaling,
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So, if WEIGHT_STROKES is set correcty for one paper size, when creating a half-size plot
the output widths would be too wide Rather than create a new half-size PLT file, you could

add:
/weightSeale=035 to the half size paper size definition
Systern printer paper sizes

The MicroStation V8 XM Edition system printer driver supports SIZE records in the PLT
file When printdng to drivers that support application-defined paper sizes, you can set up the
PLT SIZE records without regard to the paper sizes published by the drivers. You are still
restricted to the driver's non-printable margins You cannot override them.

Since many drivers do not support these definitions, the PLT SIZE records serve to filter and
rename the Windows paper sizes They can also be used to specify per-paper-size weight and
line style scale factors. For more information, refer to the secton in the delivered printerplt

file that begins as follows.

; If uncommented, the custom paper size definitions below replace the
, pap P
; paper size list obrained from Windows printer driver

You can disable this feature by removing or commenting out the 10 SIZE records that follow

the narrative
Default line join and caps

The DEFAULT_LINEJOIN and DEFAULT_LINECAP records take the place of the
LINEJOIN and LINECAP records, even though the old records are still supperted While
the legacy records require numeric values that are tied to the plotter language the drver
writes, the new records use keywords to indicate the types of caps and joins desired. Note that
not all caps and joins are valid for every device Refer to the PLT file for the list of valid

choices

Rasterized output mode

Use the QUTPUT_MODE PLT record to specify a driver-specific defaulr sewting for the
Rasterized check box in the Print dialog box You can also decide whether the sewing is 2
preference or not If it is, users can change it after the driver loads Ifitis a requirement, the

check box is disabled.

The syntax is ourpuc_mode = < force_rasterized | prefer_rasterized | force_nonrasterized |

prefer_nonrasterized >

You cannot use OUTPUT_MODE 1o override an output mode enforced by the driver itself,
such as LORIP and rasterized mode, or a rendering mode requiring rasterization

Do Naow Duplicate
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Optimize raster color depth

When printing in rasterized mode, all output is in true color unless optimized into 256 colors
More time is required for optimized color plotting, burt it produces more compact plor files
for typical drawings This setting also affects how raster data in non-rasterized mode is

handled

Optimization is enabled by default in the appropriate printer drvers but can be changed by
editing the OPTIMIZE_RASTER_COLOR_DEPTH PLT record

; If true, RG:B raster is converted to a color palette when possible
; Note that this generally results in smaller plor files, at the
; expense of plot processing time and memory requirements

optimize,_raster, color_depth = wue
Raster parameters

While most of the legacy PLT records related 1o raster ploming are stll supported, they have
all been consolidated into a single record, RASTER_PARAMETERS, in the delivered PLT

files

raster_paramesers /qualitv=<guelity_value>
/contrast=<conrast_value>
/brightness=<brighwess_value>
/grayscale= <grayscale_value>
/ignore=<ignore_value>

(Quality_value is the rato of device resolution to raster resolution, as a percentage
/quality=100 means that raster data should plor at the device resolution Setting /quality=50
zesules in raseer data plotted ac half the available resolution, which is good if plot file size is

more of a concern than ourput qualiry

In place of /quality, vou can substitute /dpi=<DPI_value> DPI_value is the desired raster
output resoluton in dots per inch. Use of /qualicy is preferred in most cases since, in addigon
to being easier 1o calculate, it will avtomarically track any changes that might be made to

device resoludon
+  Conrurast_value is the raster contrast in the range -100--100, even numbers only, where (i is

neutral
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*  Brightness_value is the raster brightness in the range -100~100, even numbers énly,

where 0 1s neutral
+  Grayscale_value is either 0 or 1 If 1, all raster dara is printed in grayscale

+  Ignore_value is either 0 or 1 If I, no raster data is printed
LORIP drivers

The delivered LORIP driver files, jpeg.pit, and png plt make use of an %include statement to
consolidate many of their common serdngs. The same as with the PostSeripr prolog files, you
will need to copy this include file along with its parent PLT files to your custom MS_PLTR
directory. Refer to the comments in the header section of lorip_common inc

The delivered file lorp_common ine contains 2 CmdName record that lers you create raster
offline files whose sizes are equal to the sheet size Piot origins are correctly reflected inside

the image data

; Uncomment the line below to create raster file sizes equal to the sheet size
; instead of the plot area size Note that this line should be commented out when

; using this driver with Bentley Publisher.
;CmdName /appname="lorip” /command="fullSheet” /qualifier="0N"
TIFF and CALS printer drivers

These are specialized printer drivers that replace the generic LORIP drver for producing
TIFF and CALS raster print files

»  TIFFDRIVER can write both monochrome and true color TIFF files It generates
output one scan line at a tme, rather than storing the entire print in memory as LORIP
does You can use larger output sizes and resolations than using the LORIP driver

The delivered tff plt has been rewritten to use TIFFDRIVER instead of the LORIP

driver Several TIFF-specific properties {compression type, photometric flag, document
name, document description, page name, and artist name) are now available. If you want

to take advantage of funcdonality you must switch to the new affplt file

F NOTE: Using dffplt files from previous editons of MicroStaton will continue to
work, even though they reference the LORIP driver, because the LORIP driver is still

included in the product

«  CALSDRIVER still requires a complete print frame buffer in memory, but it is
compressed much berter than the LORIP RGB memory frame buffer.
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PDF driver

There have been enhancements to the PDF driver For example, the outFile qualifiers have
been updated so you can control how files are numbered File size can be smaller because the
color table can be reduced when using fewer colors There are enhancements for level ourput

The default PDF Version record in the delivered pdf plt printer driver configuration file has
been changed from Acrobat 6 (PDF 1 5)/Viewable in Acrobat 5 to Acrobat 6 (PDE 1 5)

Batch Print

The formar of Batch Print specification (SPC) files is changed for the V8 XM Edition.
Specification files written by previous edidons of MicroStation remain valid, but once a
specification file is written by the V8 XM Edition, it will not be usable with previous editons

Batch Print preferences dialog box

Many Batch Print job creation setdngs that were previously available through configuration
variables are stored in the user preference file and can be set in the Baich Priac - Preferences
dialog box. Select File > Preferences in the Batch Print dialog box to open it

The conficurarion variables are stll honored and any that are defined will override the

- .
preferences. Preferences for which an override is in effect are disabled in the Batch Print -
Preferences dialog box.

»  Enable Add filename only to add one file name per DGN file, rather than muldple encries
for each model to the ]ob set (MS_BATCHPRINT_ADD_ALL_MODELS)

File'” Y R SR S : £ 1 adal: S
c \bﬂnli»y\Wﬂd SFECE\ij“Cl \vwamp! \ﬂuﬂwwg\Dgn\BSlBﬂﬂAEElm Se:hon dgn Bunld:ng Ser.ltrm,
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CribentiaWeilS pace\Proiact:\E xamples\Building\ Dan\BSII00AE 307 Sectionz.dgn  Campasite Bulding Section %2
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E\banter\Wol: Spac»\Pm;a:t \fxamnfe:\EuEd:ng\Dgn\BSEEﬂOA%O‘E Sec!m'\ dcn

Add fllersame only disabled. top. and enabled. botiom - no models Ksted

*  FEnable Add sheet models only to add only the sheet models chac are in 2 DG to the job
Set. (MS BATCHPRI NT . ASD ONLY_SHEET MODELS)

File:: | bodsl -
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*  Enable Add design models only to add only the design models that are in a DGN 1o the
job ser (MS_BATLHPRINT_ADD_ONLY_DESIGN_MODELS)

R R T P T
Ciibenliep\woikSpoce\Fiojrcla\E xamale s \Duiding\D gn B 5120048300 Seclionz.dgn Buildng Sections

Cibentlep\WakS pace\Proieel\E kamples\BuldingA D gn\BSI3004E 301 Sectisnz.dgn  Compotite Buidng Section 11
C\bertiep\WorlS pecerPrajectz\Evample\Buiding\D gr\BSI300AE 287 Sectionsdpn  Composite Bulding Section #2

LR T L T I L ; LT I Model - : .
Ci\bertley\WatkSpece\Picjaeta\E xamples\Building  DgrABSIZ00AE 20 Seciont.dan  Compasite Budding Section i1
C\bentey\Woll:Spece\Proiect:\Eramplas\Bulding\Dgr\B 513004 30-Sections don Composite Bullding Sactan 82

Both Composste Buitding 3 ection models are Design wodels tn the DGN

Enable Open design files in read-only mode so Batch Print opens design files in read-only
mode to prevent any inadvertent modifications to the files

(MS_BATCHPRINT_NO_READONLY)

I the variable is undefined, the read-only preference is enabled the first time Batch Print runs

Defined paper sizes allowed in system printer specification

You can define PLT and PLTCFG-defined paper sizes in the system printer specification file
You can also use the plot file outpur and post-processing options previously only available
wirh Bendey printer drivers

When using Batch Print with a system printer, it Is strongiy recommended that you creare a
version of printer pit for each system printer vou will use and specify the desired Windows
printer name in each specification file using the sysprinter /name qualifier This lets Barch
Print present the list of paper sizes that are appropriate for system printer you will use. If you
use the genesic printer plt without an embedded Windows printer name, Batch Print obains
the paper size list from the default Windows printer

Additional Batch Print filename formats
The following commonly used batch prine filename formats have been added to the fisc of
available formats in the Print Filename Format dizlog box that you open from the Outpur and
Post Processing section of the Printer Properties dialog box

<dgn>-<print counter> <exrension>

<dgn>-<model>-<print counter> <extension=>
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Batch Print

<job>-<dgn>-<model>-<print counter> <extension>
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- Enhancements To Models

History Navigation

MicroSmdon V8 MM Edidon Admin

12.1/406

During 2 MicroStation session you use various models and those models may reside in
muldiple DGN files. Use the icons in the View Groups dialog box to move berween all the
models you have visited, regardiess of the file in which the model resides

aEedn

The first two icons, Previons Model and Next Model, enable you to navigate backward and
forward sequentially through the models you have visited

Clicking the downward arrow next to the third icon, All Models Visited, produces a list of the
entire model history, so you can reactivate any model you have visited during the current
session. The file name is listed first, the model name follows.

When you select a model that resides in a different file, that file is opened automaticaliy

Pressing Shift or Alt 2s you select 2 model affects the configuration of the view windows In

that model

*  Using no key causes the selected model to open with the views as they were last lefrin the
current session.

«  Press the Shift key to open the selected model with the views as they were the last dme

that Fale > Save Settings was selected in thar model

+  Press Alt to open the selected model with the views as they are in the current mode]
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Additionzal Model Properties

Notes:

Additional Model Properties

Whern you crezre 2 new model there are addidonal atrribures that you can specife

Ref Logical name

You can specify a reference logical name for the model This identifies the mode! when it is
atrached to another model as a reference

Line Style Scale

Models can have a global line style scale factor that is applied to all line styles within the

madel

If you change the global line style scale for the model, all line styles will be scaled by that
amount If you choose to apply the annotation scale, that scale will be applied to all line styles
This is useful for styles that must rewin a relationship w sheet size

< Exercise: Apply model line style scale

1 Open parcels dgn, Global Scale model
2 In the Models dialog box, right click on the Global Scale model and select properties.
In the Model Properties dialog box you can see that this model’s global line style scale
issetto 1
“Line Syle Soale:_Gisbal Line S Sedie ¥ |, - (700000,
3 Change the annotton scale for the model to 1:5.
N
4 Click OK
Click Yes in the Alert dialog box
‘The parcel numbers, which were placed with the annoradon scale lock on, scale.
However, the custom line stvles are not affected.
6  Open the Use Annotation Scale model.
MigroStzon V8 XA Edidos Admin Coprright € 2007 Bentley Systems lncorporated Do Not Duplicate
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Additional Model Properties

7 Open the Model Properdes dialog box for this model.
You can see thart this model’s global line sivle scale is ser to use the annotation scale

{ine Sl:;‘:fe..éca.iga:‘_E-ﬁﬁnﬁfa&iaﬁﬁcalé. L i

8 Change the annotation scale for the model to 1:25
¢  Click OK
180 Click Yes in the Alert dialog box

The parcel numbers and the custom line styles scale

& NOTE: Settings in the Reference Amachment Settings dialog box let you choose to scale line
styles in a reference by the global line style scale of the active or referenced model You can

aiso choose not to use either

Project index links

Enable Create Link so vou can manage the model using Project Explorer When the check
box is enabled vou can select from folders in available projects. This links the model 1o a

project in Project Explorer

@ NOTE: There must be an active project in order to create a link

Automatic field updates

The Update Field Automatically check box lets you choose to update fields automatcaily
when the DGN file that contains the model is opened In seed files this is off by default for
design models and on by default for sheet models

How fields are updated is controlled by the MS_AUTC_UPDATE_FIELDS configuration

variable
+  If not set or if ser to FOLLOWMODELFLAG, the model’s Update Fields flag will be
followed

»  Ifset to ALWAYS, the fields will always be kept up to date
+  If ser to NEVER, the fields will never be updated

Numbering sheet models

Sheet models have 2 Sheer Number property This makes it easy to put sheer models in order
for presentation or printing Remember that sheet numbers are shown in Project Explorer
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Annotation Cells

When crezting a model thar will be placed a5 a cell you can make it respect annotation scale
Any text or cells that you place with the annotton secale lock enabled in the ool setrings will
automatically be scaled by that amount

For example, if you are creating a 1m = 200m scale drawing, any cell that you place would
have to be 200 times lazger than normal so that it prints at the correct size. With annotation
scale set to 200:1, you don’t have to worry about calculating the size of the cell If you enable
the Annotation Scale lock and place a Smm cell, it will be placed in the sheet model a5
1,000mm high, but when printed at 1:200 scale it will be scaled to 5mm high

= Exercise: Create the sheet

6

Create 2 new 2D design file.

In the Models dislog box, click Create 2 new model
Create a new sheet model with the following parameters:
Type Sheer: 2D

Name: Annotadon scale test

Sheet Number: 1

Anpotation Scalz: Full Size 1=1

Display Sheet Layour: Enabled

Size ISO Al

Select Setrngs > Draning S cale

Ser the master units for this model to centmeters

——

}'E!:enlirqc!cls B =i

?IFuEI_Si:; 3{! ) *] 1 )

Select Fele > Save Settings

= Exercise: Work with annotation scale

1
2

Conunuing in the file, select Element > Cells

In the Cell Library dialog box, select Fie > Attach File
and attach \dgn\Sheet5-1 dgn.

Now you will place a cell withour using annotation scale

The Place Active Cell ool’s Annotadon Scale lock ool dp indicates the active
model’s annotation scale and the szrus of the annotaton scale lock When you make
an annotaton cell active this icon is available, indicating that vou can choose to apply
the model’s annotation scale 1o the cell vou are placing
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Select the Wall cell in the Cell Library dialog box

The icon in the znnotarion scale column indicates that this model was created with
Can be Placed as an Annotazion Cell enabled

Click Placement.

Select Place Actve Cell with the following tool settings:
Active Angle: O
X &Y Seale 0.30

Aunnotation Scale: Disabled (not depressed)

" iaks [TF00000 o
: e R £

True Scale: Enabied

Place the Wall cell on the left side of the sheet

Reset

Now place the same cell with annoration scale enabled

Place the Wall cell on the right side of the sheet, with the following tool settings:
Active Angle: 0

X &Y Seale 0.30

Annotarion Yeale: Enabled

scale:. | B.506000 “Tg "
¥ Scale::[0 260000 T

True Scale Enabled

Since annotation scale can also be applied to text, you will label the sheet Label the first cell

using text without annotation scale

% NOTE: Set the annomation scale lock before entering textin the wext edizor

= Exercise: Place text with and without annotation scale

1

Continuing in the file, select Place Text (A + 1) with the following tool sertings:
Methed: By Origin

Actipe Anple: G

Hught and Width: 2.000

Aunetation Scale: Disabled

Enter Shaft Wall in the text editor and place it under the detail on the left side of the

sheet.
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3 Rese:
Nexr, label the other cell using text with znnotation scale
4  Change the following Place Text tool setring:
Annglation Scale: Fnabled
5 Enter Shaft Wall in the text editor and place it under the decail on the right side of the
sheet
Shalt Wal Shatt wall
6 Reset

-2 Exercise: Change the model’s annotation scale

1

Contining in the design file, in the Drawing Scale dialog box, change the annotaton

scale to 1:2 5.

Click Yes in the Alert dizlog box.

Fit View:

7-128
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Additional Model Properties

The cell and rext placed with annotation scale will scale along with the model

1 i

If an annotaton cell is using annotaton scale, text and dimensions that are part of the cell will

also use the same scale

To make an existing cell an annotation cell:
1. Open the library that contains the cell as a DGN file
2 In the Models dialog box, select the cell model and click the Edit Model Propertes
icon.
3. In the Model Properties dialog box, enable Can be placed as a cell and Can be placed as

an annotadon cell

4 Click O

You can toggle the annoration scale lock for previously placed annotation cells using the key-
ins ANNOTATIONSCALE ADD and ANNOTATIONSCALE REMOVE I a selecuon
set is active, the key-ins apply only to selected annotation cells. If there is no selection set, all
annotation cells in the model are included . The key-ins are useful if a cell is placed with the

Annotaton Seale lock roggled to the wrong state.

Use the key-in ANNOTATIONSCALE CHANGE <value> to change the annotaton scale
of selected or all annotation cells.
Annotation model identification

There is a column in the Models dialog box 1o help vou identify annotation cells. To enabdle irs
display, right click « colurnn heading and enable Is Annotation Cell

Copvright ¥ 2007 Benrdey Sysiems. Incoqonmied Da Not Duplicate
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References

New reference features include the ability to manipulate references using the standard
manipulation tools, just as you would elements. Attachment sertings include options for
selecting Saved Views and Named Fences, Named Groups, Revision for Design History and
serting Global Line Style Scale New reference display settings include transparency and
priority. You have the ability to print as 31> when outputting to PDF

Information About References

Information zbour references is displayed in the body of the References dialog box in
columns that correspond to the available attachment setrings. Additional columns are as

follows.

The Status column indicares wherther a reference has been modified by another user since
the session began If 2 design history revision is attached, this column indicates that the

attachment is an historic version.

Use Reload Reference to update reference status

-« The wansparency column shows the degree of transparency for the reference Click on

the column to set wansparency.

*+  The priorigy column shows the reference’s priority. Click on the column to set priority.
Higher priority is displayed on wop.

»  Trear Artachment as Element for Manipulavon makes a reference like 2 design file
element Regular MictoStation tools can be used to manipulate or modify it. You can aiso
place a fence and then use fence tools This serting can also be set in the Setings >
Attachment Serngs dialog box
For attachments prior to the MicroStation V8 XM Edition, enable Boundary Display in
the View Atributes dialog box. You then use the reference boundary as the elemenc by

which to manipulate a reference

@ NOTE: Set the Manipulate as Element Reference user preference 1o apply this
setting to all attachments.
¢ The Named Group column lists the named group used o limit the elements displaved in

the reference
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Reference Attachment Settings

*  The Revision column lets you choose the revision used for the reference if Design
History 1s initialized for the file

* Plot as 3D (PDF) is used with the PDF printer driver only When the PDF file is viewed
in Acrobzt 7, the document will have a 3D view with controls that let you rotarte, zoom in
and oug, and walk through the model, as well as running any animation

= Exercise: Transparency and priority

Open division_plan dgn, Default model.

In the View Attributes dizlog box, enable the Transparency check box.

Open the References dialog box.

Right click on a column heading and enable display of the Priority column.
Right click on a column heading and enable display of the Transparency column

Select dp_railroad dgn.

£

Click in the Priority columa for the file.

Ry ]

(oI VN 7 R O 1 H R

Set the priody to 5
The railrozad file elements display on top of the elemnents in the other references
9  Select dp_zips.dgn.

10 Click in the Transparency colamn

11 Set the transparency to 40

The elements in other references can be seen through the filled shapes

Reference Attachment Settings

The options that were available in the Attachment Options dialog box are included as toggles
in the Reference Artachment Sertings dialog box The toggles are the same as those in the

References dialog box

Toggle Description

Display Display or do not display the reference

Snap Controls whether wou can snap to reference
elements

Locate Cenrrols abilin 1o select reference elements

Treat Aviachment as Elemnent for Lers vou treat a reference like 2 design file

Manipulation element You can the use regular wools ©

modifi the reference
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True Scale

Indicates whether reference was artached with
true scale enabled so that master and
reference measurement units are reconciled

Scale Line Styles

Indicates whether reference was sttached with
the ability 10 apply a plobal kne style scale
factor o cvery line style.

Clip Back

Indicates if back clipping was applied

Clip Front

Indicares if front clipping was applied

Display Rasrer Refs

Indicates whether or not raster refesences

display.

Ignore Auachment when Live

Indicates if this attachment will or will not

Nesting (on) be displayed when the actve model is
referenced with live nesting.

Use Lights Indicares if source lighting celis in the
reference will be considered (on}
When the PDF printer driver is used, the

Plot as 3D {(PDF) reference is plotted as 3D daw in Universal

3D (U3D) format

Orientation options

You can choose to reference the contents of Saved Views and Named Fences In those
caregories, you can select from a standard view to apply to the view attachment instead of the

rotarion stored with the saved view or named fence

<> Exercise: Attach a named fence

1

2
3
4

Open REFPlan dgn
Open the PRINT SHEET model

In the References dialog box, click Avach Reference

Arrach REFPlanContours dgn, with the following attachmens settings:

Modet: Defanlt

Orpentation > Named Fences. A2

Taggles: Display, Snap Locate, Treat Attachment as Element for Manipulation, True

Scale

Seale: 1:1G00
Live Nesting: Enabled

Enter a data point 1o place the reference in the file

Right click and press and select Move from the pop-up menu

Enter a dara point o select the referenced named fence
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Reference Attachment Settings

8 Place the reference in grid A2

When vou artach a named fence you can use the Modify wol or Element Selection handles to
modify it. You can use the Manipulation tools or opdons on the Reset pop-up menu to

manipulate it

Remember that whes Treat Attachment as Element for Manipuladon is enzbled you can use
regular MicroStation tools to modify any reference actachment
= [Exercise: Attach additional named fences
T Continuing in Open REFPlan.dgn, astach REFPlanContours dgn:
Ovrientation > Named Fencer: A3
2  Place the reference in grid A3
3 Attach REFPlanContours.dgn:
Orientatzon > Nawed Fencer B2
4 Place the reference in grid B2
Ateach REFPlanContours dgn:
Orentation > Named Fences: B3

6 Place the reference in grid B3

-» Exercise: Attach saved views
T  Open training_grid dgn. Ground Floor model
2 In the References dialog box, attach plan.dgn with the following atiachment settngs:

Modet Sheet Border

Oreniation: Colncident

Seale: 1:1
o> 3 . .
W 3 Awmzch plan dgn with the following attachment settings:
MicroSmdan VXM Editon Admin Copreight € 2007 Buntey Svstems Incorparated Do Nor Dupliea
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Modet: Ground Floor All
Ortentation > Saved 1Views. interior walls
Seale: 0.5:10
4  Enter a data point to place the reference on the left side of the sheet
Atutach plan.dgn with the following artachmenr settings:
Moadet: Ground Floor All

Onentation > Saved Views: interior doors

Stale: 0.5:1.0

& Enter a darz point to place the reference on the right side of the sheet

Saved view clip boundaries

If you attach z reference that has a saved view that includes a clip boundary, the Clip
Boundary Element options control whether the clip boundary element is copied into the
master file or if it Is associated o the clip boundary element in the reference’s saved view

Nesred reference levels in saved views

Note that saved views now store the stare of levels, whether on of off, for nested references

as well as for direct artachments

Named groups

Use the Named Group option 0 identify a narned group to vse ro limic the elements
displayed in the reference. You can select a named group during attachment or change the
serting after a reference is artached in the Serfmgr > Attachment dialog box

= Exercise: Determine display using a named group

1 Continuing in waining_grid dgn, in the References dialog box, right click on a colurnn
heading and add the Named Group column.

2 In the References dialog box, select plan dgn, Logical name interior walls.
Righe elick and select Sertings from the pop-up menu.

4  From the Named Group option list in the Attachment Sertings dialog box, select

grid.
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5 Click OK

AL
| N

Display for the referenced saved view is limited to the elements in the named group
The group name is indicated in the Named Group column

To reser display that was filtered by 2 named group, select the empry entry in the Named
Group option list

Design History revisions

The Revision option list lets vou choose the revision to reference if Design History is
initalized for the reference.

Overrides

The overrides options for nested references let you control display, locate, snap, raster
reference display, and level display for sets of nested references

+  Allaw will create level and display overrides as required This is the default behavior in
version 8 5 2 and earlier All references that were attached before MicroStaton V8 XM
Edition will have this setzing

»  Always saves the level and view display state for everv nested attachment. This gives
mzximum controllability because it locks the sertings for all nested attachments and they
change only if the user specifically changes themn

+  Never will not ever create overrides for any nested references. The nested references are
shown the same as when the reference is opened as the master file.

= NOTE: This can also be set in the MS_REF_DEFAULTSETTINGS configuration variable
asing nestOverride=allow, nestOverride=always and nestOverride=never
New Level Display

This setzing determines whether 2 reference displavs newly created levels It also applies to
new levels in nested references
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Select from Alwavs, Never and Use MS_REF_NEWLEVELDISPLAY Configuration Variable
Use Alwars so new levels are always displaved or Never so they are never displaved

The Use MS_REF_NEWLEVELDISPLAY option displays new levels according to the
MS_REF_NEWLEVELDISPLAY configuration variable Ser to 1, MicroStation will display new
levels. By default, new levels are not displayed

If the configuration variable is set, it takes precedence over the user preference

NOTE: Controlling level display is only possible when both master and reference are in the
V8 format

These options can also be set in the Preferences dialog box, Reference category,

Global LineStyle scale

Fach model can have a global line style scale that is applied to all the line styles in the model
You can apply the line style scale of the master model, the referenced model, hoth, or neither

to line styles in a reference.

In the following examples the master model’s line style scale is 25 The referenced model’s

line style scale is 10

*  If you select None, the referenced line style is nor scaled

D - D - b - Master model

Haniit il il i il bl il i ot Referenced nredel

«  If you sclect Master, the actve model’s global line style scale is used to scale the line stvle

Murter mode!

B B B

"",“‘“”.““b“"’“”’“'—’~-— Referenced model
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Reference Boundary

+  If vou select Reference, the referenced model’s global line stvle scale is used

o o o o [ e Master mods!

Referenced madel

»  If you select Master * Reference, the active model's global line style scale is multiplied by
the referenced model’s global line style scale to scale the line style This will factor out an

absolute ratio.

B - - - Master mode!

Referenced model

Reference Boundary

The Move Reference tool has a Move Boundary with Reference opton If a reference has clip
boundaries or masks, this setting lets you define whether the reference boundaries or masks
move with the reference, or if they remain static while the reference moves over them

Reference Key-ins

Many reference attachment setzings, such as display, snap, and locare can be modified with the
new REFERENCE SET key-ins. This can simplify the task of modifying the sertings on a
group of references and gives you the opton of using a batch process

For most of the references operations, there is 2 key-in alternative that vou can use when
required. You can use the keyv-ins to do the following
= Awwach and detach references

«  Modify reference auributes
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*  Merge references

See the Help topic Managing References and Raster Images > Working with Axtached
References » References kev-ins > Reference settings key-ins for a complete list

Reference Exchange

Commands for attaching and detaching references, as well as manipulation commands, are
available on the pop-up menu that appears when you right click on 2 reference in the

References dialog box

You can also launch a new MicroStation session or open another file using this menu

=» Exercise: Redirect to a reference

1  Continuing in training_grid dgn, right click on a reference in the References dialog

box
2 Select Exchange from the pop-up menu
The reference becomes the acuve file.

When vou Exchange to an attached model, the elements from the reference are displaved in
the same position within the views as you saw before you initiated the exchange

You can also select Exchange from the Reset pop-up menu when you right click and press
with the pointer over reference graphics in the file If you select Edir Reference from the
menu, the file will open in another instance of MicroStation so it can be edited.

Reference Preferences

MicroStton V8 NM Edidon \dmin

12106

Options in the Preferences dialog box’s Reference category let you custornize

Arttachment preferences

Default reference parameters can be specified either by setting the configuration variable
MS_REF_DEFAULTSETTINGS or by setting them in the Reference section of the Preferences
dialog box The configuration variable takes precedence If a particular actachment setting is
specified in the configuration variable, the corresponding user preference is disabled.
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The setungs that can be controlled by MS_REF_DEFAULTSETTINGS ate sect by
“serungname=vaine” paits, delimited by commas

Settingname Value
display= 1]¢
snap= 10
locate= 11
trearAsElement= 1O
trueScaie= 110
sczleLineSeyfes= 10
displayRasterRefs= 110
ignoreWhenNesting 110
useLights= 1o
plotAs3D HU
saveReladvePath= ija -
nestDepth oo
nestMode copy | live [ none
attachMethod= cvincident | world
displavBoundary= 10
newLevelDisplay= fromconfig| ahvays | never
nestOverride= allow | always | never

By default, all elements in a referenice highlight when the reference is manipulated. If
MS_REF_DONTHILITEFORMANIP is set to any value, this highlighting is disabled This can

speed up reference manipulatons

If MS_REF_DEFAULTATTACHDIRECTORY is set, the reference atachment file dialog box
defaules o this directory rather than the directory of the last attached reference

Other preference options

*  Remap Colors on Copy uses colors with the closest color martch from the master file’s
color table when copying elemencs

* Ifyou enable Allow Editing of Self References you can modifv self-attached reference
elements and the changes will be incremensally displaved.

*  Copy Levels During Copy determines how levels are handled when copying from
references
If Not Found means thart levels will be copied from the reference only if they are not

found, orif a level with the same name is not found

[f Overrides Exist means that levels will be copied from the reference if the level does
not exist, or if the serdngs for the level are different than those of the aztachment
Select Always so levels can be copied even if an identcal level exists within the active

model
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Raster Files

The Raster Manager dialog box has been updated and raster file handling has been
significantly enhanced

Raster Manager Dialog Box

The Raster Manager dialog box has 2 menu frame in which the active DGN file and its
attached references are listed in 4 hierarchy tree The properdes frame provides information
about the selected actachment. The configuration of these frames is conurolled through items

on the View menu.

Icons are available for manipulation

Use the Actual Resolution icon to quickly display images at 1:1 resolution pixel for pixel on
the screen Use the Contrast/Brightness icon to adjust these propertes on the fly

Additional file information

e + In 2D, the Plane column shows the plane on which a raster is displayed Double click in
= the column to change this serdng in the Plane dialog box The optdons are background,
foreground or the design piane. Using these settings you can layer raster and vector data

Users can use the Plane oprions on the View menu to limit the raster attachments listed
in the dialog box to those found on the background, design or foreground plane

‘ *  The Display Priority columa, also visible only in 2D, shows the display priority value for
- raster artachments Double click in the column to change rhis setung

Right click on column headings to add more columns

»  Add the Level column to see the level to which a raster is assigned Click in the column to

change the level
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Raster Manager Preferences

# NOTE: You can snap 0 Rasters using AccuSnap.

Additions to the Settings menu

Cache Manager

Use this utility to manage raster image cache files generated on your hard drive To open it
select Settings > Cache Manager in the Raster Manager dialog box

You can choose when and how to delete cached image files and vou can specify the amount
of disk space thev use You can also specify a cache files location. Set the settings and click

Run Now to run interactvely
Binary enhancement

If 2 view is zoomed out far enough that it causes loss of detall in the display of binary raster
attachments, enable Settings > Enbance Binary to enhance their display, similar to a bold
foreground

Raster Manager Preferences

There are user preferences that affect the display of raster images. Since they are stored in the
user preference file, they do not need to be medified every time an image is atrached

*  Enabling Ignore Locate Interiors means that a raster artachment can only be selected by
its border Ifir1s disabled, the actachment can be locared with 2 dara point in the intezior

*  You can set a default display plane for reference attachments

¢ Set Defzuit Raster Auributes if raster files must always be placed on a cerwain level, or
using a certain style or weight for a border.

Attachment level

A raster atrachment is automatically assigned to the active level if no default level is specified
in the vser preferences Raster attachments are weated as standard elements with regard to
level operations such as display, freeze, lock, plot and viewporr freeze
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Additional Aitachment Settings

Additional Attachment Settings

Monochrome options

You can select the foreground color and wansparent background of a monochrome raster in
the Attach Raster Reference dialog box The raster preview reflects the foreground color

selected

Additional supported formats

+  Raster Manager supports many raster formazs, including Erdas IMG, DOQ, WMS, CLR,
LRD, MPF, RST, DIM, FIL, GIF and others

»  You can artach or create JPG 2000 files using Raster Manager.

*  You can create ECW files using Raster Manager

Attaching PDF files

PDFE attachmients are view only.

> Exercise: Create and attach a PDF

1

2

3

4

5

6

7

8

9
w10
B E
12

WicreSadon VE XM Edivon dmin

1200000

In contours dgn, open Model-1.

Select File > Print to open the Print dialog box

In the Printer and Paper Size section, seiect Bentley Driver
Select pdf plr and click Open.

Click Print

Save the print as contours pdf, to a locaton that you will remember
Close the Print dialog box

In areaplan dgn, open the Default model

Select Frle > Raster Manager

In the Raster Manager dialog box, click Amach

Atrach contours pdf with the following artachment setung:
Place Interactrrely. Disabled

Click Open

The PDF is attached, in the Background plane
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Additional Attachment Settings

Raster Manager supports the Adobe PDF mult-page format If a PDF has muldple pages,
there is an option list in the Artach diatog box that lets vou select the page to attach

Elernent Info Menu

The Attachment Settings from previous versions can be found in the Element Info dialog
box that opens when vou double click on a raster acrachment in the Raster Manager

Configuration

There is a new category, Raster, in the Configuration dialog box This category of variables is
available to control Raster files

Remote raster references

To attach a remote raster reference, key-in DIALOG REFERENCE ATTACHURL to open
the Select Remote Raster Image to Attach dialog box. In the URL field, enter the path to the
remoze reference.
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Design History

A new icon in the status bar indicates if a file has design history If design history is not
initialized, the icon is dimmed. It becomes active when design history is initialized. If design
history is initialized and there are uncommitted changes, a crayon is superimposed on the

icor’s scroll

Right clicking on the icon opens a design history shorrcurs menu.

Configuration

AMieroStdon V8 XM Edidon Admin
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MS_DESIGN_HISTORY supports the new design history funcdonality

Tag, enabled by defauly, lets you use tags 0 name revisions

Changedesc, disabled by default, lets you change che author and description of 4
previously recorded revision.

Combiae, disabled by defaul, lets you delete a range of revisions and replace themn with a
single net revision

Retire, disabled by default, lets vou delete all revisions from the start of history w a
selected revision

Autoupgrade determines whether you are prompted to confirm when upgrading
previous design hisrory data to the MicroStation V8 XM Ediuon design history format

By default, users will be prompted.

TIP: Set and lock MS_DESIGN_HISTORY a: the site, project, or system level 1o prevent users
from changing the settings
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Set Revision Number Format

Set Revision Number Format

Revision numbers are listed 25 <major revision number> <minor revision number> by
default MS_DESTGN_HISTGRY_REVISION_NUMBER_FORMAT lets vou change the format
of the revision numbers

The key-in HISTORY MANAGE SET REVISIONFORMAT <format> also sets or
removes custom tevision number formatting on a file by file basis

2F11
2F12
2¢113
2F14d
2F18

HISTORY MANAGE SET REVTSIONFORMAT 2F

If you do not specify a value for <format™, custom formating is removed from the current

file

A NOTE: A custom revision number formart will override the formart set in the
MS_DESIGN_HISTORY_REVISION NUMBERFORMAT wvariable,

If the custormn revision number format is removed from a file, formartng is conrrolied by the
configuration variable if it is set If no custom formatting is specified in the file or the
configuration varigble, then the defauit # # formarung is used

View the formatting

The key-in HISTORY MANAGE SHOW REVISIONFORMAT shows the revision number
formatting that will be used for design history It shows one of the following

+ A custom format defined for the file.

*  The custom format defined in MS_DESIGN_HISTORY_REVISION_NUMBERFORMAT

» A message indicating that no custom formatting applies w revision numbers and the
default # # formartng will be used

Revision Properties

You czn change the aethor and descripuon of a previously recorded revision using the

:’“«:}}ﬁ Revision Properties dialog box. By defaulr, this is disabled by MS_DESIGN_HISTORY. To
enable changes, set changedesc and changeauthor to 1. Then make the changes in the
Revision Properdes dizlog box and click QK
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Tagging Revisions

Tagging Revisions

You have the option to name revisions using tags The tags identfy a particular revision using
a descriptive name rather than 2 random revision number. For example, revision 1 8 may have
been commirted when 2 project was 25% complete. Creating a rag for that revision that is

named “25% complete” identifies it more clearly Design History tags can then be attached as

references,

1.6
Enginaeting stvs 22
Inithal layout 12
22 . 2005712408 08130 Ravisions kom engineer
21 2005/12/08 0810 Sel Wajot Rigvizion Mumbie)
ig 2005212708 08.63 25% complete
% 2005742708 06:08 Addiional leatutes
T4 2005772408 GB:08 Aevized plan
13 2605/42/08 08:08 Added l2atutes.
T2 2865/12/00 BE:08 Baze laypout
i1 3BO5/12/08 08:08 Initisfize

Attaching o tagged revision as a referense

Create the tags in the Design History Tags dialog box Select Utifities > Design History > Tags 1o
open it Once  tag is created, click in the Value column to associate the tag to a specific
revision The Tags column in the Design History dialog box shows tags that refer 1o each

revision

Reviewing Element Change History

You can review the change history for an element by selecting the element in the Element
Changes dialog box and clicking the Show Histary icon

Like the Isolate icon in the Design History dialog box, the Show History icon changes the
operating mode of the Design History dialog box to show an individual element’s history.
After you are done using Show History, click Isolate history by fence or selection 1o restore

the Design History dialog box to its normal mode

S Exercise: Isolate the history of a single element

1 Open MidstazeV_work dgn, taking ownesship

2 Select Took > Design History to open the Design History tool box
3  Select Show design history

4 Make sure chat Use color-coding to show changes is enabled in the Design History
dialog box. Enable all the Show elements icons
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Reviewing Elemant Change History

5 Select each of the revisions listed.

Observe the colorizaton of elements in the design, showing how the elements were
manipulated during the session

6 Select revision 1.3
The elements that made up the parking area are shown in red

7 Double click on revision 1.3 or highlight it and select the Show elernents changed in

seleczed revisions rool

The Element Changes dialog box appears, listing each of the elements that were
atfected in the revision, 2long with details about the changes

As you select each individual entry, that element will be the only elemenr shown in
the design with color coding

Selecr the Line String entry.

In the Elernent Changes dialog box, click the Show history tool

The revisions that affect the line string are active in the Design History dialog box.
All other revisions are dimmed.

10 Select revision 1.2,

11 Click Show elements changed in selected revision.

Information zbout how the element was changed in the specific revision is shown in
the Element Changes dialog box

F NOTE: The appropriate color-coding must be enzbled 1o see the activity

You can review the revisions that affected a pardcular element using these tools,
since only the revisions that affect the element are available This is useful for
reviewing the changes to 2a element leading up to its deledon.

12 Click Isolate history by fence or selection in the Design History dizlog box

Information for the entire revision is listed in the Element Changes dialog box and
all the elements involved in the revision are shown color coded

NOTE: You can check an element’s atrributes using the Element Informadon tool
that is available in the Element changes dialog box

4

13 Close the Element Changes dizlog box

2 Exercise: Isolate history using a selection set
1 Continuing in MidstareV_work.dgn, use Element Selection to select one of the lines
k that make up the road behind Bldg 3 and also one of the plants behind Bldg, 3

2  Click Isolate history by fence or selecton.
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Audit Trail

Enter a daza point in the view (o accept

The Design History dialog box ttle bar indicates that you are isolating 2 selection set
Only the revisions thart affected the elements are available. Color coding will only be
displaved in the design for the selected elements

Turn off the filter by clicking Isolate history by fence or selection again
The complete list of revisions is active
Cleat the selection ser.

Select revision 1 2.

Printing revision markup

If you print while there are revisions selected in the Design History dialog box, the
highlighting and color coding associated with those revisions will be printed.

= Exercise: Preview printed color coding

1
2

Audit Trail

Condnuing in MidstateV_work dgn, Fit View.
Select File > Print.

The preview in the Print diatog box shows the color coding. Design history can only
be printed only from the Print dialog box

In the Print dizlog box, with Bentley Driver selecred, select pdf plt and click Open.
Click Print and save the file to 2 location that is easy o find.

Navigate to the PDF and open it

The color coding is seen in the PDF

Exit Acrobat

Close the Print dialog box.

The audit trail is a record of design history management actions, such as initialize, combine
and retire. Fach entry in the audit wrail contains the type of action, 2 timestamp and the user’s

name

-» Exercise: Set the configuration variable

1 Open city_layout dgn, tking ownership.
2 Open the Configuration dialog box.
MicroSmdon VB XM Edidon Admin Capvright © 2007 Benzfey Systems Incarporared Do Nt Duplicate
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Audit Trail

Select the Design History category

4  Select the Design History capabilities variable (MS_DESIGN_HISTORY)

Edit the value so that you can combine revisions

combine=1

Exit the dialog boxes, acceptng the changes

7 Select Fils > Exit o exit MicroStaton

=» FHxercise: Create an auadit trail

1 ZLaunch MicroStation and open city_layout dgn.

2 Select Uniities > Design History > Combine

@ NOTE: You Initzlize design history, Retire revisions (delete all revisions from the
start of history to a selected revision), Delete Design History (delete the entire
Design History) and set a major revision numbers using options on the Design
History menu

In the Choose Revisions dialog box, select revisions 1 2 through 1 4.

Click OIC

In the Combined Revision Description dialog box, remove the individual
descripgons and enter the following description:

Completed city area layout
Click OK.

Click Yes in the Information dialog box.

Revision 1 4 now includes the changes for all three revisions znd uses the new

2006/03/0313.35

foptiey tnatitole  inilialized desion history

2006/03/0813.37

Benlisv institte  Complated ety atea lavout |

description
1.3 eity_lsyaut.dan
1.4 ity [avoutden
21 sity_lsuout.dgn
22 city_fapou! dgn
23 city {avgul den

2006/03/0913:38
2005/03/091338
08/03/0813323

Bapllap Inctide et Major Fisvision Humber
Benliay Insitute  Dafined centrel diztict
Hentleu Inztitute  Diafingd boeush boundaties

8 Select Usfities > Design History > Andit Trail

The initialization and the combine operation are noted in the dialog box.

& NOTE: An audit tail Is automatically deleted when the design history is removed.

MictoSmuon V5 XM Edidon Admin
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Audit Trad

If you want to reset the Design History capabilities variable, complete the following exercise

= Fxercise: Reset the variable

1 Continuing in city_layout dg, open the Configuration dizlog box and delete
MS_DESIGN_HISTORY

Exit the dialog boxes, accepting the changes
Select File > Exit.
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Audit Trail
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File Protection

MicroStation saves not only information about a signer, but also information about who

issued the signer’s certificate. By saving the entre chain of certificates leading from the signez
back to the trusted root, enough information is available for any system to verify a signature
regardless of the intermediate certificate authorities it recognizes.

Enhanced Security

MicroSmdon V8 XM Edidon Admin
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File protection enhancements improve security and flexibility.

Screening certificates

Cerrificates are screened to ensure that they meet their intended purpose. Only valid

certificates are presented for you ro select

fssved 1 Jecued B

R Fi2 Bontley Inctinte T 7" ° Bentley

1= Thawte Fraemall Member  Thawte

| issued £
Bentiay

Thew certificates are present on the systens buf each has a different intended purpose
Oniy one certificate is offersd whes the Author is profecting w jile

2507 Bendey Sustems, Incorporard
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Configuration

Previously, when vou were prompred to select a ceruficate to protect a file or add 2 digital
signature, all ceraficates where presented. This enhancement applies to digital signature

creation and file protecdon

Key information

Typically, an individual protecting a file uses 2 cerdficate for which they have the private key
They then sapply the corresponding public key to the recipients

When you obtain a digital certificate from a certificate authority, your system creates two keys;
one public, which can be published and is posted to the certificate authority’s repository, and
one private which is szored on your system. The certificate authority does not have access to
the private key. It is generated locally on your system and is never transmitted to them

There is a Key? column in the File Protection and Digital Rights dialog boxes When you are
prompted o select a certificate, this column indicates whether or not the certificate includes

the private key

: 20 /30
1 Bentley Instiute 1| Bentiay Institute I 20. /1

Restricted applications

MicroStation loads only digital rights-compliant applications in a file that has limited righss A
compliant application checks for digital rights and does not perform any unauthorized
funcdons, such as printing, exporting, or modifying if those are restricted.

Bentley has cervfied the applicadons thar are delivered with MicroStation, but Bentley cannot
certify applications developed by others Many applications will be compliant because they do
not perform restricted functons Other applications have to be changed to become
compliane. So, rather than wying to prevent illegal operatons, MicroStation does not load a
non-compliant application when less than unlimited rights are granted

In the Digiral Rights dialog box, the Restricted Apps setting from previous editions will now
only be enabled if the Export right is denied. When the Export right is denied, only rights-

compliant applications can be used

Conﬁguration

MicroStation V8 XM Editon uses 2 stronger key-generation algorithm than the one used in
MieroStation V8 2004 Editon Although both algorithms are industry standard, 2 version of
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NET zssemblies

MicroStation V8 2004 Edision can not open a file that was protected by MicroStadon V8 XM

Editon using the stronger kev-generaton algorithm

You can direct MicroSration V8 XM Edition to use the previous algorithm by serung the
MS_PROTECTION_VB_COMPATIBILITY configuration variable The defaultis 0 which does

not limit encryption strength

Set Limit encryption strength, in the Protection category, as follows.

«  Setitto 1 if you want o protece files and create licenses in 2 way that V8.1 and V8 2004
Edition can open.

+  Setitto 0 if vou want to use stronger encryption, producing protected files that V81 and
V8 2004 Edidon cannot open.

.NET assemblies

- The owner of a DGN file can not only idendfy trusted digital certificates but also trusted
NET assemblies. This lets vou use .NET add-ins, VBA, for example, with protected DGN

files without undermining digital rights checking

Use the tools in the File > Profection > Applearions Trusted Applications dialog box to add
rrusted signing certificates and NET assemblies.
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NET assembilies
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Database Interface

You can interface with an extern.al darabase using Oracle, OLE DB and ODBC connecuons
and also through the Bentey Universal Database Connection (BUDBC)

Bentley Universal Database Connection

BUDBC provides the functionality MicroStation needs to query and manipulate data in a
database BUDBC is also an interface It is used with ProjectWise Managed Tables, a database
connecton to the ProjectWise server. Through this connection you can access and store
MicroStation database attributes in the ProjectWise database

The MS_LINKTYPE value for BUDBC linkages is BUDBC. The database linkage ID is
BUDBC_ID 0x5834 22580

Connection types

There are three types of BUDBC connections

*  OLEDB, which will take 2 connecton string from a UDL file

*  SQL Server, which requires the following connection sting:
Password=pwuser;Persist Security Info=True;
UserlD=pwuser

*  Oracle, which requires the following connection string:
Password=mantabs;Persist Security Info=True;

UserID=mantabs;Data Source=pworadi
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Bentley Universal Database Connection

MizroSmzon VB XM Edidon Admin
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Connecting

The DLL is written in C# so you must register the DLL with the system using the Net
application regasm exe This application can usuzlly be found at:

CAWINDOWS\Microsoft NET\Framework'vl 1.4322

To use regasm exe, use the following key-int from the command prompt in the <MicroStation
folder=>\mdlsys\asneeded folder:

C:\<MicroStation folder>\mdlsys\asneeded\>
CAWINDOWS\Microsoft NET\Framework\v1.1 4322\ regasm exe BUDBCConnection dll

This command will register the C# DLL and allow MicroStation and MicroStation VBA to
access the objects and methods in the DLL To un-register the DLL use can use the /u option

with regasm exe.

GIS.UDL OLEDBS data source

To use the GISUDL OLEDB datz source you mast first connect to it using the OLEDB

connection. The reason for this is that the OLEDB connection updates the path in the UDL
file to accurately refiect the location of the GISMDPB file on the system Once the connecrion
is established using the OLEDB connection, the BUDBC connection can use the same UDL

file to connect to the delivered GIS database.
Oracle

The BUDBC connecton for Oracle is based on the Oracle Dara Provider for Oracle 10g To
use this connection vou must install the Oracle 10g Data Provider as part of the Oracle
Client For additional information on the QOracle Data Provider, visit the Oracle web site

Configuration variables

MS_DBBUDBCDATEFORMAT

Formart of date fields returned from the database For example %B %d, %Y will return dates
in the formart of (September 14, 2006). Note that the comma *,” was added and displayed as

part of the format. Spaces also marter

M5_BUDBCMAXDATA

Limits the amount of data returned from database columns which have vizroally unlimited
space These columns would be MEMO columns in Microsoft Access and LONG columns
in Oracle The default value of this variable (s 1024
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Bentley Universal Database Connection

Sharing the database connection

BUDBC provides the ability to share the same database consection berveen MicroStation,
ML and VBA The BUDBCConnecton. dil has the type library embedded in it

You need ro reference the Bendey Universal Database Connecton Interface in the Visual
Basic Editor to use any of its methods In the Visual Basic Editor, select Tools > References >
Benrley Universal Database Comuection Interface.

AMictoSuton VB NM Edigon Admin

127106

F2iBenliay Linrveral Database Connaction Interface |
] IAS Helpar COM Component { C Type Library
171 1A% RADIUS Protocal 1.0 Type Library
| Acrobat
+ A7 JAcrobat Access 2 0 Type Lineary
Sl Acrohat Access 3 0 Type Library
] acrobat Distiller

L visual Basle For Applications
Bantisy MicroStation DGR B 9 Object Lbrary
' OLE Avtomation

[iAcrebat WebCapture 1.0 Type Lirary

[_iAcrohat WehCaplure 1E ToolbarfFaverites | 8 fypet

[“lacrolEHelper § O Type Library
4
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Bentley Universal Detabase Connection
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- Google Earth Tools

The Google Earth environment provides you with an interface to planet Earth.

What it is

You can view and navigate 2D and 3D models of projects in the context of the Google Earth
environment Through this connection, MicroStation users can publish DGN and DWG
models which can be viewed and navigated in the context of the geographic imagery with

associated content,

MicroStation files placed in the Google Earth environment can contain links to more detailed
data that can be reviewed locally, rrning the Google Earth environment into a graphical
delivery svstem for project informadon. This informadon can be provided in a variety of
formats, including Excel spreadsheets, Word and PDF documents, additional DGN and
DWG files, and URLs All types of project information can be shared through the Google

Earth interface.

How it works

You export geosmetric data so that it can be viewed in the context of satellite data, aerial
photography, maps and other geographical data You then get an aerial view of geometry and
geography. However, the Google Earth environment is not intended to be a deiled CAD

viewer.

While the Google Earth environment is designed and optimized for spatially large designs, it
is not intended for visualizing geometric detail Inclading excessive deail will quickly exceed
the current capacity. It is important to select and export only the geometry that is valuable

MicroStation provides datz to the Google Earth applicadon as KML documents, an XML
based data structure for creating and sharing geographic data. MicroStation geometry
exported to XML remins the reference and level strucrure chat is defined for a model This
lets you selectively conurol the display of individual levels or references Saved views are also
saved to IKML so that they can be used to navigate to views of interest

Do Not Duplicaze
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Detining Geographic Location

Defining Geographic Location

MiceaStzion VB XM Edidon Admin
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In order o accurately define the geographic location of 2 model when exporrng, you must
provide the model’s locaton and its orientadon. There sre three methods you can use to do

this

*  Use the MicroSuation GeoExtension applicatons and their associated projecton
capabiiities to handle geographic projections.

*  Use a single placemark monument to define the location of 2 known point in the model

and then use the DEFINE NORTH key-in to indicate the orientaton.

In order to use this method, the geomerry must be drawn accurately and the working
units must be set correctly so thac the size of the geomerry is known.

+  Place two or more placemark monuments to provide the complete projection transform
{location, ortentation, and scale).

This method is useful when accurate scale and orientation information Is not known and

an approximate projection is sufficient:

Defining a placemark monument

These are used to associate a geographical location from a Google Earth environment
geograp g
placemark file to a monument poiat in a model First you must create a placemark file in the

Google BEarth applicaton and save it as a ML file

To create a KML file:
1 Launch the Google Earth application.

2 Create a placemark.

3 Righr click on the placemark and select Save As from the pop-up menu.
4. Save the file as Type kml.
5 Click Save

Placemark monuments are cells named KmlPlacemark with enter-dara fields that show the
name, longitude, latdtude and aldrude of the monument The placemark celi is locared in the
cell library KmlPlacemark.cel in the \Svstem\cell folder. It is placed automadcally when you
use the Define Google Earth Placemark Monument tool.
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Defining Geographic Location

The origin of the cell represents the location of the placemark in the model The design file
locaton can be modified by moving the cells The longitude, laatude, and zltitude values can
be modified by editing the appropriate text elements Placemark cell geomeury is placed on
the level KML Placemark You can turn this level off w avoid displaying or exporing the
monument geometry Scale is set by the active design file scale

2 Exercise: Define a placemark monument
1 Launch MicroStation and open placemark dgn
Select Tools > Google Earth

2
3  Select Define Placemark Monument
4

Snap 1o the center of the yellow circle to identify the point at which you want to
locate the monument and enter a data point to zccept.

5 In the Select Monument Placemark File dialog box, navigate to the class data set
\data\placemark folder

Select Google Earth - Bendey Exton kml.
Ciick Open.
Open the Key-in browser and enter:
DEFINE NORTH BYPOINTS

9@  Press Enter or click Run Key-in.

10 Enter a data poinr at the placemnark location and a second in the direction of the
arrow in the image

This defines North.

The origin of the cell represents the location of the placemark in the model. The design file
locaton can be modified by moving the cells The longirade, latitude and altizude values can
be modified by editing the appropriate text elements Placemark cell geomerry is placed on
the level KML Placemark You can rurn this level off ro avoid displaving or exporting the
monument geometry Scale is set by the active design file scale
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Exporting files

F NOTE: If you are working with MicroStadon GeoExtension you do not need to define a
monument point in 2 model

Removing placemark monuments

To remove all placemark monument cells in 2 model, you can vse the key-in
GOOGLEEARTH PLACEMARK DELETE

Exporting files

Once you have created 2 placemark file and defined a placemark monument in a model, you
can export the design geometry. When exporting, you have the choice of file types

The KMZ file type is a compressed version of IKML Both file types are recognized and
extracted automatically Tvpically, KML documents are large, so the compressed form is

preferable.

Collada files include support for textures, and can be used in other applications that support
them. You can export geometry to Collada (version 1 4) files, by selecting File > Exporz >

Collada

Configuration

You can control the default directory for the ourpur KML files by setting the configuration
variable MS_KMLOUT If this variable is not set, the output directory defaults to the current

DYGN file locaton

Settings

When geometry is exported, the view atiributes and level settings are taken from the acuve
view It is important 1o set up the view exacdy as you want it to display in the Google Earth
application. Qutput should be minimized to inclade only necessary data by turning off
unnecessary levels and disabling text and dimension view artributes if they are ro be excluded

The Google Earth Export Serings dialog box has settings thar contro! how the geamerry is
exported Open it by clicking the Google Earth Serrings rool.

General settings let you do the following
«  Google Earth Version Optons let vou set the version of Google Earth required, 3 or 4
Google Earth version 4 introduced support for textures Select this version if you want o

export geomerry with textures intact
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Exporting files

»  Srroke Tolerance (Meters) controls the accuracy of the mesh approximanng curves or
curved surfaces A smaller value produces a2 more accurare representaton but file size is

larger and display is slower

+  Transparency Override controls the level of wansparency for the geometry Including 2
lewvel of wansparency allows the geometry to be seen without obscuring the aerial
photography below it

+  Convert Custom Line Styles converts custom line styles to IKML. by dropping them to
their individual components This produces correct display of the line style but can
increase file size and degrade performance.

*  Convert Raster References To Ground Overlays converts raster references in the X-Y
plane to ground overlays. The raster references overlays are placed in 2 separate Raster
References folder Their display can be controlled as a group by selecting the folder, or
individually by selecting the individual references.

* Include Raster References in KMZ File includes raster references if you are creating a

compressed KMZ curpur file

-

3D setings:

+  Render Mode sets the mode of shading If a view is rendered and this is set to From View,
then the display mode is tken from the acdve view

+  Convert Wireframe Geomeuy in Rendered Views exports wireframe geometry, such as
text, Hnes, curves, and dimensions along with shaded objects in 2 rendered view

The Captured Geometry sertings let you set the level of deail that is captured as well as the
following
+  Enable Google Earth View to Determine Roration so the Google Earth view perspectve

1§ mainwained on capture.

Where there is no information about the location of a model, it 1s assumed that your
model’s origin coincides with the center of the Google Earth view and that the y-axis is to
be aligned with North

Export

When vou export models, first use the Google Earth Serdngs dialog box 1o define how they

are exported and displayed When vou exporr, the Google Earth application opens
avtomatically If is not already open It navigates to the Jocation of your placemark and model

< Exercise: Export geometry

If vou have Internet access and the Google Earth application is installed, vou can
complete the exercise

1 Click the Export Google Earth (KML) File rool
2 In the Create Google Earth (KML) File dialog box, leave the file type ar KMZ
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3 Click Save

The export is completed and the Google Earth applicaton opens and navigartes to

Capture Google Earth Image

Use this ool in 3D DGN files to capture the terrain and imagery of the current Google Earth
view The caprured image will be at screen resolution and in monochrome (2 Google Earth

restricrion).
Model location

If there is no information about the location of the model, MicroStation assumes that vour
model’s origin coincides with the center of vour Google Earth view and that your model’s Y-
axis is to be aligned with north If location informatdon is present in the model, then
MicroStation uses the transform derived from it

NOTE: To maintain your Google Earth view perspective, enable the Use Google Earth View
to Determine Rotation option in the Google Earth Tools Setdngs dialog box

To capture a2 Google Earth image:
1 Setup a Google Earth view displaving the required area
2 In MictoStation, select the Caprure Google Earth Image tool

Enter a data point to caprure the current Google Earth view

[WA)

NOTE: Note that the use of the Google Earth images is restricted by the Google Earth
license agreement. Please consult that document {select Help > License) to insure that vour
use of these images does not violate the restrictions

Tips for capturing a view

Helpful serrings and options within the Google Earth application are as follows
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Synchronizing Views

*  For best results, the view should have the carnera poindng straight down

)

8
Goagte Earth spplicationy comera 8t control

*  In order to capture terrain, the Terrain layer must be enabled in the Layer panel

*  On the View tzb of the Tools > Optons, Google Earth Options dialog box, set Detail
Arez o Large 1024 x 1024 and (Graphics Mode to DirectX

*  Resize the Google Earth applicatdon window to the size of the graphics image desired.

Synchronizing Views

You can move to the same view location and osientation in either MicroStation or the Google

Earth applicaton

Synchronize Google Earth View tool

Use this too! to navigate the Google Earth applicadon to the location and orientation of the

acrve view in MicroStation.

As the Google Earth application supports a camera model with a fixed Jens length and
restricts the camera to pointing downward only, the views will not always march exacdy, but

should provide a reladvely good approximation for most views

To svnchronize, set up the view as desired and select the Synchronize Google Earth View
tool If the Google Farth Application is not open, it opens automatcally.

{ Gongie Bardh - Bentley Exton

1
i | Direclione: Tohere - From hers

Chiek on the image fo zoom rght lo the area
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Synchronizing Views

Follow Google Earth View tool

Use this tool to navigate the actve view in MicroSution to the Jocation and orientation of the
current view in the Google Earth application This ool will work only if the model’s view
location is geographically close to the current location in the Google Earth application

To match the active view to the Google Earth application’s view, set the view up as desired
and select the Follow Google Earth View wol
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AutoCAD Interoperability

There are additional enhzncements that increase interoperability.

Default Units for Opening DWG files

A very important change is that the default Decimal, Scientific, or Fractonal Units LUNITSs
setdng is “Design Center Units™ rather than “Meters”. This change to the default setting
should reduce unit mismatches when the default settings are used 1o open DWG files

Prior to AutoCAD’s Design Center, unless a file had its units set to Architectural or
Engineering, which strongly implied Feet/Inches, there was no way of knowing the true size
of objects When AutoCAD introduced the Design Center (R2000) an additional setting was
added ro DWG files to indicate their true unit serring If this value is ser correcty, there is no
ambiguity in a file’s units and it can be referenced or used as a cell using True Scale

When MicroStation creates a DWG file, it always sets the Design Center units correctly
When opening a DWG file created by MicroStadon, the units will always be correct. Now, as
long as files from other sources have the Design Center units set correctly, they also will open

with the correct unirs

Tt sl is possible to have the Deswn Center units value set to Unidess or Unspecified When
this is the case, an alert dialog box appears ro allow vou to select the correct units

DWG Workmode Units

In DWG workmode, the units format in the Working Units category of the DGN File
Settings dialog box can be set to Architectaral, Decimal, Engineering, Fracuonal, or Scienufic

M chlectus af
D ecmal

Hodly wrkitg Unil Seltngz ™

s

FI&L[E’I’)E‘J g
Sl

Decwey DT L T)C
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Save As DWG/DXF

These define the linear units to use when opening DWG files with Decimal, Scienzific or

Fractonal Units

Save As DWG /DXF

The foliowing sertings have been added to the General tab in the Save As DWG/DXF
Options dialog box These settings were previously accessible only as configuration variables,

Basic options

Units

The Arch /Engineering (Feet/Inches) option lets you save a file with either Architecoural or
Engineering units based on whether fraction or decimal readout is required. Previously,
Architectural or Engineering units would be used only if the file had Master and Sub units sec
to Feet/Inches and coordinate readout set to Master:Sub units. By selecting this option, the
file will be saved with these units, even if the current units do not match the criteria

Advanced options
Create True Color From DGIN Color Indices

MicroStadon supports custom color tables, while AutoCAD supports only a fixed table
When 2 color from 2 MicroStaton table is saved to AutoCAD, it can use either the closest
color in the AutoCAD rable or a True color

If this sexting is enabled and there is no exact martch in the AutoCAD table, a True (RGB)

color is used
Force Zero Z-Coordinate

This option should onlv be used 10 save 2 3D DGN file that represents a 2D drawing, but in
which some geometry may contain non-zero values in their z-coordinaze If it is used the
resuling DWG entides will have z-coordinates of zero value

Define the configuradon variable MS_DWG_FORC E_ZERO_ZCOORDINATE so this setring is
enabied by default
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Dimension Text Placement

References options

Set Viewpart Layer From Clip Element

When this sewting is enabled the laver for a viewport will be set to martch the laver of the clip

element from 115 reference attachment
Set Viewpoint Locked From Locate Off

Use this option to set the Locked status of a Viewport to the Locate Off setting from its
reference attachment.

Dimensions options

Always Create an In-line Leader for Notes

If this option is used, 2 note without an in-line leader will result in a leader endty with an in-
line leader If it is not, the note will remain as a leader without an in-line leader in DWG, but

will cause an AutoCAD Audit error
Define MS_DWG_LEADER_HOOKLINE so this serting is enabled by default

NOTE: Save Actve Dimension Sertings is relocazed from the Advanced category 1o the

Dimensions category.

Dimension Text Placement

MicraSewian Ve XM Editon Admin

P21

Previously, when a dimension was set to have text over the first extension line in AutoCAD,
ali the dimension text displaved over the first extension line When opening the file in
MicroStation, the dimension text would shift to the second extension line

When working in MicroStation, make dimension text stay on the first extension line by
adjusting two settings on the Advanced tab of the Dimension Styles dizlog box
+ In the Text > Formar secdon, set jusuficaton 1o Left or Right

+  In the Tool Specific > Size Arrow section, set Text to Vertcal (if using Size Arrow or the
default tool)
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Auvtodesk i-Drop Indicator

Autodesk i-Drop Indicator

Some Web pages contain DWG content that is i-Drop enabled so you can drag the content
from the Web page and drop itinto MicroSwaton In order o place content from a Web page
as z cell, vou must download the i-Drop Iadicator

Placing content from a Web page as a cell

Download the i-Drop Indicator from hep://usz autodesk.com/adsk/servlet/
indexrsitelD=123112&id=2753219&ink]ID=2475161 It is installed as a plug-in to your

browser

When you point to content that is i-Drop enabled, the pointer changes to the i-Drop icon
When vou drop the content into a model it will be placed as 2 cell The Place Active Cell too!

becomes active and you set rool sertings

The key-in WEBDROP DIALOG opens the Web-Drop Settngs dialog box, which lets vou
set opuons that will affect the content
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- APPENDIX:
"~ SELECT Server V8 XM Edition

V8 XM Edition products no longer require a license file. All licensing information Is entered
and validated with activation keys SELECT Server V8 XM Edition manages both V8 XM
Edition and pre-V8 XM Edition applications, such as MicroStation V8 2004 Editon or
MicroSration/].

Licensed applications no longer require a constant connection €0 a system running SELECT
Server V8 XM Edition. They do, however, need to connect at least once every 30 days. This is
<0 ensure that users of Bentley applications are not denied use of their application(s).
SELECT Server V8 XM Edition communicates directly with Bendey servers to perform such
tasks as downloading license entitlements and uploading usage logs Oprtimally there 5
communicaton every day, but it can be delayed up to a maximum of 30 days

About SELECT Server and the SELECT Server Gateway

+ V8 XM Edition applications will communicate directly with SELECT Server V8 XM
Edidon.

- All pre-V8 XM Edition applications will communicate using the SELECT Server V8 XM
Edition Gateway. Any pre-V8 XM applications that curreatly receive their licenses from a
SELECT Server will be able to receive licenses froro SELECT Server V8 XM Edidon

through this Gateway

This Gateway replaces an existng SELECT Server, so it makes sense to install it on the
same server as the old SELECT Server, if the server meets the prerequisites. Once the
Gateway has been installed and activated, the old SELECT Server can be uninstalled

& NOTE: The SELECT Server V8 XM Edition and SELECT Server V8 XM Edidon Gareway
may be installed on the same system, or on separate systems

Proxy server environments

SELECT Server V8 XM Edition will work in a proxy server environment in several ways

» V8 XM zpplicatons can communicate to SELECT Server V8 XM Editon by way of 2

PIOXY Server
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instailation and Cenfiguration

+  SELECT Server V8 XM Editon can also communicate with Bentdevcom Web services
by wav of a proxy server

+  SELECT Server V8 XM Edition Gateway can communicate with SELECT Server V8
XM Editon by way of proxy servers.

Installation and Configuration
To install SELECT Server V8 XM and/ar the SELECT Server V8 XM Gateway, check the
prerequisites and complete the following sieps.
Prerequisites

The first step is to check the prerequisites needed to install and run SELECT Server V8 XM
and/or the SELECT Server V8 XM Gateway.

« Microsoft Windows 2000 Server (SP 4 or later)
Microsoft Windows 2000 Advanced Server (3P 4 or

later),
SELECT Server VB XM Edition + Microsoft Windows 2003 Server Web Edition
and the Gateway « Microsoft Windows 2003 Server Standard
are supported on these operating Edition
systems: « Microsoft Windows 2003 Server Enterprise
Editan
* Microsoft Windews 2000 Professional (SP 4 or
later)

+ Microsoft Windows 2000 Professional

‘T he Gareway is also supported on these
* Microsoft Windows XP Professional

operating systems:

Before you can install SELECT Server V8 XM Edition you must have Internet Informasgon
Server with ASPNET supporr and Microsoft NET Framework 1.1 installed, along with
other requirements.

+ Internes Informadon Server (with ASENET
support)

* NET Framewozk 1 3

» MSXML 40 SP2 or above

. - o * SQL Server 2000, 2005 or MSDE with Service
SELECT Server V8 XM Edition requircs: Pack 3 or higher (If SQL not already installed,

SELECT Server installadon will inscali MSDE)
= Intel Pendum {or equivalent) processor or beuter
+ TCP/IP Networking enabled
¢ 256MB RAM Minimum
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NET Framework 11
» MSXML 4 0 SP2 or above
: + Intel Pentiom (or equivalent) processor or beter
requires: . )
« TCP/IP Nerworking enabled
+ 128MB RAM Minimum

SELECT Server VB XM Edition Gateway

If you need 1o install prerequisites, install in the following ozder:
+  MSXML 40 SP2 or above

»  Internet Information Servers (with ASENET support)

+  NET Framework 1.1

NOTE: When installing I1S on Windows 2003 Server, you are given the opton to instali
ASPNET. However, this option is not available when installing it on Windows XP or
Windows 2000 Server. In order to install ASENET on these, you should install IS before
installing Microsoft NET Framework 1 1. When NET Framework is installed, it will then
detect that ITS was installed and add support for ASPNET If you install [IS after NET
Framework, you will not have support for ASPNET, and the SELECT Server Administration

site will not function.

Also, review the pre-installation check list in the on-line Help at SELECT Server 178 XM
Installation and Configuration > Pre-Installation Check List. Installadon of the required products is
described further here.

Obtain a license and an activation key

A serial number and an activation key, which are obrained from Bendey Sales Support, are

required.
+  Request a new SELECT Server XM Editon license and identify the sites that you want it
Lo manage

One SELECT Server V8 XM Edidon system can host multple sites A site can be
thought of as  license pool, so one SELECT Server V8 XM Edition system can host
multiple pools, each dedicated to a physical location as defined in the SELECT

Agreement
s

«  Existing SELECT Server license pools {one per site) will be converted 1o SELECT
Server V8 XM Editon license pools.

Also, you will need to find our the address of the Bentley Server you will be vafidating your

information against
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Installztion and Configuration

Installing SELECT Server and the Gateway

& NOTE: You must have Internet Information Server with ASPNET support inswalled. If you
do not, vou will not be able 1o install SELECT Server V8 XM Edition. You can, however,

install just the Gateway.

A IMPORTANT: SELECT Server V8 XM Edirion requires a database server You can either
use an existing SQL Server or install MSDE, the Microsoft SQL Database Engine, during the
SELECT Server installation It is delivered free with SELECT Server V8 XM Edition
If you are using an SQL Server you will need to know the name of the SQL Server and the
user name that has administrative rights for this installation.

The InstaliShield Wizard

The Bentley SELECT Server V8 XM Edidon InstallShield Wizard guides you through the
installation of both SELECT Server V8 XM and the SELECT Server V8 XM Gateway

& NOTE: You will need to install 2 SELECT Server V8 XM Edition Gateway for each existng
SELECT Server that yvou wish to convert

*  Ogn the Sewup Type page:
- Enable the Complete radio button if you want to instail the complete package; SELECT
Server V8 XM and the Gateway
- Enable the Custom radio button to customize the instailadon, 1o eliminate the Gateway

from the install, or if you want to install only the Gateway

- - To eliminarte the Gateway from the install, expand SELECT Server Gateway on the
Custom Serup page and select This fearure will not be available

Cuskom Setup

r‘";";‘ -
Select the program features you watt installad Ee EBENTLEY“
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Installation and Configuration

- - To inswll only the Gateway, expand SELECT Server V8 XM Edition on the
Custom Setup page and select This fearure will not be available

Custom Sctup

Select the progrem Features you weant instafied

This festure wil not be avallable.

% NOTE: If IIS is not installed but you are only installing the Gareway, just click Next
on the Checking Internet Information Server page. To install SELECT Server V8
XM, you would need to quit the install if you see this message and install IIS before
continuing.

thecking Internet Information Server

—
B ot .
Benkley SELECT Server VA ¥ Editlon recures Internst information S SEENTLEY

+  If you are installing SELECT Server V8 XM Editon, on the SELECT Server Darabase
page vou will choose whether to use an existing SQL server or MSDE

- Select Use an existing SQL. Server to use an existing SQL Server Provide the name of
the server and the user name that has administrative rights

- To use MSDE, select Install MSDE Configure MSDE with a password for the SQL
Admin account, usually SA

T NOTE: MSDE may require you to reboot the system

+  If you are installing SELECT Server V8 XM Edition, on the SELECT Server
Configuradon page, enter your SELECT Server V8 XM Editon serial number and
activation key This information is only required if you are doing a compierte install or if
vou selected Bentdey SELECT Server XM Edition for a custom install

»  If you are installing the Gateway, on the SELECT Server Gateway Configuration page,
enter the machine name or DNS name of the machine on which SELECT Server V8 XM
Editon is installed and the site activation key

# NOTE: If vou do not have the SELECT Server V8 XM Edition serial number and
activation key, you can continue with the installation but SELECT Server V8 XM
Edidon will not run unul this information has been entered on the Administraton
Site. Obrain these items from Bentley Sales Support Information for existing
licensing can be obtained from the Bentey Administrative Center (BAC)
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Instaliation and Configuration

*  On the Install the Program page, click Install. If vou are doing 2 complete installation or
installing Select Server V8 XM Edidon, the SELECT Server Database Serup Utility statts

after serup compleres

-Troubleshooting the Gateway:

Specifying a proxy server for the Gateway

The SELECT Server Gateway will use the Proxy Server for which the license client is
configured

1 Launch LicenseTool exe located in the \Program Files\Bentlev\SelectServer folder

1.

Select Optians from the Tools Menu
3 Select the Proxy Configuration tab

4 Enter the proxy server informaton.

(8]

. Click Apply then O

6. Restart the Bendey SELECT Server Gateway service

Verifying client connectivity to the Gateway
To verify client connecdvity you can Telnet to the port on which the Gateway is lstening
1 Open a Command prompt.
2. Enter TELNET <select server name> 3998

3 Press Enter.

You will see an OK message followed by “Connection to host lost”.

Add a firewall exception to enable remote access

Windows XP Pro SP2’s firewall sertings disable all remote access to the system In order for
SELECT Server and the Gateway to work, vou must add a firewall exception to the Windows

Firewall rules.
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Instaliaticn and Configuration

To do so, in the Conurol Panel, double-click the Firewall icon. Click the Exception tab in the
Firewall dialog box Click Add Port Enter the name SELECT Server V8 XM Edition -
Gateway in the Add a Port dialog box. Enter 3998 as the Port number

Mame: |SELELCF Serves X4 VB Ediion - Gateway

Pail pumber §3333

Gateway is not running error

If you receive this error but the Gateway is running, except on another system, it is likely that
a complete installation of SELECT Server V8 XM Edidon was done

Check the system on which SELECT Server V8 XM Edidon is running and see if there are
two Bentley services running; Bentley SELECT Server and Bendey SELECT Server Gateway
If so, you will need to uninstall the SELECT Server V8 XM Edidon Gateway.

1 Open a Command prompt.

2 Change directories to the directory to which you instalied Select Server V8 XM (typicaily
C:\Program Files\Bentlev\selectserver).

3 Type in;

SYSTEMROOTY% \Microsoft NET\Framework\v1 1 4322\InstalilUdl exe /u
Bentley SelectServer Gateway exe /Assembly bin\Bendey SelectServer Common dil

4 Press Enter

Database setup

Complete database setup in the Bendey Select Server XM Database Setp dialog box.
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NOTE: To open the dizlog box if it is not already open, select Windows Start menu > All
Programs > Beniley > SELECT Server > Database Utilicy

First, enter your SQL Server name in the Server field or enter the name of the local
machine followed by \SELECTSERVER if you are using MSDE
(machinename\SELECTSERVER)

Next, enable the Use a specific username and password optionn SELECT Server V8 XM
Editon runs as System Service, therefore it is recommend that vou do not use Windows
NT Integrared security

Then, enter your database name in the User Name field. If vou are using MSDE, enter
SA as the user name

Next, enter the password for your SQL database user in the Password field or enter the
assword vou created during installation if vou are using MSDE
J ) B f=4

If you are running SQL Server, vou can set the Run As User option

The Database setup udlity requires 2 user with administrative rights on the SQL Server in
order to create the required tables and stored procedures However, when SELECT
Server is running, vou only need to have select, insert and delete righes to the database If
you do not want the SELECT Server V8 XM Edition processes to run as the SQL
Admin accouns, disable Lise the same user as above and enter the desired user name and

password in the fields provided

Finally, select the database to be used by SELECT Server from the option list or click
New and enrter a new database name.
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Installation and Configuration

It may tzke several minutes to configure the database The Darabase creadon complete
messzge appears when the process is complete.

-Troubleshooting the database:

Strong SA message when installing SQL Server
You will need to run the instaliation executable from a Command prompt with a switch
setup.exe SAPWD="AStrongSAPwd"

Where “AStrongSAPwd” is your own strong password for the system administrator (SA)
login account

Error “msxmli2.dll not found”

Search 1o see if it is present on the system If not, the issue is that an upgrade to the operatng
system did not upgrade all of the files required by MSDE. Go to support microsoft com and
search for:

“FIN: MSXML 2.6 is not redistuributed with SQL Server MSDE SP3 or SP32”

to download the msi package to fix the problem.

Don’t want SS processes to run as SQL Admin

The database setup utility requires a user with administrative rights on the SQL. Server in
order to create the required tables and stored procedures However, when SELECT
Server is running, vou only need to have select, insert and delete rights to the database It
you do not want the SELECT Server V8 XM Editon processes to run as the SQL
Admin account, disable Use the same user as the one above and enter the desired user
name and password in the fields provided

Verifying licensing and activation

SELECT Server

+  Select Start > All Programs > Bendey » SELECT Server > Administration Site or enter
hetp:// <SELECT Server Name>/bss/admin in the Address field of a browser

The SELECT Server V& XM Ediuon Administradon Site indicates that configuration is
required.
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Installation and Configuration

*  If the serial number and acrivation key are shown, verifv that they are correct. If nog,
enter your serial number and activaton kev

*+  Verify the license file contains the appropriate applications and usage counts, then
Accept. The file is saved to SELECT Server V8 XM Edition
The Gateway

If you did not have your SELECT site acdvation key during the installation process you need
o configure the SELECT Server V8 XM Edidon Gateway using the SELECT Server
Gareway Configuradon Utdlity.

*  Select Start > All Programs > Bentley > SELECT Server > Administration Site or enter
http:/ /<SELECT Server Name> /bss/admin in the Address field of a browser

*  Click on View License File under Administration in the directory on the left

*  On the SELECT Server Properties page, select the site for which you want the activation
key The activation key for the site is shown

7 Bentley Exatnple Sie [S003237) N

Site Name Bantley Bxample Site
1 4083837
EWDKLWCEFRGWIE:
License Mode SEECT

ticense Type COMMERCIAL

# af Applications 212

*  Select Start > All Programs > Bendey > SELECT Server > SELECT Server Gateway
Contfiguration. In the GWAdminForm dialog box, enter the machine name or DNS name
for your SELECT Server in the SELECT Server Name field

% NOTE: The SELECT Server Name is the name of the machine on which SELECT
Server V8 XM Edition is ruaning You can find this name by typing in HOSTNAME
at 2 Command prompt

*  Enter the site activadon key in the Site Activation Key field You can click the Verify

button o verify the setrings If the SELECT Server name and site actdvadon code are 2

valid combination, vou receive a message stadng this

o (lick Save
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-Troubleshooting licensing and activation:

Eiror retrieving a license from Bentley.com

Error, HTTP starus 404 Not Found This indicates that the SELECT Server coutd not
communicate with the licensing server at bentley com because it does not have access t©© the
internet or requires a proxy server to access the internet

If your server needs 1o use a proxy server to connect to the internet. Use the Server Setdngs
link on the SELECT Server V8 XM Edition Administration page to configure your proxy
settings. If you cannot connect your server to the internet, conract Bentley BAC for assistance

with obuaining a a license manuaily.

“Crypto API could not be loaded” error

This error usually means ¢hat the SELECT Server can not reach the internet to talk-to the

Bentley licensing web service

First determine if you use a proxy server for internet access. If you do, configure the proxy
server settings using the Server Settings option on the SELECT Server Administration page.

Open SS-AdminSite-WebServices log, located in c:\program files\bentley\selectserverilogs

Search for the word ERROR You will find a description of why the connection could not be
made For example, “The underlying connection was closed: The remote name could not be
resolved” indicates that the SELECT Server could not resolve the DNS names for
appsnet.bentley.com or buddi.bentdey com

No 88-AdminSite-WebServices.log file

The log file may not be created because the ASPNET worker process doesn’t have rights to
write to the logs folder Grant WRITE access to the ASPNET user accouns on the
c:\program files\bentey\selecrserver\logs folder

«Server does not support activation key” for hosted license
PP Yy

The activation key takes at least an hour to be updated in the Bentley Hosted XM server for it
to be recognized for MicroStation

Also, ensure that the email that came from the Bentey Administration Center It should only
list a Bentey Server Name and activaton key If it bsts a SELECT Server serial number,
SELECT Server activagon kev and site/ Gateway activation key, it is the informadon for

{0 N Duplicate
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running SELECT Server XM on your site Coneact the Bentdev Administraton Center to re-
send the informadon for 2 HOSTED license

Start the SELECT Server services

The SELECT Server Service is 2 Windows System service that is responsible for processing
usage logs which contain updated dara that the SELECT Server V8 XM Edition relies upon,
system notifications and Usage Log processing You can start the SELECT Server V8 XM

Editon and Garteway services from two locations.

To start from the SELECT Server Administration Site, do the following

»  Select Start > All Programs > Bendey > SELECT Server > Administration Sice or enter
hop://<SELECT Server Name> /bss/admin in the Address field of a browser

= (lick Manage Services under Administration in the directory on the left.

»  Click the Start button next to Bentley SELECT Server.

o (lick the Start button next to Beatley SELECT Server Gateway to start the Gateway

Service.

To start services from the Windows Service Control Marnager, do the following,

+  Select Start > Sectings > Control Panel > Administranve Tools and double click on
Services (Local)

«  Double click on Bentey SELECT Server or Bentley SELECT Server Gareway
and click Start, then OK to start the service. Or, right click on the desired service and

select Start from the menu.

Upgrading SELECT Server V8 XM Edition

Micradtaton VB XA Edidon Admin
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This consists of uninstalling a previously installed version (Start > Setdngs > Conrrol Panel >
Add/Remove Programs) and then installing the newest version. The re-installation process
was desigried with upgrades in mind, so all of your configuration setzings, including SELECT
Server serial number and activadon key will be retained.

NOTE: During the upgrade process pre-3M clients will not be able to obtain 4 license from
the SELECT Server Gareway
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Re-installing

When reinstalling, follow the wizard, verifying your SELECT Server serial number and
activation key and your SELECT Server Gateway settings if you are installing the Gareway
When you click Install the installer will copy the required files and configure IS accordingly
When the process is complete, click Finish

Database upgrade

A

All of the previous database settings will be pre-configared and you will see a message
informing you that the Selected database currenty has version 1.### of the Bendey
SELECT Server XM darabase schema installed and that this install of Bentley SELECT
Server XM requires schema version 1 ### Continuing will migrate the database to the
required version. You just click OK to upgrade the database schema to the required version
Then click OK when you see the Database creation complete message

Versions prior to 08.09.02.35

1f you are upgrading from a version of SELECT Server prior to 08 09 02 35 you will be
notified that SELECT Server must process your usage data. During chis time SELECT Server
V8§ XM Edition will continue to process license requests

WARNING: During processing you will see a progress bar Do not stop the processing as this
will result in loss or corruption of data. Wait and then click OK at the Processing Complere

message

Restart the SELECT Server services

+  Select Start > Run and type in; services msc then click OK

+  Locate Bendey SELECT Server in the fist of services If the status is not Started, right
chck and select Start from the menu

+  If you are running the Gateway, locate Bendey SELECT Server Gateway in the list of

services and srart it if it is not started

SELECT Server XM Administration Site

MicreStaton VE XM Editlon Admin
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This site is the interface used to manage SELECT Server
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Administration tasks

Administration options let you manage services, adjust server and site serdngs, control the
transmission of log files to Bendey Systems, register multiple users at one tdme.

SELECT Server Tasks

Each task listed here shows the date and time it was last run, the result of the last run, the
current status, 2nd has a button to run the task

The Error Log Posting Service allows MiczoStation XM Crash dumps o be forwarded to
Bendey by way of SELECT Server V8 XM Editien.

Usage Log Posting is the process that sends SELECT Server usage log numbers to the
Bendey Web Service on a daily basis

Usage Log Processing processes the daily logs that are sent from the client system to
SELECT Server Builds the report data and prepares the usage logs for posting to Bendey.

The Noufication Service is the daily alert system for notifying administrators of usage
overages, impending product license expiration and system errors

The Dara Update Service connects to Bentley on a daily basis 2nd retrieves any license file
changes, and any updates wo suppordng database tables that SELECT Server relies on
Adnunistrators have the ability to disable the automatic license update, in favor of manual

review and acceptance of a license

Errarfan #ostng Taereion: e A Suncesy idie Run Naw

T Suecess Lefte RUN Mow

Usage Lol Foiting

2 Gu 1l Fa Now

Bl Lo Frooes

Warsing tdin Run How

Hetificaton 74

Livstste Ypdake Sarsirs Gunagis e Fun Plow

Server settings

The Settings page is used to configure server settings such as serial number, activation key,
data archiving, mail, proxy and database settings The Windows services sertings let you set

the time at which SELECT Server processes run
Usage Log Transmittal

Usage Log Transmital options let vou set the parameters for manual log rransmitral instead
of the automatic transmirtal, which is the defauit Enable Transmit application usage logs
manuzlly to bypass automatic uansmittal of usage logs. Steps for manual transmission are

found on the Transmit Usage Logs page

Coprrighe £ 2007 Bendey Sysiems Incumporaed Do Nor Duplicae

15-188

MicroSwmzdon VE N Edivon Admin

127106




SELECT Server XM Administration Site

MicroSaaton V8 XM Editan Admin Copyriht £ 2607 Bentley $ysiems Incnporaied

1251406

Site Settings

Determine site settings for individual sites or to set global settings for all sites
Checkout settings

Toggle Enable clients to checkour licenses to enable or disable license check our ar the site
level. If disabled, checkouss will fail

The Maximum Checkour Interval specifies the maximum number of days a license can be
checked our from the server The default is 90 days

Transmit Usage Logs

SELECT Server is configured to tansfer the usage logs on a nightly basis, directly over the
internet, to Bentley com. If your SELECT Server will not have access to the internet, you can

configure it for manual log transmittal

SELECT Server will still process the usage logs on a nighdy basis and create the log files that
would be transmitted on a daily basis However, these log files will accumulate in the database

until you manually inidate the transmittal process

+  First, configure SELECT Server for manual log transmictal This is done on the Server
Settings page.

Usage Log Transmittal :

SELECT Servers application usage logs MUST be transmitted to Bentley on
electronically during mightly processing This method requires that the SELE
directly or through a proxy server,

Aternately you can manually transmit the log files by ¢-mail or web page fr
applitation usage logs manually check the option below

{ i Trarsmit appication usaps loos manuai's,r.l

Then, The Transmit Usage Logs page has sections that walk you through the process of

rransmitting log files to Bentdey

+  Step |, creating a manual log transmittai file. This is done on the Transmit Usage Logs
page, in the Prepare Logs secdon
Click the Create File button to prepare a log file for manual transmittal The button is

only active if the Transmit application usage log manuaily check box in the Usage Log
Transmittal section of the Server Sertings page is enabled

> Step 2, downloading the transmital file for wansfer This is done in the Downioad
Submiteal Files section It lists all cransmiceal files that have not been downloaded for
transfer. Click the Download button next to the file o be downloaded

No files are listed if you didn't click Create in the previous step and files that have already
been downloaded do not shovw in this list If you need to re-download a file, use the
Previously Sent Transmitral Files secuon
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*  Step 3, wansferring the file. This is done in the Transferring the manual wransmiteal file
secuon Choose to email or uplead the files or to mail the files to Bentley on floppy or

cD

* Step 4, acknowledging the file transfer A response xml file is required to verify that vou
have sent the usage log files If the file transfer has not been acknowledged within 30 days
of tansfer, SELECT Server will stop issuing licenses You receive the response.xm file
by the method in which the usage logs where submirted {email, upload, mail)
The Process Acknowledgment File section displays a list of usage log files awaiting
acknowledgement
Browse buton to the folder that contzins SELECTServerUsagel ogs zip and select
response xmi. Then click Open Click Process File, then Submit to send the

acknowledgement

Bulk Registration

Use this page to register multiple users using 2 CSV file. Use the Registration From File
field to identify the CSV file to be used for the bulk registration

FIRST MaME  LASTMEME U EMALT T USERNAME L DoMEN
Robart . Smith .. ... _iher smithGwork com rol hooo ABC

Sample entry from o CEV bulk registration file

Viewing reports

The Report Options secton appears on the top of every SELECT Server report. Itis used to
define the range of information you want to see Use the + to expand the section You can set
the number of days in the past for which to display report information or select a date range
from which to view it See information from all sites or from individual sites

Reports

Reports in this section provide many site and application details
°  Summary reports show application usage by site and by application

The Machines column shows the number of machines that have been used ar the selected
site. The Peak Pooled Usage column shows the highest number of machines that have
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been used simnuleaneously. The Peak Pooled Date column shows the dare the highest
number of machines were used simultansously

Daily Pooled Usage reports show the application usage, by site, for 2 selected ume range
Applicadon Usage reports show application usage informatdon by site

The # of Versions column shows the number of versions of an application used during
the selected date range. The # of Machines column shows the total number of machines
using all versions of an application used during the selected date range.

Last Application Usage reports show the last usage of an application by site
Machine Usage reports show usage information by specific machine

The Unique Applications column shows the total number of applications used on the
machine This does not include multiple versions of the same application The Total
Version Count column shows the total number of different versions used on the specified
machine, including multiple versions of the same application

Named User reports

Daily client usage reports show daily icense usage, by user, per site and application.
Monthly client usage reports show monthly license usage by vser, per site Server Usage
reports contain details about the servers accessed (machine name and SELECT Server
version), by application, from the specified dates and sites

ELS (Enterprise License Subscription) reports

App Usage by Month reports show peak moath applicadon usage for each application
licensed under an ELS Site App Usage By Month reports show peak monthly application
usage for each application per site licensed under an ELS.

-Troubleshooting the Administration Site:

Page Not Found error or raw HTML

On Windows 2003, make sure that ASPNET support has been loaded for IIS In the
Control Panel, click Add/Remove Windows Cornponents Select Applicaton Server and
click Details. Select ASPNET and click OK.

On Windows 2000, Windows XP Pro or Windows 2003 if I1IS was installed after the
Microsoft NET Framework, NET must be registered with IIS.

At a Command prompr trpe in; ed /d %windit%\microsoft nec\framework\v1.] 4322
and press Fnter. Type in; aspnet_regiis exe -i and press Enter Restart IIS by trping in;

iisreset and pressing Enter.
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* You may need o enable ASPNET by adding ir to vour Power User group. Go to the
Conurol Panel > Administrative Tools > Computer Management Expand Local Users
and Groups Click on Groups Righs click Power Users and select Properties Click Add
In the Enter The Object Names To Selecr field enter ASPNET. Click O Make sure
something\ASPNET is showing in the Members box Click OK and exit Computer
Management. Restart the system

401 Error “Access Denied”

»  Although anonymous access was defined the Windows 2000 Server may also be a domain
coatroller. The IUSER_Server did not have sufficient access or did not exist Usea
domain administeator account instead.
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161 APPENDIX:

- New Configuration Variables

Cells

MS_RESOLVESCNAMECONFLICTS controls how shared cell name conflicts are handled for
operations like reference merge. If set to 0, there is no resoluton. If ser to 1, the defaulr,
MicroStation resolves the name conflicts on DWG shared cell instances; if set to 2,
MieroStation resolves name conflicts for 2ll non-anonymous shared cells

Colors

MS_COLORBOOK_LIBRARIES contains the list of DGN files that are used as a souzce for
color books

MS_SYSTEM_COLORBOOKS sets the direcrory name conrining the system colot books
delivered with MicroStation

Data Files

MS_DATETIMEFORMATS provides the list of formass available for Date/Time fields in the
Fieids Editor

MS_BSTLOG_CONFIG_FILE specifies the location of the file that controls and configures
diagnostc logging The defaultis S(MS_DATA)BSILOG CONFIG XML

MS_BSTLOG_ENABLE allows the logging of diagnostic messages.

DWG/DXF

MS_DWGSETTINGSFILE points to the file that contains the sertings for opening and saving
DWW files

MS_DWGSYSTEMDATA points 1o the directory that is used o override the local direcrory as a
source for DWG sertings files

MS_DWG_LSTYLE_FONTPATH derermines the locadon of the fonr file
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MS_DWG_LSTYLE_FONTNAME determines the name of the font file, and therefore, the name
of the font

MS_DWG_CREATE_SPACE_FROM_EDF if this variable is set to 1, any empty enter dara field
femains as a Space

MS_DWGSAVEAPPLICATIONDATA affects saving linkage dara and type 66 application
elements from IDGN o DWG. If sex, the applications are stored as XRECORDS and the

linkages as XDATA The default is off.

MS_DWG_FIELD_2005F0QRMATTING if this variable is defined and ser to 1, MicroStation
only generates field information that AutoCAL 2005 supports

Design History

MS_DESIGN_HISTORY_ _COMMIT_ON_MODEL _SWITCH specifies whether changes are
committed to Design History when the model is switched

MS_DESIGN_HISTORY_COMMIT_DOC_PROPERTIES if this variable is set to 1 (the default),
design history tracks changes to docurnent properties such as Title, Author and Comment

Distributed DGNs

MS_DISTRIBUTED_DGN_COMMIT_ON_SAVE specifies whether changes are commirted to
the distributed DGN when the file is saved.

MS_DISTRIBUTED_DGN_COMMIT_ON_CLOSE specifies whether changes are committed to
the distributed DGN before the file is closed

Extensions

MS_GUITASKTREEROOT defines which tasks are available in the Task Navigavon wol box.

MS_DOCKINGPREF

MS_DWG_OBJECT_DRX

MS_PROCESSEXCEPTIONLOG use for MicroSmton exception log and minidump dmp

managemertt
MS_PROPERTYENABLER _APES

MS_CUSTOMIZE_REPORT_STYLESHEET
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MS_SELECTBY

MS_BUTTONMENY

MS_ECFRAMEWORK_SCHEMAS

MS_RASTER_DEF _DIR

MS_VIEWTOCLBOX3D

MS_VIEWTOOLBOX2D

MS_MAINTOOLBOX

MS_ICONRSCLIST lists directories containing rsc files for icons.
MS_TCONLIBRARYLIST lists directories containing dli files for icons.

MS_ICONPATH lists directoties containing files for icans

MS_MIXEDMODBEBUTLD

Levels

MS_LEVEL_DISPLAY_FORMAT specifies the formarttng that the level name uses when the
level lists display, including in PDF plots If N, the default, the level name is used If D, the
level description is used; if C, the level code is used More than one value can be specified

MS_LEVEL_ALLOW_LIBRARY_LEVEL_EDIT allows vou to edit library tevels when it is not
yet used in master-file. If not set, a library level can be edited only when if it is used If set, a
library level that is not vet copied into the master file can be edited On editing, the library

level will be copied into the master-file

MS_LEVEL_PICKER_WIDTH sets the width, in pixels, of the level picker in the Artribures
tool box.

MS_HIDE_LTBRARY_SOQURCE_NAMES if this variable is set to 1, hides the leve] library name
(in brackers) that precedes the level name.

Operation

MS_LEGACYDRAWORDER for 3D wireframe views, use a draw order based on the element
posidorn

MS_MAINMENUDOCKINGBESIDE if this variable is ser to § or not sex (defaulr), the
MicroStation main menu bar spans the entire width of the application window If set ro a
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value other than zero, tool boxes and dockable dialogs can be docked along the main menu

bar

MS_SOURCENAME PROPERTY if this variable is set the SOURCE file properry can be set o
the name of the source file By default, only the name and extension of the source file are
saved. Set to 0 o disable the SOURCE property. Set to FULL wo save the full path of the

source file.

MS_NO_VIEW_ANIMATION if on, the animation of view tile and cascade is disabled.

MS_NATIVEMAINMENU if this variable is set to 0, menus that are larger than the screen size
do not have top and bottom scroll arrows, and auto menu positioning is not avaitable If ser to

1, menus appear corzectly

Printing

MS_BATCHPRINT_NO_READONLY if this variable is set to {, Batch Print opens design files in
read-only mode, which is the defauls

MS_BATCHPRINT_ADD_ONLY _DESIGN _MODELS

MS_PLTDLG_CLOSE_AFTER_PLOT if this varable is set to 1, the Print dizlog box closes
automadeally after 2 print job is performed successfully

MS_PLT_SET_PRINTER_FROM_SHEET if this variable is set to 1, the default Print dialog
box printer is taken from the active sheet definivion (if one is present)

MS_PLT_SET_LAYQUT_FROM_SHEET if this variable is set to 0, the Print diaiog box layout

is not automadcally set when a sheet definition is loaded and the current print area is Sheet

MS_PLT_SET_PLOT_STYLE_TABLE_FROM_SHEET if this variable 15 set to 0, plot style
rables specified in the sheer definition are not attached to the plot

MS_PLTDLG_SHOW_BASIC_LAYOUT _CONTROLS if this variable is set to 1, the Prine dialog
box’s Rotation field and Mirror option menu are hidden The orthogonal print Roraton
option menu Is displaved instead.

MS_PLTDLG _ALLGW_FORM_SIZE_EDIT if this variable is serto 1, the size of the selected
form may be modified via the Priat dialog box.

MS_PLT_SHOW_PRINT_STATUS if on, 2 print status dialog box opens when a job is being
printed. You can cancel the priat job.

MS_PLT_THUMBNATL_PREVIEW_TIMEOQUT controls how long the chumbnail preview in the
Print dizlog box paints before stopping to allow the rest of the dizlog box to refresh The

defaultis 10 seconds
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MS_PLTDLG_SHOW_ACCURATE_PREVIEW_ROTATION if this variable is set to 1, the
Preview dizlog box displays the plot in its current rotation

MS_PLT_SET_UNITS_FROM_SHEET if this variable is set to 0, the Print dialog box's units
are not auromarcelly set from the sheet definition when the current print ares is Sheet

MS_PLTDLG_TRANSPARENCY_OVERRIDE sets the Print dialog box’s transparency print
artribute 1o 2 value other then the one obrained from the view

MS_PLTDLG_DISABLE_PREFERENCES_DIALQOG if this variable is set to 1, the Preferences

menu item Is not displayed on the Senings menu

MS_PENTABLE _SEARCH_LEVEL_LIBRARIES if this variable is set to 0, level libraries are

aot included when searching for level names defined in the pen table

MS_PLT_ABBREVIATE_BORDER_FILENAME if this variable is set to 0, the file names
included in the plot border text are not abbreviated.

MS_PLT_USE_VIEW_BACKGROUND_COLOR_FOR_RENDER if this variable is ser to 1, the
print engine does not change the background color for the plot when rendering,

MS_PLT_USE_HARDWARE _PHONG if this variable is sex to 0, the print engine uses the
MicroStation software renderer 1o render Phong view modes and reference presentadon
states, including shadows If set to 1, the graphics card is used instead.

MS_PLT_APPLY_COLOR_MOBE_TO_RASTER if this variabie is set to 0, the print engine does
not apply the color mode specified in the plot descripdon to raster data

Protection

MS_PROTECTION_VB_COMPATIBILITY limits encrypdon sirength { = stronger; previous
versions cannot open (default) or 1 = previous versions can open protected file and create

Leenses

Primary Search Paths

MS_ADDINPATH search path for managed AddlIn assemblies that are used outside of
MicroStadon’s application base or configured privatePath.

MS_ADDIN_DEPENDENCYPATH Search path for managed assemblies thar are used by AddIns
ourside of MicroStation’s application base or configured privatePath Directories should not
be listed here and in MS_ADDINPATH

MS_GUIDGNLIBLIST lists direcrories containing IDGN library files that store 100, tool box,

rask, menu, and icon customizatdons
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MS_LINFILELIST specifies the directory containing line style fles

Raster

MS_RASTER_DISABLE_IPPCONNECTION if undefined, the default socket server port 1924
is used If defined, the socket port 1924 is ignored

MS_RASTER_VIEWSAVEASDWG controls whether the raster is displaved when exporting to
DWG

MS_RASTER_DEFAULT_LEVEL defines the level for raster elements when upgrading to
MicroStation XM Edition

MO_RASTER_TRANSPARENCY if set to 1, Raster Manager sets the background transparency
value; possible values are 0 to 255, where 255 is 100% wansparency.

Rendering /Images

MS_LOCAL_MATERIALS serves the same functon as the Copy Materials Locally On Use
roggle in the Setungs menu of the Material Editor dizlog box.

MS_DISABLE_RPCBROWSER If ser o 1, the RPC Thumbnadl Browser is disabled

Seed files

MS_DWGSEED_OVERRIDE seed file used o override MS_DWGSEED or the user-selecred
DWG seed file

MS_TRANSEED_OVERRIDE seed file used to override MS_TRANSEED or user-selecred
DGN seed file to be used for DWG open.

Un-categorized

MS_ALWAYSRELATIVEREFPATH if this variable is set to any value, MicroStation always turns
on the Save Relative Path toggle and disables it so that it cannot be turned off It will save

relative paths whenever possible.

MS_ANNOTATIONSCALEPROPAGATION conwols the propagation of a model's annotation
scale If ser to PROMPT, vou are prompred to accept or reject the propagatdon 1o existing
annotations If ser o ALWAYS, the scale will be automarically propagared If se: to NEVER,

the scale will not be propagated
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MS_AUTO_UPDATE_FIELDS controls the rules for updating fields in the acuve mode] If set
to ALWAY'S, the fields are always keprt up 1o date. If set vo NEVER, the fields are never
updated If nor set or set to FOLLOWMODELFLAG, the models Update Fields
Automatically field determines if fields are updated for thar model

MS,_DIMLEGACYPOINTORDER if set to 1, the dimensioning tools use the legacy data point
sequence for placing linear and angular dimensions (StartPoint — ExtensionPoint -

EndPain.

MS_DWG_LWDEFAULT controls the width of the default ine weight The default value is 0 for
urweighted default lines Vahd values are 0, 5, 9, 13, 15, 18, 20, 25, 30, 35, 40, 50, 53, 60, 70,
90, 100, 106, 120, 140, 158, 200, 211

MS_DWG_PROXYSHOW controls the display of proxy objects within a DWG drawing. Default
serting s 1, display complete graphics Set to 0 for no graphics and 2 for bounding box display

only

MS_NO_POSITION_MAPPING_HINTS if set to ), the keyboard navigational aids will not
display when <Esc> Is clicked.

MS_NOTEAUTOUPDATE controls the list of setrings that will be propagated 1o existing notes
when 2 dimension swle is saved To propagate all settings, set to All To control individual

sertings, list arributes in a comma-separated list
MS_SMARTSOLID specifies the directory path for the SmartSolid subsystem

MS_SNAPMODE_SOURCE if set to O {the default), MicroStaton saves the snap mode data to
the DGN file If set to 1, the dat is saved 1o the user pref file.

MS_SOURCENAME_PROPERTY if set, the SOURCE file property can be set to the name of
the source file. By defauly, only the name and extension of the source file are saved Setto Uto
disable the SOURCE property Set to FULL to save the full path of the source file.
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